Ubuntu

Japanese E-mobile D26HW (carrier customized Huawei UMTS modem) fails to connect (regression from karmic)

Reported by Rolf Leggewie on 2010-05-03
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
Ubuntu Japanese Kaizen Project
Undecided
Unassigned
gnome-ppp (Ubuntu)
Undecided
Unassigned
hal-info (Ubuntu)
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-ppp

Lucid introduced a regression either in gnome-ppp, wvdial or one of the packages that these two use for dialing. I have a D26HW USB stick which is essentially the widely known Huawei E220 UMTS/GSM modem. Mine works with the Japanese CDMA network from emobile.jp. Or more correctly, it stopped working in Lucid. While network-manager never made a successful connection (bug 359063), gnome-ppp did at least in Karmic. In Lucid I get "GNOME PPP: STDERR: --> No Carrier! Trying again." in the log for the exact same configuration. Please let me know if you need any further information.

current status:
gnome-ppp works
network-manager still doesn't

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-ppp 0.3.23-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Mon May 3 07:08:47 2010
EcryptfsInUse: Yes
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LC_MESSAGES=C
 LANG=de_DE.utf8
 LANGUAGE=en_US:en:de_DE
SourcePackage: gnome-ppp

Rolf Leggewie (r0lf) wrote :
Fumihito YOSHIDA (hito) on 2010-05-03
summary: - Japanese emobile-branded Huawei E220 (D26HW) fails to connect
- (regression from karmic)
+ Japanese E-mobile D26HW (carrier customized Huawei E220) fails to
+ connect (regression from karmic) in gnome-ppp
Fumihito YOSHIDA (hito) on 2010-05-03
summary: - Japanese E-mobile D26HW (carrier customized Huawei E220) fails to
+ Japanese E-mobile D26HW (carrier customized Huawei UMTS modem) fails to
connect (regression from karmic) in gnome-ppp

Hi Rolf,

I want to clear up, my guess are:
 - You have D26HW.
 - E220 is not D26HW(is D02HW).
 - D26HW is E176 based customized device(may be). but lsusb said " your usb modem is E220" :(
 - Huawei E220 and E176 are affiliated products.

# Notes: D02HW/D26HW has something modified by E-mobille, not only branded.
# IMHO, if we make no distinctions, we will get confusing.

And, Could you please test with https://bugs.launchpad.net/ubuntu/+source/linux/+bug/449394/comments/68 and network-manager ?

Rolf Leggewie (r0lf) wrote :

Here's the output of lsusb -v for the device

thank you for letting us know that the identification as E220 in that output is incorrect

Rolf Leggewie (r0lf) wrote :

and this is what shows up in syslog when I plug the device in

summary: Japanese E-mobile D26HW (carrier customized Huawei UMTS modem) fails to
- connect (regression from karmic) in gnome-ppp
+ connect with gnome-ppp (regression from karmic)

Yoshidaさん、

thank you for your help. I'd be happy if I just got this working with gnome-ppp (although I would prefer to use NM). The commands given in that command did not seem to change anything for me.

I wonder what package I should downgrade to try and get this working until a proper fix is out. I'm not sure this would be gnome-ppp itself.

Rolf Leggewie (r0lf) wrote :

I was wondering if this was a kernel bug. I booted my lucid system with 4 kernels: release and mainline for both lucid and karmic. No connection under any circumstance. I wonder what package has the regression. It doesn't seem to be the kernel.

Rolf Leggewie (r0lf) wrote :

FWIW, I was able to connect today (at least the status said 'connected') with gnome-ppp and the mainline kernel. Looks like another Ubuntu-introduced regression. I'll do some further testing and report back. I'm pretty much shooting in the dark, so any hints on where to look are appreciated.

Rolf Leggewie (r0lf) wrote :

gnome-ppp is currently the only way for me to connect via the Japanese ISP e-mobile

Rolf Leggewie (r0lf) wrote :

actually, this is fixed at least in the daily mainline kernel (for quite some time) and linux-image-2.6.32-22-generic. Connections from gnome-ppp work fine. I still fail to connect with network-manager, I think.

summary: Japanese E-mobile D26HW (carrier customized Huawei UMTS modem) fails to
- connect with gnome-ppp (regression from karmic)
+ connect (regression from karmic)
Changed in ubuntu-jp-improvement:
status: New → Fix Committed
Changed in gnome-ppp (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

yes, the kernel situation has been straightened out so that gnome-ppp can connect successfully. NM still fails to connect:

Jun 7 17:01:36 localhost NetworkManager: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Jun 7 17:01:36 localhost NetworkManager: <info> (ttyUSB0): device state change: 4 -> 6 (reason 0)
Jun 7 17:01:36 localhost NetworkManager: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Jun 7 17:01:37 localhost NetworkManager: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Jun 7 17:01:37 localhost NetworkManager: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Jun 7 17:01:37 localhost NetworkManager: <info> (ttyUSB0): device state change: 6 -> 4 (reason 0)
Jun 7 17:01:37 localhost NetworkManager: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Jun 7 17:01:37 localhost modem-manager: (ttyUSB0) opening serial device...
Jun 7 17:01:37 localhost modem-manager: Modem /org/freedesktop/ModemManager/Modems/2: state changed (disabled -> enabling)
Jun 7 17:01:37 localhost modem-manager: Modem /org/freedesktop/ModemManager/Modems/2: state changed (enabling -> enabled)
Jun 7 17:02:38 localhost NetworkManager: <WARN> stage1_prepare_done(): GSM modem connection failed: (32) Network timeout
Jun 7 17:02:38 localhost NetworkManager: <info> (ttyUSB0): device state change: 4 -> 9 (reason 1)
Jun 7 17:02:38 localhost NetworkManager: <info> Marking connection 'e-mobile Japan' invalid.
Jun 7 17:02:38 localhost NetworkManager: <info> Activation (ttyUSB0) failed.

Let me know if there is some way to collect better log information.

Can you apply this patch and test? I am sorry that I can not test it because I have no Huawei device here.

--- /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi->>2009-12-03 08:03:34.000000000 +0800
+++ /tmp/10-modem-e220cdma.fdi->2010-06-08 15:36:46.799098124 +0800
@@ -280,6 +280,7 @@
             <match <email address hidden>:usb.interface.class" int="0xff">
               <match <email address hidden>:usb.interface.subclass" int="0xff">
                 <match <email address hidden>:usb.interface.protocol" int="0xff">
+ <append key="modem.command_sets" type="strlist">IS-707-A</append>
                   <append key="modem.command_sets" type="strlist">GSM-07.07</append>
                   <append key="modem.command_sets" type="strlist">GSM-07.05</append>
                 </match>

Rolf Leggewie (r0lf) wrote :

Tyson, thank you for the patch. I will try to get you a response within the next hour. Otherwise, you'll have to wait until tomorrow.

affects: network-manager (Ubuntu) → hal-info (Ubuntu)
Rolf Leggewie (r0lf) wrote :

I applied the patch and rebooted (mainline kernel). But unfortunately, it doesn't seem to change anything.

description: updated
Rolf Leggewie (r0lf) wrote :

I'm back in a position where I can test this, including solutions put forward. FWIW, this still is unchanged in lucid. I'll set up a Maverick partition later.

possibly related bugs in NM:
bug 306552
bug 359063

from this and the upstream bugs I gather that NM is supposedly fixed for about a year, but that hal-info needs to be patched. Tyson, your patch went in that direction but unfortunately, the situation was still unresolved. Do you have a suggestion on how to proceed? I believe you'll reencounter this problem in your work, so I hope you have an interest to fix this ;-)

Rolf Leggewie (r0lf) wrote :

Chen, maybe yours is the right approach but the string is wrong?

Changed in network-manager:
importance: Unknown → Medium
status: Unknown → New
Changed in network-manager:
status: New → Incomplete
Rolf Leggewie (r0lf) wrote :

This stick now works correctly in Maverick. I tried backporting the maverick modemmanager package to lucid to see if that would enable the stick in lucid as well. Unfortunately, it didn't. Somebody more knowledgeable than me please help in finding out what needs to be backported to lucid for this to work.

Rolf,
Try to update usb-modeswitch with the package in debian. I will try to post
instructions about doing this later.

Changed in network-manager:
status: Incomplete → Confirmed
Rolf Leggewie (r0lf) wrote :

I updated both the modemmanager and the usb-modeswitch package to the maverick versions and now the stick works even in lucid. But not before I recreated the connection definition, it seems the old definition had some incorrect information (eye-balling for differences between the two showed nothing, though). Funnily enough, I was then even able to downgrade both packages back to the lucid versions and it still worked (until the next reboot, at least).

Mathieu, do you have an idea for a minimal patch to get the lucid version working?

Changed in network-manager:
status: Confirmed → Fix Released
Nobuto MURATA (nobuto) wrote :

According to the comment #16, no longer reproducible this issue on current release. I will mark as Fix Released against Ubuntu Japanese Kaizen Project.

Changed in ubuntu-jp-improvement:
status: Fix Committed → Fix Released

Rolf, I expect you should be able to get this to work by using just an updated usb-modeswitch on Lucid (not modemmanager), can you confirm you tried that?

I expect most of what's needed (aside from the recreation of profiles, which seems pretty unusual), is the modeswitch bits (so the modem is seen as a serial device/modem), and maybe the udev rules from Maverick's version of MM for which driver the modem should use.

Unfortunately, I don't have such a device so I can't help so easily.

Changed in network-manager (Ubuntu):
status: New → Incomplete
Rolf Leggewie (r0lf) wrote :

I'm currently not in Japan and I may no longer have a contract with e-mobile when I return. Not sure what I can do currently. It will be another month before I get physical access to the stick itself.

It's been a while since I fixed this for me which did not happen until I did all three of 1) upgrade modemmanager, 2) upgrade usb-modeswitch and 3) recreate connection definition. Of course, it may very well be that doing only 2+3 would be sufficient, but 1-3 is the order I did this in IIRC.

Nobuto, do you remember? Do you have contact with anyone that has such a stick and can test?

Nobuto MURATA (nobuto) wrote :

Hi Rolf,
unfortunately I don't know anyone using E-mobile D26HW around me. But then if I find them, I will ask for testing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.