network manger auto connect to every wireless network it sees

Bug #560802 reported by Usama Akkad on 2010-04-11
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
NetworkManager
Expired
Low
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

The problem:
network manger auto connect to every wireless network it sees if it's open and shows window to enter key if it's protected

to reproduce:
login to your system and you will find that network manger will try to connect to wireless network in every way possible

what should be:
network-manager should notify you of the availability of wireless networks and only connects automaticly when you chose to from configuration

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: network-manager 0.8-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic-pae 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic-pae i686
Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
CheckboxSubmission: 4190bdfb1b8df71969b6cbad70f1beb6
CheckboxSystem: 9c26adf6eed2f681ba41f94dd24c07e4
Date: Sun Apr 11 19:27:29 2010
EcryptfsInUse: Yes
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100113)
IpRoute:
 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.100 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
 default via 192.168.1.1 dev eth0 proto static
Keyfiles: Error: [Errno 2] No such file or directory
ProcEnviron:
 LANG=ar_SA.utf8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager

Usama Akkad (damascene) wrote :
Usama Akkad (damascene) wrote :

I've reported it upstream

Changed in network-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in network-manager:
status: Unknown → Incomplete
Changed in network-manager:
status: Incomplete → Invalid

Such as the outcome upstream, this is not a bug. Just after installing, NetworkManager will not automatically connect to any network, just report that some are available. On the other hand, if networks have already been configured (e.g. common names such as "linksys", "dlink", etc.) then NetworkManager will attempt to connect automatically if it has been connected once to an AP with this BSSID; bug this is standard roaming behavior.

Thanks for helping to make Ubuntu better!

Changed in network-manager (Ubuntu):
status: New → Invalid
Changed in network-manager:
importance: Unknown → Low
Changed in network-manager:
status: Invalid → New
Changed in network-manager:
status: New → Incomplete
Changed in network-manager:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.