Ubuntu

[ar9170usb] Wifi disconnects and doesn't reconnect until dongle replugged

Reported by Dominik on 2010-03-26
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
NetworkManager
Invalid
Unknown
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

This is on Ubuntu Lucid 10.04, updated with the latest packages as of yesterday, 25.03.2010. I commented on bug 525902 because I believe it's almost exactly what I'm seeing, but was told to file a new bug, so here it is.

The wifi card is a Netgear WNDA3100 USB dongle and the module for this is ar9170usb.

After a random amount of time (from a minute to a few hours) the card will disconnect from the AP, scanning will produce no more results and it will not work again until it is unplugged and replugged. Rebooting the computer does not solve the problem (I suppose unplugging the computer from the mains would work). The card normally has a blue diode and an orange diode lit up/blinking, these go off at the moment of disconnection and remain mostly off, with just the orange one lighting up occasionally.

It looks like the USB dongle's radio gets permanently locked up until power is removed.

The attached log should show that the card disconnects, NM tries to reconnect and fails and then many hours later I unplug and replug the USB dongle and it starts working again.

Uninstalling network-manager and network-manager-gnome, configuring wpa_supplicant by hand and starting it from the command line solves the problem immediately - I have another computer which had exactly the same problem run non-stop for 3 days now and the connection is rock-solid.

I installed the linux-backports-modules-wireless package, as well as downloaded and manually installed the latest compat-wireless package from linuxwireless.org a few days ago - these have had no positive effect.

ProblemType: Bug
Architecture: i386
Date: Fri Mar 26 21:56:53 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
IpRoute:

Keyfiles: Error: [Errno 2] No such file or directory
Package: network-manager 0.8-0ubuntu2
ProcEnviron:
 LANGUAGE=pl_PL:pl
 LANG=pl_PL.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
RfKill:
 1: phy1: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager
Uname: Linux 2.6.32-17-generic i686

Dominik (dominalien) wrote :
Dominik (dominalien) wrote :

Just a heads-up that this problem is not present on Karmic.

In Lucid, this is still present in Beta 2.

Dominik (dominalien) wrote :

Heh, not 15 minutes pass from my latest post and now the card has failed on Karmic in exactly the same way. This after running for more than 24 hours (which I've never attained in Lucid). So, the same problem exists in Karmic, although is perhaps less pronounced.

Gyorgyi Toth (tgyorgyi27) wrote :

I have a WG111V2 from Netgear, and had the same problem of failing in Karmic. In Lucid on the other hand (I tried B2 and now the final release) it does not work at all, Network Manager shows no wireless network at all.

Dominik (dominalien) wrote :

This is clearly a network manager problem. Uninstalling it and installing WICD (which has problems of its own, only different) solves the problem.

ngc2997 (ngc2997) wrote :

Is there anything one can do to assist solving this issue (apart from installing experimental packages - unfortunately not an option for me)? This is very annoying as I basically like to use the network manager for its convenient VPN features and its overall good usability; yet this issue renders it nearly unusable for me as I need to have a stable connection for working purposes (home office).

Btw: unloading and reloading ar9170usb does not work - device still seems to be locked afterwards; no scanning results, network manager shows "not connected" and does not list any wireless network either.

ngc2997 (ngc2997) wrote :

After having reported this to the NetworkManager developers in https://bugzilla.gnome.org/show_bug.cgi?id=620218, it turns out the issue might rather be related to the driver itself than to NetworkManager. This makes even more sense when considering that recently I ran across a disconnect when doing manual scans with iwlist for testing purposes - worked three or four times, then immediately after another scan the connection was lost and the device locked afterwards. This needs further testing (manual connection using wpa_supplicant without NetworkManager, and periodic scans with a shell script), but I am rather sure this is a driver / hardware issue.

Changed in network-manager:
status: Unknown → Incomplete
Dominik (dominalien) wrote :

Well, I tried talking to the Linux Wireless guys a while back, but was promptly ignored.

I guess this means it'll never gets fixed now :-(

ngc2997 (ngc2997) wrote :

This bug is definitely not related to NetworkManager. Running regular scans while having established a manually configured connection (wpa_supplicant) and no NetworkManager involved, the connection also died intermittently, leaving the wireless device unusable afterwards.

I have already filed a bug against bugzilla.kernel.org describing this specific issue, but so far to no effect; as far as I know, the developer of the ar9170usb module currently focuses on a replacement driver (still experimental though). This is actually sad news, as it means this issue probably won't be fixed in the near future, rendering an otherwise good wireless device useless.

Changed in network-manager:
status: Incomplete → Invalid
Savvas Radevic (medigeek) wrote :

marking this as a duplicate of bug 540827 (see comment #8)

Changed in network-manager (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.