NM | Edit Connections | Wired | Edit | IPv6 Settings | Method | "Shared to other computers" is greyed out

Bug #518890 reported by benste on 2010-02-08
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Wishlist
network-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: network-manager

Ipv4 shares are offered, if switching to ipv6 the choice is grayed

ProblemType: Bug
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Date: Mon Feb 8 17:11:46 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
IpRoute:
 192.168.2.0/24 dev wlan0 proto kernel scope link src 192.168.2.102 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.2.1 dev wlan0 proto static
Keyfiles: Error: [Errno 2] No such file or directory
Package: network-manager 0.8~rc2-0ubuntu1
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: network-manager
Uname: Linux 2.6.32-12-generic x86_64

benste (benste) wrote :
Emmet Hikory (persia) on 2010-03-10
tags: added: ipv6
benste (benste) wrote :

updates ? - looks like it's still not possible with 0.8.1

Thomas Hood (jdthood) wrote :

@benste: Hi. Can you please explain in more detail what goes wrong? Explain step by step how to reproduce the problem.

Does it still go wrong in Ubuntu 12.04?

Changed in network-manager (Ubuntu):
status: New → Incomplete
benste (benste) wrote :

open nm manager applet
create a new wired connection - or modfy existing one
in the IPv4 tab choose "shared to other computers"

→ successful ipv4 shared internet connection

----

try the same but use IPv6 instead of the ipv4 tab
→ the choicebox entry for shared is existant but greyed out without any further help

----

expectation ipv6 share should be as simple as ipv4

assumption - some backend is missing to provide IPv6 internet sharing
or - maybe a ipv6 connection is required ?

----

see screenshot

----

confirmed on 5 different machines varieng from 11.04 to 12.04

Changed in network-manager (Ubuntu):
status: Incomplete → Confirmed
Thomas Hood (jdthood) wrote :

Thanks for the extra information.

I see exactly the same thing on my laptop with Ubuntu 12.04.

Thomas Hood (jdthood) wrote :

I guess that this can be considered a wish that the greyed-out feature be made available.

summary: - Network Manager doesn't offer to share my connection if using IPv6
+ NM | Edit Connections | Wired | Edit | IPv6 Settings | Method | "Shared
+ to other computers" is greyed out
benste (benste) wrote :

:) well somehow yes and no ...

in my opnion taking a look at it as a professional system the option should either disapear, or be available - or mentioned in the package documentation that it needs the recommended dependency of xyz

i'd say it's a bug at the moment not just a wish - even though it has a low prioroty ..

Connection sharing for IPv6 is not yet supported; but the UI tends to be designed in the same way for both the IPv4 and IPv6 pages.

I agree, given that it's not supported/implemented yet, we should drop the item rather than greying it out. Triaged/Wishlist since it's such a minor cosmetic bug; 'bitesize' because it should be easy enough for anyone willing to prepare a patch for it.

Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
tags: added: bitesize

Found the upstream bug report for this.

benste (benste) wrote :

thanks a lot for the triage

Changed in network-manager:
importance: Unknown → Wishlist
status: Unknown → New
Changed in network-manager:
status: New → Confirmed
Changed in network-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.