Comment 27 for bug 509738

Downgrading modemmanager to 0.2.git.20100102t025215.a06b3f2-0ubuntu1~nmt1~karmic resolves the issue.