Lucid: GSM: PIN not being sent

Bug #509738 reported by Torsten Spindler on 2010-01-19
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
Baltix
Undecided
Unassigned
network-manager (Suse)
New
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

On Karmic network-manager and modem-manager from the PPA worked fine with a Sierra 3G card ( USB ID 1199:6813 ). On Lucid it seems that the PIN is not submitted.

The bug seems to be a regression in either modem-manager or networkmanager.

Karmic working version:
network-manager: Version: 0.8~rc1-0ubuntu1~nmt1~karmic
modemmanager: Version: 0.2.git.20100102t025215.a06b3f2-0ubuntu1~nmt1~karmic

Karmic broken version:
network-manager: 0.8~rc2-0ubuntu2~nmt4~karmic
modemmanager: 0.3-2~nmt1~karmic

STEPS to reproduce the problem:
Install latest network-manager and modemmanger from https://launchpad.net/~network-manager/+archive/trunk or latest available Lucid.
Select Edit Connections, add Mobile Broadband connection for D1, specify username and password and APN and PIN.
Connect to T-mobile (D1) connection 1
Applet icon starts spinning
Expected outcome: 3G connection established.
Actual outcome: 3G connection does not work. NM logs a warning in syslog that the PIN for the sim needs to be entered:
NetworkManager: <WARN> stage1_enable_done(): GSM modem enable failed: (32) SIM PIN required

The problem can be circumvented by using a sim card without PIN. Then nm/mm works just fine.

Torsten Spindler (tspindler) wrote :
Torsten Spindler (tspindler) wrote :
Torsten Spindler (tspindler) wrote :
Torsten Spindler (tspindler) wrote :

The HAL configuration in Karmic:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- xml -*- -->

<deviceinfo version="0.2">
<device>
<match key="info.category" string="serial">

<!-- 2x MC8755,MC8765,MC8775 & AC 875U,MC8775,AirCard 875,MC8780,MC8781, AirCard MC8790, AirCard 880,AirCard 881,AirCard 880 E,AirCard 881 E, Aircard 880 U, AirCard 881 U, Aircard 885 E, Aircard 885 E, C885, 0x6890, 0x6891, 0x6892 -->
<match <email address hidden>:usb.product_id" int_outof="0x6802;0x6804;0x6803;0x6812;0x6813;0x6820;0x6832;0x6833;0x683c;0x6850;0x6851;0x6852;0x6853;0x6855;0x6856;0x6859;0x685a;0x6880;0x6890;0x6891;0x6892">
<match <email address hidden>:usb.interface.number" int="0">
<match key="serial.port" int="2">
<append key="modem.command_sets" type="strlist">GSM-07.07</append>
<append key="modem.command_sets" type="strlist">GSM-07.05</append>
</match>
</match>
</match>
</match>

</device>
</deviceinfo>

Tony Espy (awe) wrote :

@Torsten

Can you add some more details? Which PPA / version of MM?

Also, HAL was removed as a MM dependency much before Karmic, see the following commit from the MM git tree:

commit 924814c101da42fcb53005691d136852653f0eae
Author: Dan Williams <email address hidden>
Date: Thu Jun 18 14:25:30 2009 -0400

    udev: move device probing and detection to udev

    Get rid of dependency on HAL, using libgudev instead. Fix up the plugin API
    to no longer use either HAL or udev defines, but let plugins use whatever
    mechanism they want for getting more information out of the device given the
    subsystem and device node name.

Tony Espy (awe) wrote :

That said, I'm working on an upload of the latest tagged version of MM ( 0.2.997 ) for Lucid. This should land tomorrow, if all goes well.

Torsten Spindler (tspindler) wrote :

@ Tony: I've used the PPA specified on https://wiki.ubuntu.com/DebuggingModemmanager: https://launchpad.net/~network-manager/+archive/trunk

As HAL was removed from MM before Karmic, the same code that works on Karmic should work on Lucid right now?
@ Dominik: Can you test that?

Torsten Spindler (tspindler) wrote :

Update to the latest modemmanager and network-manager on Lucid:

ii modemmanager 0.2.git.201001 D-Bus service for managing modems
Version: 0.2.git.20100119t230703.ed885b7-0ubuntu1~nmt1~jaunty

ii network-manage 0.8~rc2-0ubunt network management framework daemon
Version: 0.8~rc2-0ubuntu1

It seems the PIN is no longer served to the simcard:

Jan 21 11:37:18 lvm-laptop NetworkManager: <WARN> stage1_enable_done(): GSM modem enable failed: (32) SIM PIN required

Output in /var/log/syslog is attached.

Torsten Spindler (tspindler) wrote :

Further testing resulted in the finding that manually setting the PIN via cutecom works for establishing a connection.

@ Torsten

It seems you've got things working. Would you mind changing the status to Invalid please?

summary: - [regression] ModemManager from PPA not working in Lucid
+ ModemManager from PPA not working in Lucid
Torsten Spindler (tspindler) wrote :

@Tony
Unfortunately the PIN is not set automatically as in Karmic, so there is still a regression from the perfectly working solution in Karmic to one where you need bandaid via cutecom. As this bug affects a large roll out of several thousand machines, I'll leave the bug open for further investigation.

Torsten Spindler (tspindler) wrote :

Here the debug output from modem manager:

** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
** (modem-manager:1994): DEBUG: (ttyUSB2): --> 'ATZ E0 V1 +CMEE=1<CR>'
** (modem-manager:1994): DEBUG: (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:1994): DEBUG: (ttyUSB2): --> 'ATE0 +CMEE=1<CR>'
** (modem-manager:1994): DEBUG: (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:1994): DEBUG: (ttyUSB2): --> 'ATX4 &C1<CR>'
** (modem-manager:1994): DEBUG: (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:1994): DEBUG: (ttyUSB2): --> 'AT+CREG=0<CR>'
** (modem-manager:1994): DEBUG: (ttyUSB2): <-- '<CR><LF>ERROR<CR><LF>'
** (modem-manager:1994): DEBUG: Got failure code 100: Unknown error
** (modem-manager:1994): DEBUG: (ttyUSB2): --> 'AT+CFUN=1<CR>'
** (modem-manager:1994): DEBUG: (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> enabled)
** (modem-manager:1994): DEBUG: (ttyUSB2): --> 'AT+CPIN?<CR>'
** (modem-manager:1994): DEBUG: (ttyUSB2): <-- '<CR><LF>+CPIN: SIM PIN<CR><LF><CR><LF>OK<CR><LF>'
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabled -> disabled)

Torsten Spindler (tspindler) wrote :

NM debug output:

NetworkManager: <info> Activation (ttyUSB2) starting connection 'LVM-Mobil'
NetworkManager: <info> (ttyUSB2): device state change: 3 -> 4 (reason 0)
NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <info> (ttyUSB2): device state change: 4 -> 3 (reason 0)
NetworkManager: <info> (ttyUSB2): deactivating device (reason: 0).
NetworkManager: <info> Policy set 'Auto mosquito' (wlan0) as default for routing and DNS.
NetworkManager: <WARN> stage1_enable_done(): GSM modem enable failed: (32) SIM PIN required
NetworkManager: <info> (ttyUSB2): device state change: 3 -> 9 (reason 0)
NetworkManager: <info> Activation (ttyUSB2) failed.
NetworkManager: <info> (ttyUSB2): device state change: 9 -> 3 (reason 0)
NetworkManager: <info> (ttyUSB2): deactivating device (reason: 0).
NetworkManager: <info> Policy set 'Auto mosquito' (wlan0) as default for routing and DNS.

description: updated
Torsten Spindler (tspindler) wrote :
Download full text (6.0 KiB)

For the record, here the syslog output on Karmic:

 Jan 22 17:42:54 wm0830 NetworkManager: <info> Activation (ttyUSB2) starting connection 'LVM-Mobil'
Jan 22 17:42:54 wm0830 NetworkManager: <info> (ttyUSB2): device state change: 3 -> 4 (reason 0)
Jan 22 17:42:54 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
Jan 22 17:42:54 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
Jan 22 17:42:54 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
Jan 22 17:42:54 wm0830 modem-manager: (ttyUSB2) opening serial device...
Jan 22 17:42:54 wm0830 modem-manager: Modem /org/freedesktop/ModemManager/Modems/1: state changed (disabled -> enabling)
Jan 22 17:42:54 wm0830 modem-manager: Got failure code 100: Unknown error
Jan 22 17:42:54 wm0830 modem-manager: Modem /org/freedesktop/ModemManager/Modems/1: state changed (enabling -> enabled)
Jan 22 17:43:05 wm0830 modem-manager: Modem /org/freedesktop/ModemManager/Modems/1: state changed (enabled -> disabled)
Jan 22 17:43:05 wm0830 modem-manager: Registration state changed: 2
Jan 22 17:43:05 wm0830 modem-manager: Modem /org/freedesktop/ModemManager/Modems/1: state changed (disabled -> searching)
Jan 22 17:43:10 wm0830 modem-manager: Registration state changed: 1
Jan 22 17:43:10 wm0830 modem-manager: Modem /org/freedesktop/ModemManager/Modems/1: state changed (searching -> registered)
Jan 22 17:43:10 wm0830 modem-manager: Modem /org/freedesktop/ModemManager/Modems/1: state changed (registered -> connecting)
Jan 22 17:43:10 wm0830 modem-manager: Modem /org/freedesktop/ModemManager/Modems/1: state changed (connecting -> connected)
Jan 22 17:43:10 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 2 of 5 (Device Configure) scheduled...
Jan 22 17:43:10 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 2 of 5 (Device Configure) starting...
Jan 22 17:43:10 wm0830 NetworkManager: <info> (ttyUSB2): device state change: 4 -> 5 (reason 0)
Jan 22 17:43:10 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 2 of 5 (Device Configure) successful.
Jan 22 17:43:10 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 3 of 5 (IP Configure Start) scheduled.
Jan 22 17:43:10 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 2 of 5 (Device Configure) complete.
Jan 22 17:43:10 wm0830 NetworkManager: <info> Activation (ttyUSB2) Stage 3 of 5 (IP Configure Start) started...
Jan 22 17:43:10 wm0830 NetworkManager: <info> (ttyUSB2): device state change: 5 -> 7 (reason 0)
Jan 22 17:43:10 wm0830 NetworkManager: <info> Starting pppd connection
Jan 22 17:43:10 wm0830 NetworkManager: <debug> [1264178590.143451] nm_ppp_manager_start(): Command line: /usr/sbin/pppd nodetach lock nodefaultroute user itu002 ttyUSB2 noipdefault noauth refuse-eap refuse-pap refuse-mschap refuse-mschap-v2 usepeerdns lcp-echo-failure 0 lcp-echo-interval 0 ipparam /org/freedesktop/NetworkManager/PPP/0 plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so
Jan 22 17:43:10 wm0830 NetworkManager: <debug> [1264178590.155159] nm_ppp_manager_start(): ppp started with pid 2614
Jan 22 17:43:10 wm0830 NetworkManager: <info> ...

Read more...

Torsten Spindler (tspindler) wrote :

The modem manager log from Karmic.

This is the first difference between the one on Lucid and Karmic:

Karmic:
** (modem-manager:2763): DEBUG: (ttyUSB2): --> 'AT+CREG=0<CR>'
** (modem-manager:2763): DEBUG: (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'

Lucid:
** (modem-manager:1994): DEBUG: (ttyUSB2): --> 'AT+CREG=0<CR>'
** (modem-manager:1994): DEBUG: (ttyUSB2): <-- '<CR><LF>ERROR<CR><LF>'
** (modem-manager:1994): DEBUG: Got failure code 100: Unknown error

Tony Espy (awe) wrote :

@ Torsten

A couple of questions...

Can you add more details including, 3g modem manufacturer and model number, steps to reproduce, etc...

It sounds like what you've described is that you've created a new 3G connection that includes a PIN via NM's UI, but that the PIN is not being sent to the provider, so...you need to manually set the PIN using cutecom.

Can you try the newest versions of NM, -applet, and MM from the NM daily trunk PPA? These versions were all uploaded to Lucid yesterday. There's a possibility they may get released as an SRU, but I can't promise anything yet...

https://launchpad.net/~network-manager/+archive/trunk

Torsten Spindler (tspindler) wrote :

It's a Sierra 3G card, USB ID 1199:6813. Details are attached.

Torsten Spindler (tspindler) wrote :

For the connection info I was not using the NM GUI, I use the same configuration file as for Karmic. I cannot share this globally, but if of interest to you, I can send it by private email.

Torsten Spindler (tspindler) wrote :

Using todays modem-manager build nothing changes. Still after AT+CREG=0 I see an ERROR.

Tony Espy (awe) wrote :

Can you please clarify what you tested? Did you upgrade NM, the applet, and MM?

Thanks for the info re: the separate configuration. Please email the details.

Tony Espy (awe) wrote :

@Torsten

One more question... I realize your normal use case is a static configuration file on disk, however can you please try to reproduce the issue with the NM GUI? The upgrade from NM 0.7 to NM 0.8 involved a couple of major changes including getting rid of HAL, and also moving to MM ( vs. NM 0.7 handling 3g directly ).

Torsten Spindler (tspindler) wrote :

The versions on Karmic that work:
network-manager: Version: 0.8~rc1-0ubuntu1~nmt1~karmic
modemmanager: Version: 0.2.git.20100102t025215.a06b3f2-0ubuntu1~nmt1~karmic

Torsten Spindler (tspindler) wrote :

The version on Lucid that do not work:
network-manager: Version: 0.8~rc2-0ubuntu2~nmt3
modemmanager: Version: 0.3-0ubuntu2~nmt2

Torsten Spindler (tspindler) wrote :

I went ahead and created a manual connection, using the settings from the static configuration. The same error and problem occurred.

Torsten Spindler (tspindler) wrote :

On karmic I installed the latest modemmanager and network-manager packages from the PPA https://launchpad.net/~network-manager/+archive/trunk and it is broken there too.

Version on karmic not running:
network-manager: 0.8~rc2-0ubuntu2~nmt4~karmic
modemmanager: 0.3-2~nmt1~karmic

description: updated
Id2ndR (id2ndr) wrote :

Same behaviors for me. I tried both the versions of lucid and network manager's PPA.*

The reveling lines of debugging outputs :

sudo modem-manager --debug
[..]
** Message: (ttyUSB2) opening serial device...
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
** (modem-manager:7473): DEBUG: (ttyUSB2): --> 'ATE0 V1<CR>'
** (modem-manager:7473): DEBUG: (ttyUSB2): <-- '<CR><LF>OK<CR><LF>'
** (modem-manager:7473): DEBUG: (ttyUSB2): --> 'AT+CPIN?<CR>'
** (modem-manager:7473): DEBUG: (ttyUSB2): <-- '<CR><LF>+CPIN: SIM PIN<CR><LF><CR><LF>OK<CR><LF>'
** Message: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> disabled)
[..]

sudo NM_PPP_DEBUG=1 /usr/sbin/NetworkManager --no-daemon
[..]
NetworkManager: <info> Activation (ttyUSB2) starting connection 'SFR 3G+'
NetworkManager: <info> (ttyUSB2): device state change: 3 -> 4 (reason 0)
NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <WARN> stage1_enable_done(): GSM modem enable failed: (32) SIM PIN required
NetworkManager: <info> (ttyUSB2): device state change: 4 -> 9 (reason 0)
NetworkManager: <info> Marking connection 'SFR 3G+' invalid.
NetworkManager: <info> Activation (ttyUSB2) failed.
NetworkManager: <info> (ttyUSB2): device state change: 9 -> 3 (reason 0)
NetworkManager: <info> (ttyUSB2): deactivating device (reason: 0).
[..]

Torsten Spindler (tspindler) wrote :

Downgrading modemmanager to 0.2.git.20100102t025215.a06b3f2-0ubuntu1~nmt1~karmic resolves the issue.

Torsten Spindler (tspindler) wrote :

The bug seems to be fixed in the latest version, see attached 'home made' package.

Tested the 'home made' package:

525020@nc0631:~$ sudo tail -f /var/log/syslog
Feb 1 17:37:51 nc0631 NetworkManager: <info> (ttyUSB2): deactivating device (reason: 0).
Feb 1 17:37:51 nc0631 NetworkManager: <info> Clearing nscd hosts cache.
Feb 1 17:37:51 nc0631 NetworkManager: <info> Policy set 'Auto eth0' (eth0) as default for routing and DNS.
Feb 1 17:37:51 nc0631 NetworkManager: <WARN> stage1_enable_done(): GSM modem enable failed: (32) SIM PIN required
Feb 1 17:37:51 nc0631 NetworkManager: <info> (ttyUSB2): device state change: 3 -> 9 (reason 0)
Feb 1 17:37:51 nc0631 NetworkManager: <info> Activation (ttyUSB2) failed.
Feb 1 17:37:51 nc0631 NetworkManager: <info> (ttyUSB2): device state change: 9 -> 3 (reason 0)
Feb 1 17:37:51 nc0631 NetworkManager: <info> (ttyUSB2): deactivating device (reason: 0).
Feb 1 17:37:51 nc0631 NetworkManager: <info> Clearing nscd hosts cache.
Feb 1 17:37:51 nc0631 NetworkManager: <info> Policy set 'Auto eth0' (eth0) as default for routing and DNS.

m525020@nc0631:~$ dpkg-query -W modemmanager
modemmanager 0.3-1ubuntu1

So it does not fix the problem for me.

Tony Espy (awe) wrote :

@Torsten

We should make sure to use "~" versions when re-building an existing Ubuntu version of a package. So, if you're building this for Karmic, then something like:

0.3-0ubuntu1~karmic

or

0.3~0ubuntu1~karmic~tetet

Doing so allows the *true* version to install if the system were to upgrade to Lucid for instance. FYI, I'll try and get this version pushed into the main NM PPA. It looks like only NM and the -applet were pushed there last week.

Torsten Spindler (tspindler) wrote :

@Tony

Understood, sorry for the confusion.

Seems that the new version does _not_ fix the problem. Here is what I observed so far:

Installing modem-manager 0.2.git.20100102t025215.a06b3f2-0ubuntu1~nmt1~karmic and network-manager 0.8~rc1-0ubuntu1~nmt1~karmic lets the problem disappear. After that when installing an updated network-manager and modemmanager, the modem continues to work until the kill switch is used. After using the kill switch once, the problem occurs again.

Please note that I observed the above behavior exactly once.

Torsten Spindler (tspindler) wrote :

I try to build an old version of modemmanager the following way and fail:

$ bzr branch http://bazaar.launchpad.net/~modemmanager/modemmanager/ubuntu/ mm
$ cd mm
$ bzr revert -r 63
 M debian/changelog
 M debian/compat
 M debian/control
 M debian/copyright
 M debian/patches/series
 M debian/rules
$ bzr bd --merge --dont-purge --builder='debuild -uc -us -b'
Building using working tree
Running in merge mode
Looking for a way to retrieve the upstream tarball
Using apt to look for the upstream tarball.
apt could not find the needed tarball.
Trying to use get-orig-source to retrieve needed tarball.
set -e; tmpdir=`mktemp -d -t`; cd $tmpdir; echo "cloning upstream repository ..."; git clone git://anongit.freedesktop.org/ModemManager/ModemManager; echo "getting specific upstream revision/tag: "master""; cd `ls | head -n 1`; git checkout -b orig "master"; commit_id=`git log -n1 --abbrev-commit | grep '^commit ' | sed -e 's/commit //'`; raw=`date --utc --date="$(git log --pretty=fuller -n1 --date=rfc | grep CommitDate: | sed -e 's/CommitDate:[^0-9]*//')" "+%Y%m%dt%H%M%S"`; if echo "master" | grep -c "orig" > /dev/null || echo 0.2.git.20091208t060758.07114d4-0ubuntu1 | grep -c "git" > /dev/null; then upstream_version=0.2.git.$raw.$commit_id; else upstream_version=0.2.git.20091208t060758.07114d4; fi; cd ..; tar --exclude=.git -czf /tmp/builddeb-get-orig-source-nT7a3v/export/modemmanager_$upstream_version.orig.tar.gz `ls | head -n 1`; cd /tmp/builddeb-get-orig-source-nT7a3v/export; rm -rf $tmpdir;
cloning upstream repository ...
Initialized empty Git repository in /tmp/tmp.hlc7MLgbIr/ModemManager/.git/
remote: Counting objects: 2279, done.
remote: Compressing objects: 100% (769/769), done.
remote: Total 2279 (delta 1742), reused 1928 (delta 1500)
Receiving objects: 100% (2279/2279), 602.56 KiB | 54 KiB/s, done.
Resolving deltas: 100% (1742/1742), done.
getting specific upstream revision/tag: master
Switched to a new branch 'orig'
get-orig-source did not create modemmanager_0.2.git.20091208t060758.07114d4.orig.tar.gz
No watch file to use to retrieve upstream tarball.
bzr: ERROR: Unable to find the needed upstream tarball: modemmanager_0.2.git.20091208t060758.07114d4.orig.tar.gz.

Tony Espy (awe) wrote :

Hmm, something seems to be wrong with the MM debian/rules. I get the same failure.

Try this the following to generate the correct tarball:

% ./debian/rules get-current-source

That should do the trick.

Torsten Spindler (tspindler) wrote :

More testing with older and recent modemmanager revealed that the problem is more likely in network-manager:

Non working modem-manager
install modemmanager_0.2.git.20100102t025215.a06b3f2-0ubuntu1~nmt1~karmic_i386.deb
reboot
3G connection not working
install network-manager_0.8~rc1-0ubuntu1~nmt1~karmic_i386.deb
reboot
3G connection working
=======
Non working modem-manager
install self built modemmanager_0.3-0ubuntu1_i386.deb
install network-manager_0.8~rc1-0ubuntu1~nmt1~karmic_i386.deb
reboot
3G connection working
kill switch
3G connection working
=======
Non working modem-manager
install modemmanager_0.3-1ubuntu1+tetet_i386.deb
install network-manager_0.8~rc1-0ubuntu1~nmt1~karmic_i386.deb
reboot
3G connection working
kill switch
3G connection working

All the time the old network-manager had to be installed.

Torsten Spindler (tspindler) wrote :

Working network-manager

Torsten Spindler (tspindler) wrote :

I discovered a problem in my earlier test: there was still a modem-manager binary used from /usr/local/sbin. Hence the testing proofed nothing. However, a new test revealed that the current Lucid mm works with the old Karmic nm:

network-manager: 0.8~rc1-0ubuntu1~nmt1~karmic
modemmanager: 0.3-0ubuntu2

My current hypothesis is that something broke in network-manager.

description: updated
Tony Espy (awe) wrote :

@Torsten

You're missing the steps between install nm/mm packages and "Expected result".

E.g.

1. Created a new NM connection via "Edit Connections : Mobile Broadband tab - entered the following values..."
2. Selected new connection from the NM applet menu
3. Applet icon started spining, eventually went back to disconnected icon
4. etc...

description: updated
description: updated
description: updated
Torsten Spindler (tspindler) wrote :

Just tested the latest modemmanager from PPA with old network-manager for karmic on Lucid and 3G works.

Working:
network-manager: 0.8~rc1-0ubuntu1~nmt1~karmic
modemmanager: 0.3-2~nmt1

Torsten Spindler (tspindler) wrote :

Without PIN the new network-manager and modemmanager is working.

Working without PIN:
network-manager: 0.8~rc2-0ubuntu2~nmt4
modemmanager: 0.3-2~nmt1

summary: - ModemManager from PPA not working in Lucid
+ NetworkManager/ModemManager from PPA not working in Lucid, PIN cannot
+ entered
summary: - NetworkManager/ModemManager from PPA not working in Lucid, PIN cannot
- entered
+ NetworkManager/ModemManager from PPA not working in Lucid, PIN does not
+ work
description: updated
Tony Espy (awe) on 2010-02-06
Changed in network-manager (Ubuntu):
status: New → Confirmed

Fixed in lucid with network-manager 0.8~rc3-0ubuntu1~nmt1

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
Id2ndR (id2ndr) wrote :

I changed the status to "fix commited" because it is only in the NM's PPA. It's not a real "fix commited" because it has not landed in Luncid yet.

Torsten Spindler (tspindler) wrote :

Not fixed for me, connection still not established.

Changed in network-manager (Ubuntu):
status: Fix Committed → Confirmed
Alexander Sack (asac) wrote :

feels like a regression from the UI backouts. Tony/Matt, Maybe lets drop those patches and see if that fixes the ppa again.

Tony Espy (awe) wrote :

@ld2ndR

When marking a bug FixCommitted, it's generally best practice to include the commit you think resolved the issue in a comment.

I looked over the commits for 0.8-rc3 in both network-manager, and the -applet, and didn't see any obvious fix candidates.

FYI, I've prepared new uploads for Lucid, but haven't yet done release commits. The new versions will be:

network-manager -- 0.8~rc3-0ubuntu1
network-manager-applet -- 0.8~rc2-0ubuntu2 ( UI revert patches dropped )

@Torsten

I uploaded Lucid versions of both of these to my personal PPA, if you want to try them out.

Id2ndR (id2ndr) wrote :

Sorry I was wrong. In fact I tried to connect after doing these updates :
[MIS A JOUR] libnm-glib2 0.8~rc2-0ubuntu2~nmt4 -> 0.8~rc3-0ubuntu1~nmt1
[MIS A JOUR] libnm-util1 0.8~rc2-0ubuntu2~nmt4 -> 0.8~rc3-0ubuntu1~nmt1
[MIS A JOUR] network-manager 0.8~rc1-0ubuntu1~nmt1~karmic -> 0.8~rc3-0ubuntu1~nm
t1
[MIS A JOUR] network-manager-gnome 0.8~rc2-0ubuntu2~nmt2 -> 0.8~rc2-0ubuntu2~nmt
3

Today I tried to reconnect and it didn't work. So I watch trough my aptitude log to check if there was an other update that may explained was it worked one time and... I didn't found anything interesting. The reason why it worked should be because I didn't restart the applet, NM daemon and modem-manager so I should still have been using the working part of nm-rc1. I read in the aptitude log that nm service restarted but maybe not everything fully restarted.

As you just explain to me Tony Espy, next time I'll check for the commit that may fix the bug and report it. I'll also prevent you for wasting your time because of my mistake.

Torsten Spindler (tspindler) wrote :

@ Tony

I tried your packages, but they don't work :(

Tony Espy (awe) wrote :

commit 21242568a6191a6c8067bf5af42135d21c5dac41
Author: Dan Williams <email address hidden>
Date: Mon Feb 8 13:16:14 2010 -0800

    gsm: handle PIN requests during modem enable too (bgo #609197)

    Fix a regression after f61af8e139a35cfa52e443fdc66ad4c05851085f where
    a PIN request while enabling the modem wouldn't properly make NM
    request secrets from the settings service.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Committed
summary: - NetworkManager/ModemManager from PPA not working in Lucid, PIN does not
- work
+ Lucid: GSM: PIN not being sent
Tony Espy (awe) wrote :

@Torsten

Please test so I can let Dan know his fix worked. Thanks!

Torsten Spindler (tspindler) wrote :

Unfortunately the fix does not work, a similar log is generated, but network-manager also gets an abort signal:

Feb 9 09:54:57 lvm-laptop NetworkManager: <WARN> stage1_enable_done(): GSM modem enable failed: (32) SIM PIN required
Feb 9 09:55:01 lvm-laptop init: network-manager main process (1173) killed by ABRT signal
Feb 9 09:55:01 lvm-laptop init: network-manager main process ended, respawning

Attached is the complete syslog from the system.

Tony Espy (awe) wrote :

@Torsten

Can you get a stack trace for NM?

In case it can be useful; https://bugs.edge.launchpad.net/ubuntu/+source/network-manager/+bug/507700/comments/3 mentions start nm-connection-editor as root and re-entering the PIN.

Dan Williams (dcbw) wrote :

Finally able to reproduce the crash with a Sierra device; the problem is specific to certain plugins where the PIN check takes a while to happen (because the CFUN needs time to complete). Because the PIN check fails during the Enable() call, ModemManager will move the device from enabling -> disabled state, and that changes the Enabled property to FALSE, upon which NetworkManager would deactivate the device. That's bad since we want to move the device to NEED_AUTH and ask for the PIN. But since the device was already deactivated when the Enable() call reply came through, the g_assert () in handle_enable_pin_required() would fire.

I've pushed a number of updates to NM and nm-applet to fix various bugs I found while investigating this problem, but there's still one issue with nm-applet I have to fix tomorrow. Setting a PIN in the connection itself should work fine now, but entering the PIN through the PIN request dialog will fail if you have a username set on the connection (which is what I still have to fix).

Torsten Spindler (tspindler) wrote :

Establishing the 3G connection works again with this version from the PPA:
network-manager: 0.8~rc4~git.20100210t075026.096f87e-0ubuntu1~nmt1
modem-manager: 0.3-2~nmt1

Thanks for all your hard work on resolving this issue!

Torsten Spindler a écrit :
> Establishing the 3G connection works again with this version from the PPA:
> network-manager: 0.8~rc4~git.20100210t075026.096f87e-0ubuntu1~nmt1
> modem-manager: 0.3-2~nmt1
>
> Thanks for all your hard work on resolving this issue!
I can confirm it now works for me too (I haven't look for the commit but
it's already know according to previous comments).

Any chance the fix will get to Karmic, too?

Id2ndR (id-2ndr) wrote :

> Any chance the fix will get to Karmic, too

According my knoledge, it always has been working on karmic. Is it a
trouble that occured to you after doing some updates ?

It never worked for me on Karmic.

But I updated these packages from Lucid and it started to work - a bit of strain for average users though.

Torsten Spindler (tspindler) wrote :

On Thu, 2010-02-18 at 17:33 +0000, TomaszChmielewski wrote:
> It never worked for me on Karmic.

There was a version of network-manager in the PPA that worked for
Karmic.

Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Fix Released
Peter Magnusson (kmpm) wrote :

This seems to happen in Maverick as well.
If I disable PIN for the simcard it works but not else.
Anyone else noticed this.

Mantas Kriaučiūnas (mantas) wrote :

ZTE MF628 3G modem doesn't connect from network-manager applet until I disable PIN code in SIM card.
Network manager applet doesn't ask PIN code at all :(
Should I report separate bug for this issue?

Thomas Hood (jdthood) on 2012-07-10
Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.