"Available to all users" is greyed out

Bug #470049 reported by Brian J. Murrell on 2009-11-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

In Karmic, the "Available to all users" options (for wireless connections at least -- I have not check any other type of connections) is greyed out. How am I supposed to make a "system" connection out of a per-user one with this option greyed out?

BTW: I was going to send you the output of ubuntu-bug network-manger as it looked very useful to you, however, you are leaking the WPA secrets that I have in (commented out sections of) /etc/network/interfaces.

Once again, I must advocate for the item-by-item editing or removal entirely of items in apport reports.

Brian,

I can't reproduce your bug at the moment -- when I start to create a new wireless connection, the "Available to all users" checkbox is indeed greyed out, but as soon as I enter an SSID, it becomes sensitive. Just for kicks, if this is for an existing connection, have you tried to edit and re-enter the contents of the SSID field?

Also, I believe you should be able to use 'apport-collect 470049' without too much trouble w.r.t leaked WPA secrets for example, if you want to quickly provide us with additional data about the version numbers of the network-manager packages you are running.

Changed in network-manager (Ubuntu):
status: New → Incomplete

This is happening for me with wired connections also. The only way I can create a wired connection that is available to all users is if I do "gksudo nm-connection-editor"

Carl-Erik Kopseng (kopseng) wrote :

This is happening for me with a 9.04 install too. I tried running the steps in a guide for automatically setting up wifi (http://ubuntuforums.org/showthread.php?p=7626685) when I found out the checkbutton "Available to all users" was greyed out.

I have a 10.04 install on my laptop where it functions perfectly.

The only reason I can come up with for this to work for some people and not for others is that it might be due to distribution upgrades. My server (where I have this problem) have been going through the motions of upgrading all the way from 2007-2010. That might leave some crust behind ...

Carl-Erik Kopseng (kopseng) wrote :

Whoops, I meant it was happening on a 9.10 install. I am trying to upgrade my server to 10.04 now, just to see if should change anything for the better, but I am not very confident it will, given that it should have worked 3 distribution generations ago ...

Launchpad Janitor (janitor) wrote :

[Expired for network-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in network-manager (Ubuntu):
status: Incomplete → Expired

This happens to me as well.
I've checked /etc/NetworkManager/system-connections :it's on place.
I've deleted all config files related to nm (the users files as well), no luck!
User seems to have neccessary privileges ("network connections admin").
I'm stuck.

Changed in network-manager (Ubuntu):
status: Expired → Confirmed
tags: added: natty
JW (tykho) wrote :

I was having trouble with the password not being remembered when I ran some other window manager (like pekwm, wmii) other than the default DE's for ubuntu or xubuntu (gnome and xfce).

I did what Mathieu Trudel-Lapierre said in the first post, and disconnected, removed it from wireless connections and created a new one. When I entered the SSID the checkbox became clickable, greyed out again when choosing wpa2, but clickable again when entering the info. I saved it, and now it is being remembered.

Thomas Hood (jdthood) wrote :

@Brian: Can you reproduce this in Ubuntu 12.04?

summary: - Available to all users is greyed out
+ "Available to all users" is greyed out
Changed in network-manager (Ubuntu):
status: Confirmed → Incomplete

On 12-07-13 05:12 PM, Thomas Hood wrote:
> @Brian: Can you reproduce this in Ubuntu 12.04?

Hrm. I guess not. But TBH, I am using Cinnamon on Linux Mint's Maya,
which is leveraging Ubuntu 12.04. So I am not entirely sure if the
network configuration interface is the same any more.

Launchpad Janitor (janitor) wrote :

[Expired for network-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in network-manager (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers