Ubuntu

Hidden SSID WLAN doesn't work under Ubuntu.9.10 at all

Reported by Kris on 2009-11-01
118
This bug affects 20 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Mello
Nominated for Lucid by Mello

Bug Description

Hi,
I've recently upgraded to Karmic.

Hardware is OK - Lenovo ThinkPad T500, dual boot Ubuntu/Vista.
Under Vista everything working fine.
Under Ubuntu I'm unable to connect to my home wireless network which has hidden SSID and WPA-PSK/TKIP password.
If I change the router settings to enable the SSID broadcast, then Ubuntu has no problems with this WiFi connection - same password/WPA-PSK.

Thus, I assume, that the problem is only about connecting to hidden SSID networks with WPA-PSK/TKIP passwords.
I know, that hidden SSID is not helping to much with security, but I still want to have SSID broadcasting turned-off.

Could you please advise, how to solve the problem?

Thank you in advance.

Regards,
Kris

P.S.
From my dmesg:
[ 11.319473] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27k
[ 11.319477] iwlagn: Copyright(c) 2003-2009 Intel Corporation
[ 11.319964] iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 11.319974] iwlagn 0000:03:00.0: setting latency timer to 64
[ 11.320195] iwlagn 0000:03:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
[ 11.356720] iwlagn 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[ 11.356784] alloc irq_desc for 32 on node 0
[ 11.356786] alloc kstat_irqs on node 0
[ 11.356807] iwlagn 0000:03:00.0: irq 32 for MSI/MSI-X
[ 11.635891] cfg80211: World regulatory domain updated:
[ 11.635894] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 11.635898] (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 11.635902] (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 11.635905] (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 11.635908] (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 11.635911] (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 11.654517] phy0: Selected rate control algorithm 'iwl-agn-rs'
[ 20.832115] iwlagn 0000:03:00.0: firmware: requesting iwlwifi-5000-2.ucode
[ 20.927766] iwlagn 0000:03:00.0: loaded firmware version 8.24.2.12
[ 21.074778] Registered led device: iwl-phy0::radio
[ 21.074805] Registered led device: iwl-phy0::assoc
[ 21.074827] Registered led device: iwl-phy0::RX
[ 21.074846] Registered led device: iwl-phy0::TX
[ 21.122041] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 23.343363] cfg80211: Found new beacon on frequency: 2472 MHz (Ch 13) on phy0

Kris (kpaz) wrote :

Bug confirmed on DELL laptop by Axel:

Hi all,
it seems to be a new old problem with the network-manager: I didn't get it to work with hidden SSID WiFi access points neither with Ubuntu 7.10 nor with 8.04
I was happy, that the bug has been obviously fixed in 8.10, because network-manager worked well since then with my access point.

But now the problem is back again:
There are two Dell notebooks on the table in front of me. One is running Ubuntu 8.10 working perfectly well and one is running 9.10 whith a network manager, that shows exactly the erroneous behaviour which Kris already described.

Regards,
Axel

Charlie (rumburaknet) wrote :

Same problem here, machine is HP 550, with Intel PRO/Wireless 4965 AG. The versions 8.10 and 9.04 worked flawlessly. I've updated to Karmic this morning and now no wireless. Even when I get it working without a "hidden" SSID after resume from suspend or stanby it can't connect anymore.
Snip...
 Registered led device: iwl-phy0::radio
[10598.462023] Registered led device: iwl-phy0::assoc
[10598.462044] Registered led device: iwl-phy0::RX
[10598.462064] Registered led device: iwl-phy0::TX
[10598.503861] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[10598.865470] Registered led device: iwl-phy0::radio
[10598.865518] Registered led device: iwl-phy0::assoc
[10598.865559] Registered led device: iwl-phy0::RX
[10598.865599] Registered led device: iwl-phy0::TX
[10598.907088] ADDRCONF(NETDEV_UP): wlan0: link is not ready
 Snip.....

B/R
Charlie

Craig (craig-cgwnet) wrote :

Same problem on Toshiba L305 with Atheros AR5007EG wireless with Karmic 64-bit. Unhide SSID and I'm able to connect.

Regards
Craig

Ömer ÜCEL (omerucel) wrote :

Same problem on LB RD510

Device
01:00.0 Network controller: RaLink RT2860

Kris (kpaz) wrote :

Ok,
error is confirmed on many platforms.

Now,
who can take a lead with development of the fix for this issue, cause I'm not able to patch it myself.
Who should be assigned to the bug - what team or developers?

I can offer my help with testing the fixes/solutions.

Regards,
Kris.

Changed in ubuntu:
status: New → Confirmed
woods (s-woods) wrote :

Just to confirm that I am also having problems with connecting to hidden wireless networks on 9.10, using a netgear MA111 usb wireless adapter.

Strangely I can connect to my hidden network by creating a new connection (inputting the SSID and passphrase through network manager) but once I disconnect the only way I can re-connect is to restart the machine and create a new network (the one I created earlier just has a greyed connection button as others have described)

Unfortunately my router is supplied by my ISP who have modified it so I can't unhide the SSID

Craig

Kris (kpaz) on 2009-11-04
Changed in ubuntu:
assignee: nobody → Bug Management Team (bugmanagement)
Changed in ubuntu:
assignee: Bug Management Team (bugmanagement) → nobody
OlivierS (olivier-olivier) wrote :

Same problem on IBM Thinkpad T42 with USB wifi stick.

Ubuntu 9.04 worked without a problem. Automatic worked after some time, so usually I enabled it manually to speed it up.

in Ubuntu 9.10 if I manually try to enable the network with the hidden SSID the connect button is greyed out. After a few minutes networkmanager detects the network availability and connects, but those few minutes are very annoying.

Same problem on a Dell latitude E5400.
It was working ok on 9.04.
The strange is that after I try to connect to the router, no more machines can connect.
I have to reset the router so that others can connect.

Mello (mellowiz) wrote :

Lenovo T60 with Intel 3945ABG [Golan] chipset: wireless with hidden SSID was working fine with 9.04, it doesn't with 9.10.
Workaround is to unhide SSID.

Kris (kpaz) wrote :

@Mello
- sorry, but you cannot name it workaround.

Workaround would be fine, if it would allow me modfity something on MY Ubuntu/Laptop and connect to WLAN with hidden SSID.
You proposal is about changing sometihng that is outside of MY Ubuntu/Laptop - so usually out of my control.
For example - at my office I can not change the corporate security policy to unhide SSIDs in whole building, because just I want to use Ubuntu...
Thus this bug - and if not repaired, it's gonna to prevent me from using Ubuntu, cause I have to have working WLANs with hidden SSIDs on my laptop at work, so I'm going to consider switching back to old, good debian or just boot the Windows unfortunatelly.

So,
anyone - please help with this bug, cause I like Ubuntu and this problem with hidden SSIDs WLAN connections is really painful.

Reagrds,
Kris

Changed in ubuntu:
assignee: nobody → Ubuntu Bugs (ubuntu-bugs)
pongkiat (pongkiat) wrote :

Same problem on Thinkpad X200.
Ubuntu 9.04 work very well with hidden SSID.

Dermis (dermis) wrote :

same problem with Thinkpad x61 using karmic

Kris (kpaz) on 2009-11-15
Changed in network-manager:
status: New → Confirmed
summary: - Hidden SSID WLAN doesn't work under Ubuntu.9.10 - tested on Lenovo T500
- and DELL
+ Hidden SSID WLAN doesn't work under Ubuntu.9.10 at all
Changed in network-manager:
assignee: nobody → Crash bug triagers for main packages (ubuntu-crashes-main)
dmarrazzo (marrazzo) wrote :

I have the same problem of Lenovo T60, T400, T500.
I can connect the first time to the hidden wlan, but when I try to connect again using the previous settings the network manager popup has the connect button disabled. I tried disabling keyring with no success. I have also tested with Fedora 12 same HW, same release of NM and it works fine, it seems an Ubuntu problem.

hall900 (hall900) wrote :

I'have the same problem in a acer aspire 5735. After many test, i see when go to select hidden network, the password not appear (in the profile the password, wep 128 bits, is ok), the problema can be in the password retrieving (i haven't a key ring), that affect the automatic connection and the manual hidden connection. As well of others, creating a new network profile works as well as unhide the ssid.

Kris (kpaz) wrote :

I confirm that the bug is still in place after latest updates on Karmic 9.10.

Tested on Ubuntu 9.10-AMD64 with machines:
- IBM/Lenovo T60p
- IBM/Lenovo T61p
- IBM/Lenovo T500
- Apple MacBook Pro 5.3

Please help with finding patch/solution.

Regards,
Kris.

jrehacek (kuba-rehacek) wrote :

Same problem here on kubuntu 9.10 Lenovo SL400. WIFI card Intel wifi link 5100AGN. Creating network, setting WPA/WPA2enterprise TKIP, certificates and then... Simply doesnt do anything... Iven if connect automatically is checked, after reboot, log is similar to the one posted above. Come on guys. Please work this out ASAP. I have to use my laptop at work and IT IS NOT in my power to make the corporate wifi visible. I dont want to go back to windows, but if this bug won't be corrected soon, i will be forced to:(. Thanks a lot! Have a nice day!

m0sfet (riccardo-donato) wrote :

A probably workaround (it worked for me!) could be to create the same wifi network connection as it was not hidden and try to connect to both (first the hidden one).

dmarrazzo (marrazzo) wrote :

I found a workaround, too: Installing Fedora 12! :-)
For me it's as easy as ubuntu, but network manager works!

m0sfet (riccardo-donato) wrote :

@dmarrazzo
 I don't think is a network manager issue...I tried using wicd and the problem persist

jrehacek (kuba-rehacek) wrote :

Guys im confused. I was trying to override KNM through manually configured wpa_supplicant.conf using wpa_supplicant then. I was using, ifconfig, iwconfig, iwlist to configure every possible thing. After I shot KNM, for the first time using wpa_supplicant, it successfully connected to hidden network but failed to authenticate certificates:(. Ok right. I modified wpa_supplicant.conf and then it wasn able to connect again. Even if I recreated first attempt with original conf after reboot. Weird. I started KNM manually after i gave up with wpa_supplicant and what the hell? It was showing hidden wifi as available and secure. BUT WHEN I CLICKED ON IT IT WASNT CONNECTING. So I figured, that when wlan0 is issued with name of hidden wifi through iwconfig wlan0 essid ****** and then iwlist wlan0 scan (sometimes twice or three times:o)) KNM shows the hidden network as available, but cannot connect:(. Im starting to think that this is more complex problem than KNM:-/.

m0sfet (riccardo-donato) wrote :

@jrehacek
Try to delete all connections that you created into network manager and create 2 new connections with the same ssid one hidden and one not and try to connect.

Charlie (rumburaknet) wrote :

As someone mentioned that a workaround is installation of Fedora 12 I have to confirm that it also work on Mandrake 2010, to me it is more of a kernel driver problem than anything else. Both Fedora and Mandrake have later kernel versions than Karmic and it works on them. Ubuntu 9.10 and OpenSuSE 11.2 have same issue and both use similar kernel versions. This is very annoying.

m0sfet (riccardo-donato) wrote :

@Charlie

It is useless to just say "I am using fedora 12 and it works" it could be better to describe what kernel version are you using and related kernel config file so we can try to fix this problem on Ubuntu too.

traxxas (traxxas) wrote :

I have had the same problem since upgrading to karmic. I use wicd and have had the problem there as well as NetworkManager. My workaround is to build a wpa_supplicant configuration for the hidden network and then have a shell script that starts wpa_supplicant twice, killall wpa_suppilcant processes this will get the wifi out of ADDRCONF(NETDEV_UP): wlan0: link is not ready mode. Then the script will do a call to wpa_supplicant and dhclient and I have a working connection.

Chekotia (ningleepo) wrote :

I can confirm this problem in my HP dv2000 with a Broadcom WLAN card.

Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in network-manager.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

Changed in network-manager:
assignee: Crash bug triagers for main packages (ubuntu-crashes-main) → nobody
affects: ubuntu → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
assignee: Ubuntu Bugs (ubuntu-bugs) → nobody
affects: network-manager → null
Michael Nagel (nailor) wrote :

closing task on NULL project

Changed in null:
status: Confirmed → Invalid
Mitch Towner (kermiac) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug #446394 (even though that bug is discussing the use of WEP, not WPA), so it is being marked as such. The fix as described by Matt Trudel (Post #44) resolved this issue for me when using WEP, WPA or WPA2 on my router. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Yfff (yfff) wrote :

I use Kubuntu 9.10 on an Asus F6Ve (Intel WiFi Link 1000bgn and module iwlagn) and had the same problem with knetworkmanager. I replaced it with nm-applet but, while better with network-manager-vpnc than knetworkmanager, it didn't connect either.

So I tried to force scanning of my particular hidden ssid (let's call it "whereRU") with :

-----8<----------8<----------8<----------8<----------8<-----
sudo iwlist wlan0 scan essid whereRU
-----8<----------8<----------8<----------8<----------8<-----

and ... after a few seconds... tada... IT WORKS !

and with knetworkmanager too.

I suppose iwlagn can't find a hidden ssid until you put its nose ON it ;-)

Hope this helps

Yfff

Yfff (yfff) wrote :

... forgot to mention : my "whereRU" is a wpa/psk protected hidden network...

Yfff

Rocko (rockorequin) wrote :

After reading the original report, I don't think this is a duplicate of bug #446394, although it seems that some comments in it probably do belong to #446394.

Could this be an 11n issue? My Ubuntu 9.10 can connect to a hidden 11n network at work, but previous versions of Ubuntu to get it to work I had to disable the 11n functionality in my intel 4965 card by adding a file /etc/modprobe.d/iwlagn.conf with the line:

options iwlagn 11n_disable=1

and then restarting the network card with:

sudo modprobe -r iwlagn && sudo modprobe iwlagn

I've done this again in Ubuntu 9.10 recently because either network-manager or the 11n driver is still a bit buggy (after connecting to the hidden 11n network, when I standby and resume and try to connect to my home 11g network, it often can't connect).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers