[karmic] Network manager add DNS servers only once for mobile broadband

Bug #420999 reported by Id2ndR on 2009-08-29
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: network-manager

System : up-to-date karmic with NetworkManager PPA

My 3G mobile broadband works great the first time I try to connect with it : the ping is correct and 2 DNS servers ar filled in resolv.conf by NetworkManager.
The second time, the ping is a little bit slower (I don't stop the ping command so it still have the IP address to ping) but resolv.conf is not filled so new DNS resolution are impossible.

I noticed that restarting the NetworkManager service allows to reconnect normaly (neither killing modemmanager nor unpluging/repluging the usb modem helped).

Viktors Petrovs (viks77) wrote :

Same situation here.

If i'm connecting my wireless connection before broadband connection, DNS is always set/replaced with broadband connection's nameservers. Disconnecting broadband restores wireless connection's nameservers.
If i disable wireless when broadband connection is active, broadband works anyway, but disconnecting restores wirless connection's nameservers. After that reconnecting broadband always works correctly.

If i disable wireless while broadband is not connected, broadband connection works only for first time setting nameservers. For second time and so on nameservers is not set anyore.

Sergiu Bivol (sergiu-bivol) wrote :

I'm experiencing the same behavior with a ZTE MF637.
If I remove /etc/resolv.conf and connect, NM will put DNS servers in it and create another backup file. If the file exists already, it won't write the DNS servers to it.

Should be noted that it doesn't work the first time for me, unlike the bug reporter mentioned.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please open a terminal and execute: apport-collect 420999 ? It will attach the necessary information to this report. Also you can submit more information for it by looking to https://wiki.ubuntu.com/DebuggingNetworkManager , Thanks in advance.

Changed in network-manager (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Low

Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 80.232.128.74 via 192.168.0.1 dev eth1 src 192.168.0.100
 192.168.0.0/24 dev eth1 proto kernel scope link src 192.168.0.100 metric 2
 169.254.0.0/16 dev eth1 scope link metric 1000
 default via 192.168.0.1 dev eth1 proto static
NonfreeKernelModules: wl
Package: network-manager 0.8~a~git.20090831t055002.74f125b-0ubuntu1~nmt2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
Uname: Linux 2.6.31-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Viktors Petrovs (viks77) wrote :

Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 9.10
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 80.232.128.74 via 192.168.0.1 dev eth1 src 192.168.0.100
 192.168.0.0/24 dev eth1 proto kernel scope link src 192.168.0.100 metric 2
 169.254.0.0/16 dev eth1 scope link metric 1000
 default via 192.168.0.1 dev eth1 proto static
NonfreeKernelModules: wl
Package: network-manager 0.8~a~git.20090831t055002.74f125b-0ubuntu1~nmt2
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
Uname: Linux 2.6.31-9-generic i686
UserGroups:

Viktors Petrovs (viks77) wrote :

Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 192.168.0.0/24 dev eth1 proto kernel scope link src 192.168.0.100 metric 2
 169.254.0.0/16 dev eth1 scope link metric 1000
 default via 192.168.0.1 dev eth1 proto static
NonfreeKernelModules: wl
Package: network-manager 0.8~a~git.20090831t055002.74f125b-0ubuntu1~nmt2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
Uname: Linux 2.6.31-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Viktors Petrovs (viks77) wrote :

Sorry for 3 repeated posts. apport-collect was crashing all the way while i was trying to collect additional info. I did not know that I am sending something. I was unable to complete the collection of information using apport-collect because of crashes, what can I do more?

Id2ndR (id2ndr) wrote :

Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.22 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.1.1 dev wlan0 proto static
Package: network-manager 0.8~a~git.20090825t221816.592769c-0ubuntu1~nmt1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Id2ndR (id2ndr) wrote : Gconf.txt
Id2ndR (id2ndr) wrote : IpAddr.txt
Id2ndR (id2ndr) wrote : IwConfig.txt
Changed in network-manager (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 9.10
IpRoute:
 10.64.64.64 dev ppp0 proto kernel scope link src 10.166.83.223
 default via 10.64.64.64 dev ppp0 proto static
IwConfig: Error: [Errno 2] No such file or directory
NonfreeKernelModules: wl nvidia
Package: network-manager 0.8~a~git.20090911t130220.4c77fa0-0ubuntu1 [modified: usr/sbin/NetworkManager usr/lib/NetworkManager/nm-crash-logger usr/lib/NetworkManager/nm-dhcp-client.action usr/lib/NetworkManager/nm-dispatcher.action usr/lib/NetworkManager/nm-avahi-autoipd.action usr/bin/nm-tool]
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
RfKill: Error: [Errno 2] No such file or directory
Uname: Linux 2.6.31-10-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare
WpaSupplicantLog:

Changed in network-manager (Ubuntu):
status: New → Confirmed
Max (maxter) on 2009-10-30
description: updated

I have had this problem as well with AT&T broadband and a Sierra Wireless USBConnect 881 on a fresh install of Karmic. I was previously using Jaunty and had no problems, and upgrading Jaunty to Karmic caused no problems. A fresh install of Karmic exhibited this behavior.

Everything seemed to work fine on the connection to AT&T broadband, I couldn't reach any websites. (Once or twice, the connection seemed to work fine, but there was no apparent commonality to any actions I had taken to get it to work.) Disconnecting, unplugging, rebooting, and restarting network manager seemed to have no effect.

After reading this bug, I checked my /etc/resolv.conf file and found that it had no entries in it. I added an entry for "nameserver" with the first ip address on the opendns site and everything began working fine, even after disconnect and reconnect.

By doing the following, I was able to add DNS entries to the connection so that it works consistently:

Right click on the network manager icon in the top panel, and select "Edit Connections..."
Choose the "Mobile Broadband" tab.
Select the "AT&T Data Connect" entry and click the "Edit" button. (an editing dialog appears)
Choose the "IPv4 Settings" tab
Change "Method" to "Automatic (PPP) addresses only"
Enter your nameserver ip addresses in DNS Servers, separated by a comma or semicolon. I entered the opendns entries as follows: 208.67.222.222, 208.67.220.220 but you should check their website and see if these are appropriate for you. If I can dig out the AT&T nameserver ip addresses, I may change to them, though opendns seems to work well so far.

I don't know what the overall problem is or if this helps resolve it (or if it has already been resolved!), but I hope this info will help anyone who has a similar problem.

Patrick (94bc1052) wrote :

I have a similiar problem: Network manager doesn't write the nameservers to resolv.conf when I use a mobile broadband connection.

-root@xinu:~# cat /etc/resolv.conf
# Generated by NetworkManager

My version of network manager: 0.7.996
And that's all there is. As a workaround, I added the nameservers to the file manually after the connection has been established. (echo nam.es.erver.ip >> /etc/resolv.conf)

Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
IpRoute:
 192.168.2.0/24 dev wlan0 proto kernel scope link src 192.168.2.54 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.2.1 dev wlan0 proto static
NonfreeKernelModules: fglrx
Package: network-manager 0.8~a~git.20091013t193206.679d548-0ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-20-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev root sambashare tape vboxusers video
XsessionErrors:
 (gnome-settings-daemon:3795): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:3916): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:3901): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (firefox:4249): GLib-WARNING **: g_set_prgname() called multiple times

Thomas Hood (jdthood) wrote :

Should be fixed in Precise.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.