Network-Manager does not associate with a WEP AP

Bug #40538 reported by Graham White on 2006-04-21
This bug report is a duplicate of:  Bug #41480: static WEP broken on wext driver. Edit Remove
14
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

I have Dapper on a Thinkpad T42 (IPW2200 wireless). NeworkManager
will not associated with my WEP-encrypted AP at home, but it successfully associates with the unencrypted AP at work. Manual
configuration (editing /etc/network/interfaces) works with
the WEP-encrypted AP at home.

Messages when NM fails to associate, generated by
running NetworkManager --no-daemon in a terminal

Tony Arnold (tony-arnold) wrote :

I have a similar problem on a Dell C.400 laptop with the orinoco_cs wireless driver. Output from NetworkManager includes lines saying 'ioctl[SIOCSIWAUTH]: Operation not supported'

Peter Gavin (pgavin) wrote :

Similar problem here, on a IBM ThinkPad T30 using the airo driver. The network-manager in Breezy worked fine, but after I installed dapper, I was unable to connect to a WEP AP. (My current version of nm is 0.6.2-0ubuntu3).

Here are the log messages (from /var/log/debug) that I recieved when I attempted to connect:

Apr 24 14:34:41 localhost NetworkManager: <debug info>^I[1145903681.826523] nm_device_802_11_wireless_get_activation_ap (): Forcing AP 'my-ssid'
Apr 24 14:35:47 localhost NetworkManager: <debug info>^I[1145903747.106260] real_act_stage4_ip_config_timeout (): Activation
(eth0/wireless): could not get IP configuration info for 'my-ssid', asking for new key.
Apr 24 14:36:51 localhost kernel: [4313885.714000] eth0: no IPv6 routers present

Reinhard Tartler (siretart) wrote :

could you please retry with wpasupplicant_0.4.8-3ubuntu1?

Download full text (44.3 KiB)

On Thu, 2006-04-27 at 12:21 +0000, Reinhard Tartler wrote:
> *** This bug is a duplicate of bug 41480 ***
>
> could you please retry with wpasupplicant_0.4.8-3ubuntu1?
>
Well, partial success: wpasupplicant now works (with the
wext driver, but not with the ipw driver). It's never worked
with static WEP before, so that's an improvement. On the other hand,
NetworkManager still doesn't work: messages attached.

Graham

graham@cusa:~ $ sudo NetworkManager --no-daemon
NetworkManager: <information> starting...
NetworkManager: <WARNING> main (): nm_data_new: Setting up dbus filter
NetworkManager: <information> eth0: Device is fully-supported using driver 'e1000'.
NetworkManager: <information> nm_device_init(): waiting for device's worker thread to start
NetworkManager: <information> nm_device_init(): device's worker thread started, continuing.
NetworkManager: <information> Now managing wired Ethernet (802.3) device 'eth0'.
NetworkManager: <information> eth1: Device is fully-supported using driver 'ipw2200'.
NetworkManager: <information> nm_device_init(): waiting for device's worker thread to start
NetworkManager: <information> nm_device_init(): device's worker thread started, continuing.
NetworkManager: <information> Now managing wireless (802.11) device 'eth1'.
NetworkManager: <information> Updating allowed wireless network lists.
NetworkManager: <information> SWITCH: no current connection, found better connection 'eth1'.
NetworkManager: <information> Will activate connection 'eth1/moretus'.
NetworkManager: <information> Device eth1 activation scheduled...
NetworkManager: <information> Activation (eth1) started...
NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <information> Activation (eth1) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <information> Activation (eth1) Stage 2 of 5 (Device Configure) starting...
NetworkManager: <information> Activation (eth1/wireless): access point 'moretus' is encrypted, but NO valid key exists. New key needed.
NetworkManager: <information> Activation (eth1) New wireless user key requested for network 'moretus'.
NetworkManager: <information> Activation (eth1) Stage 2 of 5 (Device Configure) complete.
NetworkManager: <information> Activation (eth1) New wireless user key for network 'moretus' received.
NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <information> Activation (eth1) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <information> Activation (eth1) Stage 2 of 5 (Device Configure) starting...
NetworkManager: <information> Activation (eth1/wireless): access point 'moretus' is encrypted, and a key exists. No new key needed.
NetworkManager: <infor...

Reinhard Tartler (siretart) wrote :

Please don't paste such long logs, please save them to a file and attach that to this bug instead.

I'm a bit confused of your answer. On the one hand, you say that WEP would work now. (the new wpasupplicant only fixed the wext interface, ipw2100/ipw2200 are supposed to work with wext, better don't use ipw).

On the other hand, you state 'it does not work', and the log indeed looks like association problems. Could you please clarify?

Graham White (graham-dcs) wrote :

On Thu, 2006-04-27 at 17:13 +0000, Reinhard Tartler wrote:
> *** This bug is a duplicate of bug 41480 ***
>
> Please don't paste such long logs, please save them to a file and attach that to this bug instead.
>
Sorry: attached it to the email in error.
> I'm a bit confused of your answer. On the one hand, you say that WEP would work now. (the new wpasupplicant only fixed the wext interface, ipw2100/ipw2200 are supposed to work with wext, better don't use ipw).
>
> On the other hand, you state 'it does not work', and the log indeed looks like association problems. Could you please clarify?
>
Well, my original bug report was about NetworkManager, which still
doesn't work. WPA supplicant now works.

Graham

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers