Wi-Fi Protected Setup (WPS) not supported

Bug #388553 reported by Daniele Napolitano on 2009-06-17
276
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
NetworkManager
In Progress
Wishlist
network-manager (Ubuntu)
Wishlist
hadi khani
Declined for Lucid by Robert Ancell

Bug Description

As the title the Wi-Fi Protected Setup (WPS) is not supported by NetworkManager (but is supported by wpa_supplicant).

The WPS WI-Fi standard is implementated in various newer access points and allow user to configure the access point in just a few of steps and do all configuring process very simple.

Specifications: http://www.wi-fi.org/wifi-protected-setup/

Thomas (t.c) wrote :

Intel Corporation is providing a Linux reference implementation

http://software.intel.com/en-us/articles/wi-fi-simple-config-wsc-linux-reference-implementation/

Laurence (l-d-anderson) wrote :

This is already supported in wpa_supplicant (but not NM?)

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid packages ?
Tanks in advance.

Changed in ubuntu:
status: New → Incomplete
Daniele Napolitano (dnax88) wrote :

> Thank you for taking the time to report this bug and helping to make Ubuntu
> better.
> Is this bug reproducible with the latest Lucid packages ?

Yes. Currently wpa_supplicant support WPS [1] but Network Manager don't support the new DBus methods.

Changed in ubuntu:
status: Incomplete → New
affects: ubuntu → network-manager (Ubuntu)
description: updated
Fabio Marconi (fabiomarconi) wrote :

Thank you for your suggestion. However, the changes you are requesting aren't really a bug and require more discussion, which should be done on an appropriate mailing list or forum. http://www.ubuntu.com/support/community/mailinglists might be a good start for determining which mailing list to use.

Fabio Marconi (fabiomarconi) wrote :

You can also try to post your idea at http://brainstorm.ubuntu.com/ or on IRC http://webchat.freenode.net/?channels=ubuntu-devel
Then as it isn't a bug or malfuction I mark as Invalid
:)Fabio

Changed in network-manager (Ubuntu):
status: New → Invalid
Changed in network-manager:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Changed in network-manager (Ubuntu):
status: Invalid → Triaged
importance: Undecided → Wishlist
Robert Ancell (robert-ancell) wrote :

This will require a design in https://wiki.ubuntu.com/Networking

James Pent (mouseiscool) on 2015-09-28
description: updated
hadi khani (hadi-khani) on 2016-01-24
Changed in network-manager (Ubuntu):
assignee: nobody → hadi khani (hadi-khani)
bam (mybigspam) wrote :

Any progress?

Sven R. Kunze (srkunze) wrote :

Still not working on Ubuntu 16.04. :(

Martin G Miller (mgmiller) wrote :

Ran into this problem at a patients house today. I am running Ubuntu 16.04 and usually connect through my cell phone as a mobile hotspot, but there was no cell service at the location I went to. The patient has wifi in her house, but it only works with Windows 10 with WPS button on the router. Even though she gave me the password, I could not connect. Her new Verizon supplied router only wants WPS connections for some reason. Anyway, Ubuntu should really be able to do this.

buhtz (buhtz) wrote :

Do I understand that website correct, that lauchpad ist the UPSTREAM for network-manager?

WPS is a well known standard and important to make a desktop system usable. There is a high need to implement this in network manager do come closer to a usable and ergonomic "desktop linux".

Changed in network-manager:
status: Confirmed → In Progress
Daniele Napolitano (dnax88) wrote :

This was fixed upstream with Network Manager 1.10: https://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/NEWS?h=nm-1-10

Now we need a good GUI to configure all the WPS stuff (gnome-control-center).

Grazie mille!

Sadly, I'm a very long way from being able to handle the creation of the
GUI side... it's too many decades since I used to programme.
Respect to the coders!

On 14 November 2017 at 09:08, Daniele Napolitano <email address hidden> wrote:

> This was fixed upstream with Network Manager 1.10:
> https://cgit.freedesktop.org/NetworkManager/NetworkManager/
> tree/NEWS?h=nm-1-10
>
>
> Now we need a good GUI to configure all the WPS stuff
> (gnome-control-center).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/388553
>
> Title:
> Wi-Fi Protected Setup (WPS) not supported
>
> Status in Ayatana Design:
> New
> Status in NetworkManager:
> In Progress
> Status in network-manager package in Ubuntu:
> Triaged
>
> Bug description:
> As the title the Wi-Fi Protected Setup (WPS) is not supported by
> NetworkManager (but is supported by wpa_supplicant).
>
> The WPS WI-Fi standard is implementated in various newer access points
> and allow user to configure the access point in just a few of steps
> and do all configuring process very simple.
>
> Specifications: http://www.wi-fi.org/wifi-protected-setup/
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/388553/+subscriptions
>

kbunty (kbunty) wrote :

So what is needed here?

This is a major deficiency in Linux as a viable , everyday desktop solution. Wifi is now an essential part of any OS/software installation. The abitility to connect to various wifi routers at other people's houses, cafes etc, where a WPA password is required MUST be available to the basic lambda user without the need to enter or even know the root pw or start screwing around with obscure command line editing of config files. Jeez this is 2018 , not 1990.

The above link says NM 1.10.x can handle WPS but says not more. AFAICT it is implemented in low level but there is nothing in the NM GUI widgets to actually use it.

What is needed here, and is there anything actively in the pipeline?

thx

kbunty (kbunty) wrote :

PS, I know that Ubuntu allows users to do sudo su , I will lets not divert into how silly that is.

NM is commonly used on most Linux distros and needs a pushbutton solution , not command line hacking. Let's not deviate from that basic issue.

Maciej Krüger (mkg20001) wrote :

I'd like to add that it's now 2019 and still no fix insight.
It really just requires support for WPS in NM GUI and the gnome control center.

Please, please, make this a thing!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.