wrong mtu value on dsl connection

Bug #387456 reported by Yigit Güneli on 2009-06-15
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
NetworkManager
Expired
Medium
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager

i am using pppoe connection for internet. however, i cant visit some sites and i cannot use pidgin for msn on 9.04 due to wrong mtu value for ppp0. network manager sets 1492 as mtu value for dsl connections. if i use pppoeconf instead of network manager to set my connection, it gives 1488 and everything works as expected. i am now manually setting mtu with ifconfig ppp0 mtu 1488 everytime a make a connection.

and also trying to set the mtu value for my dsl connection with the gui of network-manager does not work, and it gives 1492 all time.

this was not a problem with 8.10, and i am not the only person affected on my network.

network-manager:
  Installed: 0.7.1~rc4.1.cf199a964-0ubuntu2

Alexander Sack (asac) wrote :

could you verify if the problem is gone in the packages in the ~network-manager PPA (https://launchpad.net/~network-manager/+archive/ppa) ... be aware that 3g has some minor problems in that snapshot, so if you need 3g, downgrade after testing. the rest should work fine though.

Changed in network-manager (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Alexander Sack (asac) wrote :
Changed in network-manager (Ubuntu):
status: Incomplete → Triaged
Changed in network-manager:
status: Unknown → New
Changed in network-manager:
importance: Unknown → Medium

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Sergey Chebotar (s-chebotar) wrote :

Well, i'm on Lucid and this problem is still here. When i tried Natty, it looks the same but i'm not sure, i downgraded because of some not related bugs.
With pppoconf configured connection, my ifconfig looks like

ppp0 Link encap:Протокол PPP (Point-to-Point Protocol)
          inet addr:46.175.126.109 P-t-P:89.16.99.229 Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1480 Metric:1
          RX packets:1099 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1088 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:683704 (683.7 KB) TX bytes:138476 (138.4 KB)
With network-manager configured connection all the same but MTU:1492. And it ignores 1480 settings in network-manager GUI.
I tried network-manager from the trunk ppa. All the same.

Istarion-rus (istarion-rus) wrote :

In 11.04 problem still here. I solved this problem as follows:

sudo nano /etc/NetworkManager/system-connections/DSL (name of my connection)
go to section [ppp] and see what mtu = 1492. After changing of this value all good.

P.S Changing of MTU in GUI affect mtu record in section [802-3-ethernet], and this record has no effect for me.

Changed in network-manager:
status: New → Expired
Thomas Hood (jdthood) wrote :

Expired upstream. If this is actually still a problem then please reopen.

Changed in network-manager (Ubuntu):
status: Triaged → Invalid
vsespb (vsespb) wrote :

Yes, this actually still a problem in 12.04. Not sure why upstream closed this.

Changed in network-manager (Ubuntu):
status: Invalid → Confirmed
Graham Inggs (ginggs) wrote :

I am seeing this behaviour in 14.04. MTU set to 1392 in GUI, but ifconfig displays 1492.

Graham Inggs (ginggs) wrote :

Editing the file /etc/NetworkManager/system-connections/<name of DSL connection> and adding the section below seems to work around the issue:

[ppp]
mtu=1392
mru=1392

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.