"Auto eth0" in notifications is confusing

Bug #386900 reported by Ruben Verhack on 2009-06-14
270
This bug affects 48 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Wishlist
One Hundred Papercuts
Low
Papercuts Ninjas
network-manager (Ubuntu)
Wishlist
Mathieu Trudel-Lapierre

Bug Description

Hi,

When I first starting using Ubuntu (a couple of years ago) I really had to look up what "eth0" was. And I still think this is really confusing and potentially scaring for non-tech people.

"Connected to Auto eth0" or "Could not connect to Auto eth0" doesn't really sounds that good?

Maybe changing Auto to Standard or Default? Maybe "Connected to wired network (eth0)"?

There is surely a more elegant way for fixing this, but my English isn't that good.

Thanks

Related branches

description: updated
tags: added: auto confusing eth0
description: updated
Mat Tomaszewski (mat.t.) wrote :

Thanks for your bug report. This is being fixed with the new network-manager. The notification message will be:

Wired network
Connection established

Changed in hundredpapercuts:
status: New → In Progress
importance: Undecided → Low
Changed in hundredpapercuts:
milestone: none → round-1
Changed in hundredpapercuts:
assignee: nobody → Mat Tomaszewski (mat.t.)
Mat Tomaszewski (mat.t.) wrote :

Alexander, is this something you can have a look at? Cheers

Changed in network-manager (Ubuntu):
assignee: nobody → Alexander Sack (asac)

On Mon, Jun 22, 2009 at 02:51:01PM -0000, Mat Tomaszewski wrote:
> Alexander, is this something you can have a look at? Cheers

Current suggestion of user experience team is to name those
connections "Wired network [X]" .. where X is a number when you have
multiple wired NICs

 - Alexander

Changed in hundredpapercuts:
assignee: Mat Tomaszewski (mat.t.) → nobody

We should move this to a later milestone ( 8-10 ) as the expectation is that this will be fixed by upstream and picked up by us later in the Karmic cycle.

Also, please note that this is related to bug #386407, that I recently entered about "Auto" being used as a prefix all over the place.

Changed in hundredpapercuts:
milestone: round-1 → round-10
Changed in network-manager (Ubuntu):
status: New → Confirmed
Alejandro Mallea (janoma) wrote :

I think most people use just one connection, so the default name shouldn't include a number. It's confusing since it leads too easily to look for another connections.

Alexander Sack (asac) wrote :

forwarded upstream.

Changed in network-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
Changed in network-manager:
status: Unknown → New
superfly (superfly) wrote :

agreed with Mr. Mallea

Vish (vish) on 2009-08-12
Changed in hundredpapercuts:
milestone: round-10 → round-9
komputes (komputes) wrote :

Should it use the name of the hardware? I think NetworkManager does that already for some usb controllers.

For network controllers on the PCI bus, the connection could be named from the output of the command:

$ lspci | grep Ethernet | cut -d':' -f3

Attached is a screenshot of what this would look like.

Gorka Navarrete (emrys) wrote :

I think using the name of the hardware can be even more confusing, at least for non-technical people.

The recommendation of not using numbers when there is only one connection is also a valid point.

Kurt Nelson (kurtisnelson) wrote :

How about the title of the notification is [Wired|Wireless] Network Connected and the body has Via [Hardware name] (eth0)

Chris Jean (gaarai) wrote :

Here is a list of what I think would work well and create a consistent, easily-understood interface.

Wired connection (default settings):
Wired network
Connected

Wired connection ("Show Wired Connection Names in Notices" enabled):
Wired network
Connected to [connection name]

Wireless connection:
Wireless network
Connected to [SSID]

There are a few things going on here that I will address individually.

The main focus I went for with my samples was consistency. Rather than using the SSID of the connection as the heading for wireless status messages, "Wireless network" is used to keep consistency with the use of "Wired network". In addition, "Connection Established" is replaced with a simple "Connected" as that can stay consistent with "Connected to [connection name]". Using "Connected" in place of "Connection Established" also keeps consistency with the "Disconnected" message that currently exists.

In the Network Connections manager below the Wired connections list, a checkbox is added with the label of "Show Wired Connection Names in Notices". By default, this checkbox is not checked. When this option is not checked, a simple "Connected" message will be shown for the wired connection. When this option is checked, the Connection Name is appended to the connected/disconnected message. For example, "Connected to Home Network" and "Disconnected from Home Network".

Notice that I do have a break in consistency with the use of the SSID in the message body for wireless connections rather than the Connection Name. This is due to the fact that it is possible to encounter different networks that have the same SSID. Showing the Connection Name that may differentiate from the SSID and may have been set up by someone else would cause confusion. Thus, I believe a break of consistency will enhance understanding rather than complicate it.

The default Connection Names need to be changed. I suggest that the "Auto" portion is dropped entirely since it is redundant and not that informative. For wired connections that have only one interface, "Local Connection" can be used in place of "eth0". For wired connections that have multiple connections "Local Connection #1", "Local Connection #2", etc can be used.

In order to still provide information about which interface is being used (eth0, eth1, etc), an additional entry inside the Wired tab of the Edit dialog for wired connections could list which interface is being used. This way the information is still readily available, but isn't constantly being shown in a way that would confuse the user.

Andrew (and471) wrote :

In Karmic this is now

Wired Network
Connection Established

Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in network-manager (Ubuntu):
status: Triaged → Fix Released
Changed in network-manager:
status: New → Fix Released
Michael Lazarev (milaz) wrote :

Are you sure the fix is released?
How about this screenshot from Ubuntu-9.10 rc?

Matthew Paul Thomas (mpt) wrote :

It is fixed in the notification bubbles, which is what this bug was reported about.

The window you have shown is designed to present multiple wired interfaces, if there are any. Unfortunately, as far as I know, the names like "eth0", "eth1", "eth2" etc are the only unique identifiers we have for them. If there is a better way they could be named, that is something the Linux kernel developers would need to fix.

How about making the connection name of auto eth0 by default Wired Connection 1, and eth1 Wired Connection 2, and so on?
same could be done if we have multiple wireless adapters.

Exactly. What kernel does is OK, and should not be changed. I meant
the other thing: user can rename NM connections (not interfaces, and I
don't want to rename interfaces!) in the dialog box on the screenshot
I attached above. What I ask is just putting "Wired Connection 1"
instead of "Auto eth0" by default there. I do it somehow manually, and
no real network interfaces are harmed in the process.

Also notification bubble must show the connection name as it is. So
that user know what exactly is connected or disconnected by name she
gave and used to.

If I understand the problem correctly, no modification to notification
bubbles code had to be done. Instead, default way of assigning a
connection name in NetworkManager had to be changed.

In an up-to-date Karmic, the nm-applet still says 'auto eth0'.

Vish (vish) on 2009-11-01
summary: - "Auto eth0" confusing for most people
+ "Auto eth0" , In notifications , is confusing for most people

this has not been fixed in ubuntu 9.10. please see the attached screenshot

Vish (vish) wrote :

@sayantandas:
Pls see , comment #14 , this bug is regarding the notifications [notify-osd] that appear when user connects and not about the menu or the network editor.

Sayantan Das (sayantan13) wrote :

@mac_v: Oh my mistake. The notify osd also has not changed, it still says auto eth0. See the screenshot below.

Vish (vish) wrote :

This bug seems to have been *wrongly* marked as fixed released.
Confirmed with others that the notifications are still eth0 and as such.
If it is working properly for anyone knidly report back. Thanks!

@Andrew : Always , Kindly check before marking bugs as fix released...

Changed in network-manager (Ubuntu):
status: Fix Released → Confirmed
Vish (vish) wrote :

@sayantandas: Thanks for the screenshots.

Changed in hundredpapercuts:
status: Fix Released → Triaged
summary: - "Auto eth0" , In notifications , is confusing for most people
+ "Auto eth0" in notifications is confusing
mstombs (michael-tombs) wrote :

I really don't see what is wrong with correctly labelling the hardware interface with eth0 and eth1, which would be educational for new users and useful for others. But on my "up-to-date" Ubuntu 9.10 system, something keeps swapping the hardware names eth0 and eth1, and I can have "Auto eth1" connected to "Wired Network (eth0)" and I now have a "Wired Network (eth1rename)" which tries to connect to "eth1_rename" as well. I suspect it is udev and the kernel harware detection order mucking the names up which just confuses "Network Manager" and this user.

Vish (vish) wrote :

Re-scheduling for Lucid , as we missed this for Karmic.

Changed in hundredpapercuts:
milestone: round-9 → lucid-round-10
Changed in hundredpapercuts:
milestone: lucid-round-10 → lucid-round-8

I was trying to work on this issue, tried getting the source code. Got stuck up in a problem:
Which is the correct branch for NetworkManager in Lucid from this list?
https://bugs.edge.launchpad.net/network-manager

Probably I can fix this, provided I come to know the correct branch.

SnoStorm (n0nl1nearsb0x) wrote :

This patch changes the wording of the notifications and tooltips to replace "Auto Eth0" with "Wired network".

Merge requested here: https://edge.launchpad.net/~victor-launchpad/network-manager-applet/bugfix-lp-386900/+merge/19274

tags: added: patch
Vish (vish) wrote :

Can the sponsors comment wrt the patch ?

Changed in network-manager:
importance: Unknown → Undecided
status: Fix Released → New
importance: Undecided → Unknown
status: New → Unknown
Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: lucid-round-8 → maverick-round-7-notifications+gtk
Changed in network-manager:
status: Unknown → New

I suggest somethimg more familiar or easy to understand, like Wired
Connection. :)

Greetings,
JaD!

Sebastien Bacher (seb128) wrote :

Chris, could you review this change?

Changed in network-manager (Ubuntu):
assignee: Alexander Sack (asac) → Chris Coulson (chrisccoulson)
dimitris (dimitrakhs9) wrote :

Hello guys!Thank you all so much with your assisting emails.I think 'eth'it's from ethernet(a refference for cable connection).Anyway,i've reinstalled Buntu and everything was fine,and now it's making sense to me more and more(to tell you the truth,i'm becoming more satisfied than Windows.Speacking of which,can i get ridd of them,or do they have to co-exist?because they're getting lots of space

Fabio Bossi (fabio-bossi) wrote :

Yes dimitris, you should be able to get rid of Windows partitions safely by using gparted and editing GRUB's configuration, but you should send your questions to Ubuntu Forums (ubuntuforums.org) if you need help. This place is for bug discussion only.

Changed in network-manager:
importance: Unknown → Wishlist
Sebastien Bacher (seb128) wrote :

Seems sometime to fix this cycle, Mathieu could you review the work there?

Changed in network-manager (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → Mathieu Trudel (mathieu-tl)

Yup, I'll be looking at this one; let's work to get this *really* fixed in Natty.

That said, I see a number of issues. While I agree it seems confusing to designate the connection as "Auto eth0", it really does have a reason to exist: it's an automatically added connection when NM is installed, that uses the eth0 interface to connect. This could easily be changed to something different, like "Default Wired Connection".

Looking at the latest patch applied I'm a little against making changed to tooltips (or other places for that matter) to not display the connection that is being used. In some cases, a user could have different wired connections (such as how to deal with being at work or being at home), and thus removing the connection's name would cause confusion.

Ideally you want to make sure what is written in a tooltip or notification matches the options available in the nm-applet dropdown where you choose the connection.

Vish (vish) on 2010-11-23
Changed in hundredpapercuts:
milestone: maverick-round-7-notifications+gtk → nt3-ayatana
Martin Pitt (pitti) wrote :

Indeed we don't want to apply this in Ubuntu without it being applied upstream first, otherwise we'd have a permanent delta on user-visible strings. This would keep breaking all translations.

Also, please don't drop the interface name from the string, as it's not uncommon to have more than one. I think "wired connection (eth0)" is a good enough compromise.

Martin Pitt (pitti) wrote :

I'm unsubscribing sponsors for now, as this is not something we should upload in the current state.

papukaija (papukaija) on 2010-12-04
tags: removed: auto confusing eth0
Vish (vish) on 2010-12-08
tags: added: patch-forwarded
removed: patch
Vish (vish) on 2010-12-21
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Changed in network-manager:
status: New → Fix Released
aaron (aaron-zareason) wrote :

"Ideally you want to make sure what is written in a tooltip or notification matches the options available in the nm-applet dropdown where you choose the connection."

Yes, agree 100%.

Who cares what the notification says if there's nothing matching it in the nm-applet?

Let's just change the nm-applet words. As comment #16 says, we can all manually change the name of the connection in network manager. All we're asking here is that the default name given to a connection (the same one we can edit ourselves) is not Auto eth0.

Marcus Haslam (marcus-haslam) wrote :

I'm out of the office until 1st August.

On 26 Apr 2011, at 22:50, Bug Watch Updater
<email address hidden> wrote:

> ** Changed in: network-manager
>       Status: New => Fix Released
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/386900
>
> Title:
>  "Auto eth0" in notifications is confusing
>
> Status in One Hundred Paper Cuts:
>  Triaged
> Status in NetworkManager:
>  Fix Released
> Status in Network Manager GNOME Applet:
>  New
> Status in “network-manager” package in Ubuntu:
>  Triaged
>
> Bug description:
>  Hi,
>
>  When I first starting using Ubuntu (a couple of years ago) I really
>  had to look up what "eth0" was. And I still think this is really
>  confusing and potentially scaring for non-tech people.
>
>  "Connected to Auto eth0" or "Could not connect to Auto eth0" doesn't
>  really sounds that good?
>
>  Maybe changing Auto to Standard or Default? Maybe "Connected to wired
>  network (eth0)"?
>
>  There is surely a more elegant way for fixing this, but my English
>  isn't that good.
>
>  Thanks

Changed in hundredpapercuts:
status: Triaged → Fix Committed
Chris Wilson (notgary) on 2011-12-17
Changed in hundredpapercuts:
milestone: nt3-ayatana → precise-5-indicators

Changes are upstream, the actual notification and name of the connection is in fact "Wired connection 1" (and is translatable, the translation for this has been fixed up in Precise). Closing as Fix Released.

Changed in network-manager (Ubuntu):
status: Triaged → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
no longer affects: network-manager-applet
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.