Intel PRO/Wireless 2200BG Fails to connect to any network

Bug #366217 reported by Shaze on 2009-04-24
86
This bug affects 4 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

Just installed 9.04 on a Dell D410 (all intel) laptop, and no matter what I try, I can't get the wireless to connect to any network. This has always worked flawlessly in past releases, but now it seems that it won't connect to any network; no matter the security type. Wired connections work as expected, but all the wifi networks I try to connect to either time out while connecting, or prompt me for the pass-phrase again.

I can't seem to find anything regarding this, and would appreciate any assistance you could provide.

Output of "sudo lshw -C network"

description: Wireless interface
product: PRO/Wireless 2200BG [Calexico2] Network Connection
vendor: Intel Corporation
physical id: 3
bus info: pci@0000:02:03.0
logical name: eth1
version: 05
serial: 00:13:ce:52:a1:4c
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.2.6 (Mar 22 2005) latency=64 link=no maxlatency=24 mingnt=3 module=ipw2200 multicast=yes wireless=unassociated
*-network DISABLED
description: Ethernet interface
physical id: 2
logical name: pan0
serial: be:b7:e7:fa:72:79
capabilities: ethernet physical
configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
IfupdownConfig:
 auto lo
 iface lo inet loopback
Package: network-manager 0.7.1~rc4.1.cf199a964-0ubuntu2
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
Uname: Linux 2.6.28-11-generic i686

Shaze (theshaze) wrote :
parix (josema) wrote :

Same here. "Network manager applet 0.7.0.100" says last time I used the connection was 12 days ago (before the 9.04 update). I have a Zydas USB wifi card that still works fine after the update (zd1211rw module).

parix@parix-laptop:~$ sudo lshw -C network
[sudo] password for parix:
  *-network:0
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 2
       bus info: pci@0000:06:02.0
       logical name: eth0
       version: 10
       serial: 00:c0:9f:c3:68:cb
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=32 link=no maxlatency=64 mingnt=32 module=8139too multicast=yes port=MII speed=10MB/s
  *-network:1
       description: Wireless interface
       product: PRO/Wireless 2200BG [Calexico2] Network Connection
       vendor: Intel Corporation
       physical id: 4
       bus info: pci@0000:06:04.0
       logical name: eth1
       version: 05
       serial: 00:13:ce:3b:cd:ba
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list logical wireless
       configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG:9.0.1.6 (Jan 21 2005) latency=32 link=no maxlatency=24 mingnt=3 module=ipw2200 wireless=unassociated
  *-network:0 DISABLED
       description: Ethernet interface
       physical id: 1
       logical name: pan0
       serial: da:59:d7:6e:4d:40
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes
  *-network:1
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 00:02:e3:44:35:5c
       capabilities: ethernet physical wireless
       configuration: broadcast=yes ip=192.168.2.106 wireless=IEEE 802.11bg
parix@parix-laptop:~$

Shaze (theshaze) wrote :

Would just like to add that it appears this is a more widespread problem than just my setup, others are now reporting the same symptoms. http://ubuntuforums.org/showthread.php?p=7145250

Have tried recompiling the driver from scratch (ala this thread http://www.debuntu.org/2006/03/27/9-how-to-ipw2200-getting-intel-pro-wireless-2200-bg-to-work-on-debian-ubuntu) to no avail; problem still exists.

Also I have since partitioned the drive to install XP, which I used to confirm that the wireless is working, with the latest Intel drivers.

Any advice or help would be greatly appreciated!

Shaze (theshaze) on 2009-05-12
visibility: public → private
parix (josema) on 2009-05-13
visibility: private → public
Albert Zeyer (albertzeyer) wrote :

Same problem here. This is very urgent to me, I need the WLAN working. What possibilities are there? How can I downgrade to Ubuntu 8.10? (Because after a lot of reports in the forum, it has worked for everybody in 8.10 but got broken in 9.)

Albert Zeyer (albertzeyer) wrote :

I read something about that I need a kernel with Toshiba support activated to use the WLAN hotkey (which is not working). But why have users reported that it worked just fine in Ubuntu 8? Does the kernel in Ubuntu 8 has this support?

Is it possible to use a different kernel?

Shaze (theshaze) wrote :

Albert, see the forums for downgrading instructions or simply back up your data and reinstall. Please limit your comments with this bug to specific hardware details or related troubleshooting tips.

Albert Zeyer (albertzeyer) wrote :

Reinstalling would be the last option. That's why I asked if there is any other options. I wonder also about that Toshiba support. Perhaps that missing support could be the reason (at least for my case) that it does not work. That's why I asked if that support was there in Ubuntu 8. If so, this support should be added again in Ubuntu 9.

alexlinux (alexandrelimaconde) wrote :

I have the same problem with my Intel PRO/Wireless 2200BG in a VAIO VNG-S4HP! He worked fine for the last 6 months (including after I upgrade to 9.04), until last week, when he disconnected from my network while I was using Firefox. Now he “connects” but no Internet (when I ping my router I receive the message “Destination Host Unreachable
”). He works well with wired connections... and the wireless connection works ok with Windows XP.

I tried almost everything, including a clean install... and nothing. With Ubuntu 8.10 from live CD, works well too.

I see that this problem is widespread with Ubuntu 9.04, and one month in the release it seems that there are no solution available...

Shaze (theshaze) wrote :

I just want to add that I eventually did find the source of the problem for all of my issues. It appears that some new neighbors moved in to my building and began broadcasting their wireless on the same frequency as me. Luckily I am running the Tomato firmware on my router, so I was able to see the congestion and switch to a portion of the frequency that no one was on.

Once I did this, my connectivity issues with Ubuntu, and the speed issues with Windows' wireless disappeared.

The symptoms were very strange, and without having access to any wireless monitoring tools like those included with DDWRT or Tomato, I would have never have found the source of the problem. So my suggestion it to log in to your respective routers and try changing the frequency/channel that your wireless broadcasts on; then try reconnecting.

66Ton99 (66ton99) on 2010-04-01
description: updated

Still happening on Maverick...

ricardisimo (ricardisimo) wrote :

It's happening on every laptop on which I've tried Ubuntu in the past two years or so, no matter the make, model or wireless card... what the hell is going on? Ubuntu wireless works on desktops but not laptops, which is about as back-asswards as one can conceive.

So, has there been a fix or workaround issued for this yet?

Daniel, ricardisimo, if you're still having issues, please file separate bug reports, using 'ubuntu-bug network-manager', so that all the relevant information about your wireless hardware is available. Don't forget to comment here with the bug number so I can take a look at it.

The issues on 9.04 with the ipw2200 hardware are likely specific to WPA, and AFAIK they were fixed since in newer releases, so I would suggest upgrading to a newer release (especially since Jaunty is EOL since October 23, 2010). Because the release is EOL and further issues are definitely visible on other hardware and other releases (but don't include enough information to suggest it's the same issue), I'll mark this bug Invalid.

Changed in network-manager (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers