Network-Manager blocks pppoeconf from accessing wireless

Bug #355826 reported by der_vegi on 2009-04-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I am using n-m 0.7.1~rc3.2.gitb8fc83a7-0ubuntu1 on a Jaunty installation here.

The network setup is the following: A wireless bridge connected to a DSL modem (which is the default setup of a German provider called 'Alice'). Using Ubuntu 8.10, I connected to the wireless bridge and then could run pppoeconf to configure the DSL connection, as network-manager cannot handle this over wireless. 'pon dsl-provider' worked fine, then. But with Jaunty now, pppoeconf seems to be blocked by network-manager. It scans through all interfaces but cannot find the DSL modem any more. Forcing a configuration of the interface wlan0 does not help, 'pon' does not connect.

This happens on the computer, I was installing Ubuntu on, fresh Jaunty Beta. Also on mine with updated Alpha-something and on Ubuntu 8.10 with network-manager 0.7-0ubuntu1~nm1~intrepid1 from ppa.../network-manager. With the default network-manager version of Ubuntu 8.10 on a third computer, it works.

Alexander Sack (asac) wrote :

I am not sure where this regression comes from, but for now I would lean towards the wireless driver or wpasupplicant.

What chipset are you using?

der_vegi (m-may) wrote :

The two computers where pppoeconf does not work any more use the b43 driver, in my case it is a BCM4312 802.11a/b/g [14e4:4312] (rev 01). The computer with the stock n-m from Intrepid has an intel chipset.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Julian Alarcon (julian-alarcon) wrote :

I found some info here:
http://ubuntuforum-pt.org/index.php?topic=48588.0

But, i don't know portuguese.. Seems like a workaround (maybe a solution)

Julian Alarcon (julian-alarcon) wrote :

I confirm that bug.. The connection worked the first time, when I configure it. But, after restart, network manager can't see any network.. And, pon dsl-provider show me:

Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5

But, there was no connection.

Seems that Newtwork manager is blocking pppoeconf...

The problem is not in my computer, but I don't think that this is the cause.. the wireless chip is an intel, and works flawlessly with other networks.

Alexander Sack (asac) wrote :

duplicate of bug 232172

Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers