Please auto-reconnect to VPN

Bug #344455 reported by Michael Jones on 2009-03-17
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
High
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

On my campus VPN, a connection can be made, and an Internet connection established. But the VPN disconnects every several minutes.
The pptp module for network-manager has an "automatically" connect option, but not a "automatically reconnect" option.
It would be nice.

    A team of us tried to go through the code and add this functionality, but were absolutely unable to find where to begin. The string that is displayed: "The VPN connection failed" exists in none of the C files, and the en_GB.po file that DOES contain it specifies that its found in nm-ppp-starter.c... which doesn't appear to exist.

-Mike

Martin (martin-wetterstedt) wrote :

I would also like to see this feature!

I am connecting my home network to the net with a mobile broadband connection and shares it using network-manager. Every now and then I am disconnected, maybe due to issues with the mobile broadband provider. However, it would be great if network-manager could keep trying to reconnect, instead of me having to do that manually. I am depending on my internet connection for SIP telephony.

Martin (martin-wetterstedt) wrote :

I've now upgraded to Jaunty (9.04) and the same issue persists.

I've added NetworkManager to the list of affected packages. Perhaps network-manager-applet should be removed altogether from the list. It's NetworkManager itself that this issue affects, the applet just does the displaying.

I also added a link to the upstream bug report.

Changed in network-manager:
status: Unknown → Confirmed
Changed in network-manager:
importance: Unknown → Wishlist
Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Changed in network-manager:
importance: Wishlist → High
Thomas Hood (jdthood) on 2012-10-30
affects: network-manager-applet (Ubuntu) → network-manager (Ubuntu)
summary: - network-manager-applet auto-reconnect to VPN
+ Please auto-reconnect to VPN
Mark Wentland (wentland) wrote :

This bug has something to do with hereafter bug
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1158442
I think.

Changed in network-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.