Comment 6 for bug 314713

I'm having the same problem. ubuntu 8.10, fully updated (Apr 09). wired and wireless connections behave the same. Have had no response from linkedin. I have taken some additional "debugging" steps:
1. fully diabled ipv6 - no improvement
2. have tried using opera - no improvement
3. have tried using galeon - small improvement (?)
4. have tried specifying name servers manually - no improvement
5. have checked to make sure there is no local DNS caching... I'm not running a specific process to do this (no named) but perhaps something in gnome is doing this? network manager? LinkedIn has a help page suggesting flushing of the local dns cache as a solution to "slowness". This is my best lead. Especially after reading this possibly related post:
http://www.nabble.com/dns-cache-td189025.html

In common with other posters here I have D-Link equipment:

Wireless access point:
Product Page: DIR-615
Firmware Version: 2.25
Hardware Version: B2

ADSL modem:
Product: DSL-502T
ADSL Firmware Version: 4.03.03.00 - 3.02.00.03 - 3.02.06.00 Annex A - 01.07.02 - 0.49
ADSL Software Version: V2.00B05.AU_20060710

Hope some progress can be made. I need linkedin just now :-(