NetworkManager cannot handle both eth0 and ppp0 at the same time

Bug #290639 reported by Klaus Doblmann
104
This bug affects 19 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Wishlist
Nominated for 0.7 by igor
Nominated for Main by igor
network-manager (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by igor

Bug Description

Binary package hint: network-manager

Okay, so I have a pppoe-connection to my internet-provider which I connect to via a WLAN-AP that's connected with my home-network.

In network-manager I can set up my Ethernet (eth0) connection to connect to the local network and my ppp0e (ppp0) connection to the internet. When I click on network-manager, I only have radio-buttons to select the desired "wired connection" which only allows me to EITHER start eth0 OR ppp0. When I'm connected to the internet, I can't access the LAN and vice-versa.

The ony solution for me right now is to use pppoeconf and configure the eth0-connection via config file, which of course breaks network-manager.

What I am asking for is simple: Allow the use of more than just one "wired connection" in network-manager (ditch the radio buttons and make them "multiple choice"?)

here's my etc/network/interfaces: (comments were made by me for better readability here, they're not in the file itself)

##BEGIN interfaces
auto lo
iface lo inet loopback

auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider

auto eth0
iface eth0 inet static
       address 192.168.0.3
       netmask 255.255.255.0
       gateway 192.168.0.1
##END interfaces

System is 8.10 with all the latest updates,
network-manager is:
network-manager:
  Installiert: 0.7~~svn20081018t105859-0ubuntu1
  Kandidat: 0.7~~svn20081018t105859-0ubuntu1
  Versions-Tabelle:
 *** 0.7~~svn20081018t105859-0ubuntu1 0
        500 http://at.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

description: updated
description: updated
Revision history for this message
Alexander Sack (asac) wrote :

not a NM problem if you have things configured in /e/n/interfaces. remove everything from there or dont use NM.

Changed in network-manager:
status: New → Invalid
Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

I added the current interfaces-file for reference only, I had to configure the file because of the bug/missing feature in NM. I.e.: I ran into the described problem with an _empty_ interfaces file!

Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

To be a bit more explicit, here's what I did when I ran into this error:

- Install Intrepid (fresh install)
- Configure eth0 in NM
- Configure ppp0 (pppoe via eth0) in NM
- clicking on NMs icon in Gnomes tray only allows me to either select eth0 or ppp0, not both at a time as I would require it
- configured the interfaces-file to bypass the problems

I hope everything is clear now.

Revision history for this message
Alexander Sack (asac) wrote :

why do you need to select both? just ppp should be enough imo.

Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

If that worked, I wouldn't have filed a bugreport ;)

I just tried it again to reproduce the problem - same error. I configured ppp0 in NM as my internet connection and configured eth0 with a manual (local v4) IP. Then I looked at the status of the network by using the graphical gnome-nettool.

When I select eth0 as my connection when clicking on NMs icon, everything works. When I select ppp0 instead, I get an internet connection but the local eth0 only gets an IPv6 assigned (I didn't configure any IPv6 adresses) and it doesn't get the IPv4 I assigned to the connection. Obviously, Ican't access my IPv4 LAN with an IPv6-adress only.

I attached 2 ifconfig-files, one with ppp0 enabled, one with eth0

Revision history for this message
Alexander Sack (asac) wrote :

thats ok. i dont see where the problem is. if you use ppp0 eth0 cannot have an ip unless ppp0 goes through eth1 or so.

Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

Well, in that case it's curious that when I use the interfaces-file I included in the first post everything works ok with IPv4-adresses being assigned to eth0 AND ppp0 at the same time.

Since there doesn't seem to be a way to get this to work with the current NM (as you just confirmed) I'm now reverting to using the config-file.

Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

Here's the ifconfig-output after I deactivated NM (well, actually I didn't do anything as it conveniently refuses to start when I use the config file ;) ) and reverted to the said /e/n/interfaces.

It shows that my eth0 can actually have an ip even when ppp0 goes through it. That's the way it's always been for me in 7.04, 7.10, 8.04 and now in 8.10...

Revision history for this message
Alexander Sack (asac) wrote :

yeah ... still doesnt make much sense. if you want to use it that way, dont use NM - as you never used it since 7.04 ... its probably not a loss for you individually.

Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

Well, I did use NM on the previous versions of Ubuntu on my laptop to manage the wireless connetions. Wireless is not a requirement on my workstation at home but I can't (don't want to) upgrade from 8.04 to 8.10 on my laptop because of this (and more severe bugs/lack of features in 8.10). I'm just lucky that hardy will be supported for some time to come :D

I don't think I'm the only one one with a computer (think laptops) with only one ethernet port that wants to use LAN and internet via pppoe at the same time. Maybe there is a way to allow this in future versions of NM. If not, well, I'll find ways around it.
Thanks anyway for your time and explanations!

Revision history for this message
Alexander Sack (asac) wrote :

OK, lets open a bug in bugzilla.gnome.org then. could you do that as you are probably the one that can stand in for your use-case? give me your bug id so i can track that properly there too. thanks.

Changed in network-manager:
importance: Undecided → Wishlist
status: Invalid → Triaged
Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

Thanks for triaging :)

Bugreport filed @bugzilla.gnome.org: http://bugzilla.gnome.org/show_bug.cgi?id=559134

Changed in network-manager:
status: Unknown → New
Revision history for this message
der_vegi (m-may) wrote :

So you want to use a wireless bridge to start a ppoe connection over wireless like the description here: http://mail.gnome.org/archives/networkmanager-list/2008-November/msg00211.html ? I had the same problem when installing Intrepid on some friend's machines who are clients of a popular German provider that usually delivers the combination bridge + ADSL modem.
A possible workaround still using network-manager would be: Connect to the wireless network via n-m, giving yourself any static ip. Then run pppoeconf to configure your pppoe connection. This will change your /etc/network/interfaces so that this interface is not managed in n-m any more. Revert these changes by commenting out all the lines with the interface you configured. Then you can connect with n-m to the network and finally you use 'pon dsl-provider'.

Revision history for this message
der_vegi (m-may) wrote :

Oh, so it's eth0 and not wireless. But still, it could work like that.

Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

Yeah, that's exactly what I do. I set up a static IP for eth0 in the interfaces-config-file and used pppoeconf to set up the pppoe-connection. Works like a charm if you know how to use the tools and the config-file but it'd still be better for the "noob user" if setting up your connection via NetworkManager would work...

Revision history for this message
Klaus Doblmann (moviemaniac) wrote :

Well, okay, sorry, I overlooked something: While I could use NetworkManager now (after a few updates) to manage the wired network I refrain from doing so - I don't want NM to screw up all my stuff, I guess I'm a burned child... Unless I can manage both connections via NM (don't have to edit the eth0 anyway as it is connected to my static home-network) I'll leave everything as it is, never change a running system, right? :D

Changed in network-manager:
status: New → Confirmed
Revision history for this message
igor (igor.name) wrote :

Now that it comes to user-friendly system, it would be that the bug has been fixed.

Revision history for this message
Yigit Güneli (yiit) wrote :

Sam is living in an university campus.
He has a laptop which has only one ethernet port.
He plugs the cable and gets ip adress for eth0 from dhcp (192.168.1.x) He is able to access his roommate John's computer which has an ip of 192.168.1.y
Then he wants to connect to the internet, use NM for pppoe connection. Now he got 181.x.x.x ip for ppp0 and lost the connection to John's computer.
(He could have used first nm to connect to pppoe, then ifconfig eth0 to eth0 to have access for both networks. But he doesn't know and care about this command since he thinks nm does manage the all networks.)

He is unhappy with this problem, and tries windows.
He connects to lan with 192.168.1.x ip (only with dhcp)
He connects to wan with 181.x.x.x ip (with pppoe)
Now he has the access to both wan and lan since windows can handle pppoe and ethernet connection at the same time.

I am living in this campus. We have a DC server on 192.168.1.1-255 network, but we use pppoe for validating our username, password and mac adress. At this moment, Windows users could both surf the internet and use DC, but NM users can not do this in linux.

Changed in network-manager:
importance: Unknown → Wishlist
Revision history for this message
MaksimKa (netvin) wrote :

Need this feature too

Thomas Hood (jdthood)
summary: - [Intrepid] network-manager only allows to use either eth0 or ppp0
+ NetworkManager cannot handle both eth0 and ppp0 at the same time
Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

Upstream Network manager list discussion thread "Prioritizing between wwan and wlan" might be related to this problem.

tags: added: precise quantal
Revision history for this message
Anita Kuno (anteaya) wrote :

This bug looks a bit dusty, what is the status on this? I connect via eth0 to my ip provider which uses ppp0 and can't seem to connect using xenial. I'm wondering if this is the issue.

Right now I'm considering dropping back to Trusty which comes with an earlier version of network-manager and seems to be able to get me connected without an issue.

Would love to see an update to this bug. Thank you, Anita.

Changed in network-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.