Network Manager claims devices are unmanaged

Bug #280417 reported by Shai Inbal on 2008-10-08
60
This bug affects 6 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

* Installed ubuntu using alternate cd ( server install) .

* Network Manager's applet shows no connection. Clicking on it shows that all interfaces are in "unmanaged" mode so that Network Manager has no control over them. This occurs without the user making any changes to the interfaces. User has not manually set the devices into unmanaged mode. How to correct it in the Network Manager -> Edit Connections dialog is unclear.

Details:

$ cat /etc/network/interfaces
auto lo
iface lo inet loopback
iface eth0 inet dhcp

auto eth0

iface wlan0 inet dhcp
wireless-key XXXXXXXXX
wireless-essid XXXXXXXXXX

Mackenzie Morgan (maco.m) wrote :

Is nm-applet disabled when you try to connect or did you disable it after connecting failed? And how are you finding "Wireless Networks: Device is unmanaged" if nm-applet is disabled? I'm rather confused by your explanation.

Changed in network-manager:
status: New → Incomplete
Shai Inbal (thetunamaster) wrote :

It appears disabled becuase there's a red "x" on the tray icon (as shown in the screenshot. The mouse cursor is over it). I didn't disabled it or anything in the first place. Maybe the term "disabled" isn't right at this case.

What happened is that I updated, restarted and the tray icon was with an "X" on it, and by left-clicking on it I saw that I can't connect to a wireless network. Instead of listing the wireless networks (that appear when I use "iwlist"), I see a "device is unmanaged" line.

However the connection itself is fine. I'm connected to the internet using the "iwconfig" command.

I attached a more detailed screenshot.
Hope everything is clear now.

Mackenzie Morgan (maco.m) wrote :

I'm marking this confirmed since now that you explained it, yeah, this is exactly the bug I'm seeing.

description: updated
Changed in network-manager:
status: Incomplete → Confirmed
Mackenzie Morgan (maco.m) wrote :

I'm marking this Critical since some NM update just made the network unusable to anyone that doesn't know how to connect from the command line, and networking is pretty darned important.

Changed in network-manager:
importance: Undecided → Critical
Mackenzie Morgan (maco.m) wrote :

Whatever updates occurred in the last day set all the devices to managed=false in /etc/NetworkManager/nm-system-settings.conf

Change that and "sudo killall nm-system-settings" and it'll start working again.

Changed in network-manager:
status: Confirmed → Triaged
Mihai Chivu (mihai.chivu) wrote :

i had the same issue. I've managed to solve it by change managed=true in /etc/NetworkManager/nm-system-settings.conf. I have a wired DHCP connection. The wired connection appear as ifupdown (eth0) in Network Connection and I cannot change it or delete it (gave me the "Updating connection failed: nm-ifupdown-connection.c.82 - connection update not supported (read-only).." error. Also I have to mannualy type the mac adress . I can make a new wired connection and set it to manual configuration.
my curent ifconfig -a status:
eth0 Link encap:Ethernet HWaddr 00:16:e6:11:da:93
          inet addr:192.168.1.209 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::216:e6ff:fe11:da93/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:73361 errors:0 dropped:0 overruns:0 frame:0
          TX packets:55244 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:84071075 (84.0 MB) TX bytes:4529812 (4.5 MB)
          Interrupt:23 Base address:0xa000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:2114 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2114 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:111548 (111.5 KB) TX bytes:111548 (111.5 KB)

pan0 Link encap:Ethernet HWaddr 26:35:e8:d8:da:2c
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Bas Janssen (watcheroftheskies) wrote :

I had the same problem. Unfortunately, changing the nm-system-settings has made my wireless network connection unstable. I now lose the connection every 10 or 20 secs. Changing back to managed=false kills the connection completely.

Danny Adair (danny-adair) wrote :

I think this is a result of actions related to
https://bugs.launchpad.net/network-manager/+bug/256054

Danny Adair (danny-adair) wrote :

Editing /etc/network/interfaces to just keep the loopback and "auto eth0", followed by a reboot (not sure what needs bouncing) did the trick for me.
No further ado: The "ifupdown" device disappeared from nm-applet and "Static eth0" reappeared, configured as before.

Dana Goyette (danagoyette) wrote :

I have a bridge device in my (attached) Interfaces file, for any VMs I may run; this bridge device uses dnsmasq to serve up dns and dhcp, for NAT. However, with the latest few versions of NetworkManager... NetworkManager seems to try to connect as a _client_ on that interface... which I am the _host_ of. It appears in nm-applet as "Ifupdown (br0)". Switching to my eth0 entry works... but I really shouldn't have to do that manually. There seems to be no way to associate specific network profiles to specific network devices; the new NetworkManager feature would be totally useless on a computer with multiple wired NICs. Same for Mobile Broadband connections... no way to specify what modem to use.

Alexander Sack (asac) wrote :

Dana, there is a problem in the ifupdown plugin. it shouldnt load the br0 interface as a connection, but in your case that doesnt cause the problem.

You should really add the eth0 iface to your interfaces too. otherwise it will be managed by NM and NM will try to connect through it.

Alexander Sack (asac) wrote :

this isnt a bug from what i see. its a feature that devices configured in /etc/network/interfaces are "unmanaged" unless you enable the (experimental) managed=true in /etc/NetworkManager/nm-system-settings.conf.

Changed in network-manager:
status: Triaged → Invalid

Alexander,
We didn't fill in /etc/network/interfaces. We didn't do anything to
have this bug. All we did was install updates. Next thing we know,
networking is dead as far as NM is concerned. If a user manually got
themself into this situation, that wouldn't be a bug. The fact that
automatic updates took systems from working to "what the hell happened
to my networking?" is.

Dana Goyette (danagoyette) wrote :

Aah, new discovery: the latest version of NetworkManager (0.7~~svn20081008t224042-0ubuntu1) fixed my br0 issue for me; now br0 merely does not appear in NetworkManager. I actually do want eth0 to be managed by NetworkManager; the bridge contains only tap devices, not physical devices.
It looks like my issue may have been different from the topic of this bug.

Nicholas Skaggs (nskaggs) wrote :

I fixed this by doing the following. This happened because during the netinstall, my wireless network was used. Therefore network manager was not managing the connection. I edited /etc/network/interfaces to remove auto eth0. I then killed network manager and restarted it.

sudo nano /etc/network/interfaces
(leave only loopback)

sudo /etc/init.d/networking stop
ps aux | grep Net

root 6220 0.0 0.1 6400 2252 ? Ss 12:13 0:00 /usr/sbin/NetworkManager
root 7078 0.0 0.1 7696 3508 ? S 12:17 0:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf

sudo kill -9 6220 7078
sudo /etc/init.d/networking start

Changed in network-manager:
importance: Critical → Undecided
psypher (psypher246) wrote :

thanks guitara that worked for me but i had to still do sudo /etc/init.d/NetworkManager start to get it all up again

hirak99 (hirak99) wrote :

Sorry but it did not work for me. When I rebooted after removing "auto eth0", I lost Internet connection. I had to put the line back to get it working again.

Changed in network-manager:
status: Invalid → Confirmed
hirak99 (hirak99) wrote :

I have a wired connection to the Internet. Here's my /etc/network/interfaces (which is still giving the problem, and not connecting to Internet if I remove auto eth0):

$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.1

auto eth0

Vlado (vskoric) wrote :

sudenly I have problems with wireless device eth1, (using proprietary Broadcom STA wireless driver).
after startup under wireless networks in nm applet says - device is unmanaged and can not connect to wireless network
 i cant get things to work after disabling/enabling wireless card using laptop button and deactivating/activating proprietary broadcom sta wireless,removing/inserting wl module from/to kernel, restarting /etc/init.d/networking and networkmanager, but sometimes have to do it many times and I am not sure what actually "repairs" networking, when it starts to work than it is stable.

Did no changes in network configuration, wireless worked fine for ~ 1 month until before few days

from syslog, regarding eth1 when restarting network manager

NetworkManager: <info> eth1: driver is 'wl'.
NetworkManager: <info> eth1: driver does not support SSID scans (scan_capa 0x00).
NetworkManager: <info> Found new 802.11 WiFi device 'eth1'.
NetworkManager: <info> (eth1): exported as /org/freedesktop/Hal/devices/net_00_21_00_60_b0_00
NetworkManager: <info> (eth1): now unmanaged

Wired network works fine without any problems, applet looks same as for Shai Inbal at http://launchpadlibrarian.net/18351483/Screenshot.png

2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux

Vlado (vskoric) wrote :

correction
I CAN get things to work after disabling/enabling wireles........

Vlado (vskoric) wrote :

this time I got it back working with (it does not work after every boot):

killall nm-system-settings

I changed no configuration files ...

Mário Pinto (m+p) wrote :

After updating to 8.10 on my laptop and Desktop i have having problems with wireless.

in my Desktop the unmanneged problem appeared.I just did that file nm-system-sentings.config menaged=false, and rebooted, and it seamed to work.

the laptop didnt have the unmmaneged problem,just other wireless bug,card related, thou the file was with menaged=false.altered to true .but it seams as allways.

bigdaddy (mcomfy) wrote :

after i did "sudo killall nm-system-settings" it made my ethernet connection say it was unmanaged too but i can still connect to the internet using my ethernet but it says "no active connections found" in the manager so now both say device is unmanaged can you tell me what to do to fix this at least for my ethernet and for my wireless too

also how do you open the nm-system-settings.conf file so you can edit it cuz everytime i do "gksudo gedit /etc/networkmanager/nm-system-settings.conf" it comes up blank and if i open it manually from file system it says cannot save im not owner

i know what a newb huh?!?!?! sorry can you help me???

Alexander Sack (asac) wrote :

> gedit /etc/networkmanager/nm-system-settings.conf
-> thats NetworkManager not networkmanager here.

the default in /etc/NetworkManager/nm-system-settings.conf is:

[main]
plugins=keyfile,ifupdown

[ifupdown]
managed=false

bigdaddy (mcomfy) wrote :

yes but when i do that it comes up blank but when i go through the files system i can see it but cant edit it

Vlado (vskoric) wrote :

enter this line on terminal
sudo nano /etc/NetworkManager/nm-system-settings.conf
then enter your password if propmpted
make changes you want to and save them with ctrl+o
i have this on my laptop working ok:
~$ cat /etc/NetworkManager/nm-system-settings.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=disabled

2009/4/22 bigdaddy <email address hidden>

> yes but when i do that it comes up blank but when i go through the files
> system i can see it but cant edit it
>
> --
> Network Manager claims devices are unmanaged
> https://bugs.launchpad.net/bugs/280417
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “network-manager” source package in Ubuntu: Confirmed
>
> Bug description:
> Network Manager's applet shows no connection. Clicking on it shows that
> all interfaces are in "unmanaged" mode so that Network Manager has no
> control over them. This occurs without the user making any changes to the
> interfaces. User has not manually set the devices into unmanaged mode. How
> to correct it in the Network Manager -> Edit Connections dialog is unclear.
>
> Details:
>
> $ uname -a
> Linux Lenovo 2.6.27-6-generic #1 SMP Tue Oct 7 04:15:04 UTC 2008 i686
> GNU/Linux
>
> $ cat /etc/network/interfaces
> auto lo
> iface lo inet loopback
> iface eth0 inet dhcp
>
> auto eth0
>
> iface wlan0 inet dhcp
> wireless-key XXXXXXXXX
> wireless-essid XXXXXXXXXX
>
> $ apt-cache policy network-manager
> network-manager:
> Installed: 0.7~~svn20081004t225044-0ubuntu1
> Candidate: 0.7~~svn20081004t225044-0ubuntu1
> Version table:
> *** 0.7~~svn20081004t225044-0ubuntu1 0
> 500 http://archive.ubuntu.com intrepid/main Packages
> 100 /var/lib/dpkg/status
>

Paul Flint (flint) wrote :

Dear Mackenzie Morgan,

Thanks for what your wrote on 2008-10-08:

Whatever updates occurred in the last day set all the devices to managed=false in /etc/NetworkManager/nm-system-settings.conf

Change that and "sudo killall nm-system-settings" and it'll start working again.

This kills this bug.

I believe it is completely squashed in 9.04, but hey, I am a throwback.

Regards,

Flint

jomegatau (jmeyer-sonic) wrote :

FYI

I had this problem too and all of the suggestions above did not resolve it. What did fix it was to disable bluetooth PAN networking. I had enabled Personal Area Networking Profile without the bluetooth hardware USB device present. The daemon is not "supposed" to create an interface unless it finds the hardware is present but nonetheless a pan0 interface was present when I did an ifconfig.. By removing the bluetooth pan daemon from my system configuration the NetworkManager wireless problems all went away.

Vlado (vskoric) wrote :

Just experienced unmanaged device problem on my laptop and it came "out of nowhere", to use wireless I had to plug in another wireless usb adapter, I also deinstalled all blue-tooth stuff I had installed in case it interferes with wireless because it is on same adapter on myhp 6730b notebook :
lsusb
Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]

anyway integrated wireless would not work until I changed managed=disabled to managed=true in NM config file. But it did work for months on previous setting....

so what should be in that config file and what it means, I checked man page and http://projects.gnome.org/NetworkManager/ but didnt found info. I had few settings on that line working, managed=true,false,disabled, enabled
I am considering to remove network manager and use simple iwconfig script for wireless :-(.

Linux inf0011l 2.6.28-14-generic #46-Ubuntu SMP Wed Jul 8 07:41:18 UTC 2009 x86_64 GNU/Linux
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true

vito_lem (vito-lem) wrote :

"Whatever updates occurred in the last day set all the devices to managed=false in /etc/NetworkManager/nm-system-settings.conf

Change that and "sudo killall nm-system-settings" and it'll start working again."

Thanks, worked like a charm :D

pjcamp (pjcamp) wrote :

McKenzie Morgan:

Thanks. That fixed a problem I just had. Pre-update, networking, post-update no networks anywhere.

Alexander Sack:

"this isnt a bug from what i see. its a feature "

No, if an update silently kills the network for no obvious reason, it is a bug, not a feature.

Paul Flint:

No, I'm running 9.04 and so it is not completely squashed.

Alexander Sack (asac) wrote :

too many issues mixed in this bug. The initial reported bug is that the devices are unmanaged with the /etc/netwokr/interfaces file submitted:

iface eth0 inet dhcp
auto eth0
iface wlan0 inet dhcp
wireless-key XXXXXXXXX
wireless-essid XXXXXXXXXX

thats a feature. putting that into /etc/network/interfaces tells networkmanager to not manager your device; it means you opt into using ifup/ifupdown.

Changed in network-manager (Ubuntu):
status: Confirmed → Invalid
Alexander Sack (asac) wrote :

... and no, i dont know why you ended up with that config. If you would have just followed plain ubuntu those lines would be commented out in the feisty to gutsy upgrade.

Ruth Cheesley (ruth-cheesley) wrote :

I believe i experienced this problem on my HP G72 laptop with Kubuntu 11.10 as I ran the gui installer (as I needed to set up encryption) with a wireless connection.

I can confirm that following the steps suggested by Nicholas Skaggs (nskaggs) above, I was able to resolve this problem.

Ruth

Ruth Cheesley (ruth-cheesley) wrote :

that should read, used the non-gui installer, on the alternate CD.

description: updated
Nicolas Diogo (nicolasdiogo) wrote :

solved by editing a different (but similarly named) file in LinuxMint

see here:
http://forums.linuxmint.com/viewtopic.php?f=90&t=166299

file to edit:
gedit /etc/NetworkManager/NetworkManager.conf

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers