NM 0.7: GSM connect failed with "pppd_timed_out(): Looks like pppd didn't initialize our dbus module"

Bug #271446 reported by Andreas Schildbach on 2008-09-17
14
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

On intrepid, with the latest updates, NetworkManager fails to connect via GSM. One bubble appears, but after about 3 seconds it says "Disconnected".

I am using a Nokia E70.

Andreas Schildbach (schildbach) wrote :

These are the packages updated since it worked last time.

Andreas Schildbach (schildbach) wrote :
Andreas Schildbach (schildbach) wrote :

disabling "add_probe_for_v250_modems.patch" cures the problem

Alexander Sack (asac) wrote :

Can you please attach a SERIAL DEBUG log when having this patch applied?

Changed in network-manager:
status: New → Triaged
Alexander Sack (asac) wrote :

in case you dont remember: the define to do that is:

src/nm-serial-device.c:/* #define NM_DEBUG_SERIAL 1 */

Thanks!

Alexander Sack (asac) wrote :

please also add info about what phone you are using to the bug summary.

Antti Kaijanmäki (kaijanmaki) wrote :

We are investigating the problem, but in the meantime could you please remove any existing old mobile broadband connection settings using nm-connection-editor?
(right click on NM panel applet -> edit connections -> mobile broadband)

description: updated
Alexander Sack (asac) wrote :

Please also drop this patch (add_probe_for_v250_modems.patch) in debian/patches/ (replacing the original one), build and test.

Thanks!

With NM 0.7~~svn20080908t183521+eni0-0ubuntu4~nm1, without the patch from the previous comment, I get the following behaviour:

1st attempt of connecting shows no (visible) reaction from nm-applet, all following attempts succeed.

The "1st attempt" problem from the last comment was caused by me operating too fast (bug 272305).

I consider this problem fixed with NM 0.7~~svn20080908t183521+eni0-0ubuntu4~nm1 - thanks again!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.7~~svn20080908t183521+eni0-0ubuntu4

---------------
network-manager (0.7~~svn20080908t183521+eni0-0ubuntu4) intrepid; urgency=low

  * src/probe-modem.c: type_gsm, type_cdma and type_v250 variables are not
    properly reset when the retry: block is run twice in probe_modem. This can lead to
    unpredicted behaviour; the fix initializes those variables at the beginning of the
    retry: block; (LP: #271446)
    - update debian/patches/add_probe_for_v250_modems.patch

 -- Alexander Sack <email address hidden> Thu, 25 Sep 2008 03:27:46 +0200

Changed in network-manager:
status: Triaged → Fix Released
Luqe (luqeckr) wrote :

i'm using 0.7~~svn20081018t105859-0ubuntu2~nm4 on intrepid
and i got this bug

i'm using Sierra 875U usb modem

i provide my syslog..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers