libnm-glib-dev missing dependency on network-manager-dev

Bug #270584 reported by Martin Nowack on 2008-09-15
8
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Low
Alexander Sack
Nominated for Intrepid by Mark Lee
Jaunty
Low
Alexander Sack

Bug Description

Binary package hint: libnm-glib-dev

For the current intrepid version of libnm-glib-dev the dependency network-manager-dev is missing.
The result is pkg-config won't find libnm-glib.

Add the dependency network-manager-dev in libnm-glib-dev and update Standards-Version to 3.8.0

Changed in network-manager:
status: New → Confirmed
Alexander Sack (asac) wrote :

network-manager-dev depends on libnm-glib-dev and not the other way around? Why do we need a dependency in both directions?

Changed in network-manager:
status: Confirmed → Incomplete
Martin Nowack (martin-nowack) wrote :

I tried to compile knetworkmanager from svn it complained about missing libnm-glib(-dev) I installed it but configure couldn't find it, because pkg-config won't find it without network-manager-dev.
So, yes you are right with network-manager-dev depends on libnm-glib-dev but otherwise libnm-glib-dev is useless without network-manager-dev and this should be somehow indicted through the dependencies.

Alexander Sack (asac) wrote :

I removed network-manager-dev:

Removing network-manager-dev ...
asac@hector:/tmp/sponsoring$ pkg-config --list-all | grep libnm
libnm-util libnm_util - Convenience library for clients of NetworkManager
libnm_glib_vpn libnm_glib_vpn - Convenience library for clients of NetworkManager
libnm_glib libnm_glib - Convenience library for clients of NetworkManager

so it works! Unless I dont get the point, its knetworkmanager that should build-depend on network-manager-dev instead. Reassigning.

Alexander Sack (asac) wrote :

maybe its just really the knetworkmanager upstream configure message that is confusing. Please check for what .pc file knetworkmanager really checks when complaining in the reported way.

Martin Nowack (martin-nowack) wrote :

No it isn't, it checks for following needed packages
* hal
* libnm-util >= 0.7
* libnm_glib >= 0.7
* libnl-1
* dbusxml2qt3

so their are no direct network-manager dependencies but only indirect through libnm-util and libnm_glib.

On Tue, Sep 16, 2008 at 11:08:32AM -0000, Martin Nowack wrote:
> No it isn't, it checks for following needed packages
> * hal
> * libnm-util >= 0.7
> * libnm_glib >= 0.7
> * libnl-1
> * dbusxml2qt3

Did you assemble that list from looking at the configure.in code or
from what ./configure outputs?

 - Alexander

Martin Nowack (martin-nowack) wrote :

From the configure.in and as a result they were also shown in the configure script which was autogened and does not exist after checkout, so configure.in is the source and also should be not outdated.

Alexander Sack (asac) wrote :

On Wed, Sep 17, 2008 at 08:02:01AM -0000, Martin Nowack wrote:
> >From the configure.in and as a result they were also shown in the
> configure script which was autogened and does not exist after checkout,
> so configure.in is the source and also should be not outdated.
>

OK. Please attach the config.log that captured the failure. Thanks!

 - Alexander

Martin Nowack (martin-nowack) wrote :

so I updated to the latest nm packages, I removed the network-manager-dev package, run configure again and it failed (see attached config.log)

The nice message:

**************************************************
*
* KNetworkManager will not be built due to missing dependencies!
* Missing: libnm-glib
*
**************************************************

Running the following: pkg-config libnm_glib --print-errors

Package NetworkManager was not found in the pkg-config search path.
Perhaps you should add the directory containing `NetworkManager.pc'
to the PKG_CONFIG_PATH environment variable
Package 'NetworkManager', required by 'libnm_glib', not found

After installing network-manager-dev it works again, like a charm.
So NetwormManager is a dependency for libnm_glib at least currently. I looked at the current svn head of NetworkManager so it seams nm has not libnm-glib and libnm-util as dependency it is the other way around at least for the libnm-glib.

Alexander Sack (asac) wrote :

Thanks for the info. Will look into fixing that dependency.

 status triaged

On Wed, Sep 17, 2008 at 12:41:03PM -0000, Martin Nowack wrote:
> so I updated to the latest nm packages, I removed the network-manager-
> dev package, run configure again and it failed (see attached config.log)
>
> The nice message:
>
> **************************************************
> *
> * KNetworkManager will not be built due to missing dependencies!
> * Missing: libnm-glib
> *
> **************************************************
>
> Running the following: pkg-config libnm_glib --print-errors
>
> Package NetworkManager was not found in the pkg-config search path.
> Perhaps you should add the directory containing `NetworkManager.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'NetworkManager', required by 'libnm_glib', not found
>
> After installing network-manager-dev it works again, like a charm.
> So NetwormManager is a dependency for libnm_glib at least currently. I looked at the current svn head of NetworkManager so it seams nm has not libnm-glib and libnm-util as dependency it is the other way around at least for the libnm-glib.
>
> ** Attachment added: "config.log"
> http://launchpadlibrarian.net/17692826/config.log
>

 - Alexander

Changed in knetworkmanager:
status: Incomplete → Triaged
Bryce Harrington (bryce) on 2008-11-03
Changed in knetworkmanager:
importance: Undecided → Low
Steve Langasek (vorlon) wrote :

$ pkg-config --libs libnm_glib
Package NetworkManager was not found in the pkg-config search path.
Perhaps you should add the directory containing `NetworkManager.pc'
to the PKG_CONFIG_PATH environment variable
Package 'NetworkManager', required by 'libnm_glib', not found
$

Problem still present in intrepid and jaunty. Reassigning back to libnm-glib-dev, since this is confirmed to be an NM problem.

Alexander Sack (asac) wrote :
Changed in network-manager:
status: Triaged → Fix Committed

I'm unsubscribing the Sponsors' Team for now. Please re-subscribe when ready.

Bryce Harrington (bryce) wrote :

unsubbing sponsors since already is committed.

Steve Langasek (vorlon) on 2009-01-29
Changed in network-manager:
assignee: nobody → asac
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.7-0ubuntu2

---------------
network-manager (0.7-0ubuntu2) jaunty; urgency=low

  * ppp 2.4.5git transition: bump ppp-dev lower version bound to 2.4.5~
    - update debian/control

  * fix LP: #120363 - NetworkManager should support smartcard based
    certificate; we apply the backend patch contributed by David Smith
    - add debian/patches/lp120363_smartcard_pkcs11.patch
    - update debian/patches/series

  [ Alessandro Ghersi <email address hidden> ]
  * fix LP: #270584 add the dependency network-manager-dev in
    libnm-glib-dev; also fixes LP: #321473 liferea doesnt handle
    network-manager online/offline state
    - update debian/control
  * update Standards-Version to 3.8.0
    - update debian/control

  [ Steven S Danna <email address hidden> ]
  * fix LP: #283416 - add /etc/init.d/NetworkManager status; init
    script was fixed upstream; however, we take the lsb-base lower
    version bound from the bug (>= 3.2-14)
    - udpate debian/control

 -- Alexander Sack <email address hidden> Sat, 14 Feb 2009 22:16:12 +0100

Changed in network-manager:
status: Fix Committed → Fix Released
Mark Lee (malept) wrote :

Offhand, this seems like something really, really trivial to patch Intrepid's version of libnm-glib-dev with.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments