Ubuntu

Wireless only works when wpa_supplicant is run manually

Reported by James Le Cuirot on 2008-09-12
2
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by James Le Cuirot

Bug Description

Binary package hint: network-manager

I installed Intrepid Alpha 5 on this system today. I found that wireless would not work with the two USB adapters I tried. I blacklisted the built-in 802.11b adapter in case that was causing problems but it didn't help. Both USB adapters would see the network but neither would actually connect, despite having entered the correct WPA2 key.

I had some trouble with wpa_supplicant on another distro recently so I thought I'd try running it manually. I killed NetworkManager and the existing wpa_supplicant process and fired up a new instance with the wext driver and a minimal configuration. It authenticated immediately and I was able to get an IP with dhclient. This worked with both adapters. One is prism54-based and the other is rt73usb-based so this doesn't appear to be hardware-related. I am unable to get any information from wpa_supplicant when it is running under NetworkManager because dbus is used instead of the control interface. wpa_supplicant.log doesn't show anything interesting and neither does the syslog. I can only assume the problem lies with NetworkManager. The version I have installed is 0.7~~svn20080908t183521+eni0-0ubuntu2.

James Le Cuirot (chewi) wrote :
James Le Cuirot (chewi) wrote :

I realised that I could get debug output from wpa_supplicant by running it in dbus mode before starting NetworkManager. The log doesn't seem to show anything interesting though.

James Le Cuirot (chewi) wrote :

The problem is still present in 0.7~~svn20080908t183521+eni0-0ubuntu3.

James Le Cuirot (chewi) wrote :

I'm not sure what fixed it exactly but the latest round of updates did the trick. Thanks.

Changed in network-manager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers