NetworkManager crashed with SIGSEGV in strlen()

Bug #269474 reported by Niki Guldbrand on 2008-09-12
230
This bug affects 25 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager

I had been struggling to get nm to connect to my wireless network, and gave up on it, and did it manually (tried to reproduce bug #269039).
Then after an hour using the connection this happened (didn't touch nm in that time frame).

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/sbin/NetworkManager
Gconf:

NonfreeKernelModules: nvidia
Package: network-manager 0.7~~svn20080908t183521+eni0-0ubuntu2
ProcAttrCurrent: unconfined
ProcCmdline: /usr/sbin/NetworkManager
ProcEnviron: PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
Signal: 11
SourcePackage: network-manager
StacktraceTop:
 strlen () from /lib/libc.so.6
 ?? () from /lib/libdbus-1.so.3
 ?? () from /lib/libdbus-1.so.3
 dbus_message_iter_append_basic ()
 ?? () from /usr/lib/libdbus-glib-1.so.2
Title: NetworkManager crashed with SIGSEGV in strlen()
Uname: Linux 2.6.27-3-generic x86_64
UserGroups:

StacktraceTop:strlen () from /lib/libc.so.6
_dbus_marshal_write_basic (str=0x7429c8, insert_at=0, type=<value optimized out>,
_dbus_type_writer_write_basic (writer=0x7ffff77ab720, type=111, value=0x7ffff77ab6f8)
dbus_message_iter_append_basic (iter=0x7ffff77ab710, type=111, value=0x7ffff77ab6f8)
marshal_object_path (iter=0x7ffff77ab710, value=<value optimized out>) at dbus-gvalue.c:1452

Changed in network-manager:
importance: Undecided → Medium
Alexander Sack (asac) wrote :

how did you connect "manually"?

Changed in network-manager:
status: New → Incomplete

Hi Alexander.

What I did was removing the commenting for wlan0 (everything related to wlan0 was commented), then I used ifup/down to bring the interface up.

If you have more questions, just ask :-)

Glenn Brumfield (gbrumfield) wrote :

Confirmed. Hardy (host), Virtualbox 2.02, Intrepid daily build 17 Oct 08 (guest). Network manager crashed when I plugged in a USB wireless card/antenna (Realtek RTL 8187B_WLAN_adapter[0200]) but not until I assigned it to the guest it using the USB icon of the VM. Before selection it was probably assigned to the host.

I am still using the 2.6.24-19-generic kernel for Hardy.

Any news about this? Can someone test this with the final on Intrepid or even with an alpha of Jaunty (since Jaunty is shipping the final release of network-manager 0.7). Thanks in advance.

I did read that the bug had something related with an error of the realtek's
driver for the Linux OS.
So, I installed the ndiswrapper and added the realtek's driver for Windows
OS.

I didn't know to say if that problem went solved.

In soon I will test the alfa ubuntu and write here about my experience.

Vinicius

On Thu, Jan 15, 2009 at 12:46 PM, Martin Mai <email address hidden> wrote:

> Any news about this? Can someone test this with the final on Intrepid or
> even with an alpha of Jaunty (since Jaunty is shipping the final release
> of network-manager 0.7). Thanks in advance.
>
> --
> NetworkManager crashed with SIGSEGV in strlen()
> https://bugs.launchpad.net/bugs/269474
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Vinicius Marques Aguiar
*****************************
Grupo Guardians - LCC http://www.lcc.ufcg.edu.br
Grupo de Metodos Formais - GMF http://www.gmf.ufcg.edu.br
Laboratorio de Sistemas Distribuidos - LSD http://www.lsd.ufcg.edu.br

Universidade Federal de Campina Grande - UFCG http://www.ufcg.edu.br
Centro de Engenharia Eletrica e Informatica - CEEI
http://www.ceei.ufcg.edu.br
Unidade Academica de Sistemas e Computacao - UASC http://www.dsc.ufcg.edu.br

Glenn Brumfield (gbrumfield) wrote :

I'm running Ubuntu 8.10 in VirtualBox 2.0.6 on Ubuntu 8.04.1. I use an external Realtek RTL 8187B_WLAN_adapter[0200] card/antenna connected by USB to my notebook.

The latest 8.10 seems to run the RTL 8187B well in my VM by connecting the USB port directly to the Virtual Machine. Ubuntu 8.04 does not properly recognize the RTL 8187B, although it seemed to work for a while during the previous 8.04 kernel.

One issue still remaining is that if 2 wireless cards are connected, it can be a lengthy process for 8.10 to recognize the external card, list all of the wireless networks available to it and connect.

I need to run 2 wireless cards because the Atheros is built-in (minipci bus), and the Realtek (USB) is for use in my RV when connecting to a distant wireless network at a campground.

Kamus (kamus) wrote :

Can you check if this problem is still occurring in latest ubuntu version (network-manager)? if this problem persist please attach a Backtrace log for network-manager, you should see further information at: https://wiki.ubuntu.com/DebuggingNetworkManager

Regards

Glenn Brumfield (gbrumfield) wrote :

Sorry about the delay; I've only got one machine and it was tied up.

I ran Network Manager applet 0.7.995 from Ubuntu Karmic alpha 5 live-cd with 2 wireless cards enabled in hardware. It seemed to work OK. I also ran the applet with only the external card enabled. It seemed to be OK also, so I guess you can _mark this bug as solved_.

My installed system is Ubuntu 8.04 with network Manager applet 0.6.66 (I believe; I'm on the live-cd right now). It also seems to avoid the crash with SIGSEV in strlen(). It does not name the external card (Realtek 8187b) in the applet, calls it Unknown USB wireless (or some such.)

None of the applets are able to precisely direct one particular wireless card to one particular wireless router, in my experience, while connecting the other wireless card to a different wireless router. Or just as importantly, to disconnect one wireless card completely while leaving the other connected.

At the moment my work-around involves hardware - I go into BIOS to enable or disable the internal wireless card. I plug or unplug the USB wireless card. That does mean I have to completely shut down to change from external to internal or visa-versa.

Thank you for your time and involvement to improve wireless connectivity for all of us!

-----Original Message-----
>From: Kamus <email address hidden>
>Sent: Sep 3, 2009 4:01 PM
>To: <email address hidden>
>Subject: [Bug 269474] Re: NetworkManager crashed with SIGSEGV in strlen()
>
>Can you check if this problem is still occurring in latest ubuntu
>version (network-manager)? if this problem persist please attach a
>Backtrace log for network-manager, you should see further information
>at: https://wiki.ubuntu.com/DebuggingNetworkManager
>
>Regards
>
>--
>NetworkManager crashed with SIGSEGV in strlen()
>https://bugs.launchpad.net/bugs/269474
>You received this bug notification because you are a direct subscriber
>of the bug.

Kamus (kamus) wrote :

You are welcome sir , so according to your last message, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Karmic Koala.

Best regards

Changed in network-manager (Ubuntu):
status: Incomplete → Fix Released
tags: added: iso-testing
To post a comment you must log in.