0.7, 3G USB devices detected by usb-storage maybe need modeswitch

Bug #259028 reported by Arne Goetje on 2008-08-18
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
NetworkManager
Unknown
Medium
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager

A lot of USB 3G modems also carry a USB storage device, which contains the Windows drivers. These devices are detected as usb-storage and mounted automatically when plugged in.
In order to be able to use the modem instead, the USB product ID needs to be switched.
There is a tool to do this: http://www.draisberghof.de/usb_modeswitch/

Example (MU-Q101):
The device shows has a vendor ID of 0x0408 and a product ID of 0x1000 when plugged in.
It needs to switch the product ID to 0xea02 to enable the modem.
The following steps need to be done to do this:
1. When first plugged in, the device will be recognized as usb-storage device and automatically mounted. Unmount the device.
2. As root:
2.1. run usb-modeswitch
2.2. tell the kernel that the device product ID has changed:
2.2.1. get the port number where the device is connected by looking into the dmesg output, e.g.: 1-2
2.2.2. send a "suspend" to that device: echo "suspend" > /sys/bus/usb/devices/1-2/power/level
2.2.3. the device will wake up again and then carry the correct product ID (confirm with lsusb)
2.3. Load either the option module, or the usbserial module, depending on the device (for MU-Q101 usbserial is necessary): modprobe usbserial vendor=0x0408 product=0xea02
3. Now, 4 ttyUSB devices should have been created: ttyUSB0~3.
3.1. For MU-Q101 only: send the following AT command to /dev/ttyUSB2 (I currently do this manually with minicom): AT+CFUN=1
4. Use ttyUSB0 to connect with ppp.

The affected devices are listed in the attached usb_modeswitch.conf file.

Arne Goetje (arnegoetje) wrote :
Arne Goetje (arnegoetje) wrote :
Arne Goetje (arnegoetje) on 2008-08-22
description: updated
Runar Ingebrigtsen (ringe) wrote :

I have Telenor Mobile Broadband in Norway. My USB adapter identify as 0af0:6971 Option.

I can't get network-manager to recognize this as a modem even if I am able to load the usbserial module with it.

I am able to connect using HSOConnect, though. The problem with this approach is that HSOConnect doesn't integrate with network-manager, so not all GNOME programs accept the fact they're online. In Firefox I had to remove the "work offline" tick from the file menu to be able to surf.

Why wouldn't networ-manager connect through my ttyUSBs?

Alexander Sack (asac) on 2008-10-07
Changed in network-manager:
importance: Undecided → Medium
status: New → Confirmed
dpkirton (dan-kirton) wrote :

To get this to work with intrepid

hso 1.6 and udev mode switch from pharscape.

all now working

Laurent GUERBY (laurent-guerby) wrote :

I have a Orange USB Icon225 3G key, it has the same id has Runar above ("0af0:6971 Option"), so it's widespread in Europe.

It would be nice to have this working out of the box for intrepid.

I installed rezero from "PPA for Martijn van de Streek" it switched the mode from storage to modem, but no luck to have it working in network manager 0.7 yet.

https://edge.launchpad.net/~martijn/+archive

tom (tdeckert) wrote :

I've downloaded the latest usb_modeswitch.conf from the above webpage, but it does not list my modem,
which is a ZTE MF626. What do I do from here?

dav2dev (gin18) wrote :

it seems that also one Alcatel hspa usb modem needs to be switched from 1c9e:f000 (memory stick) to whatever is the correct product id for the modem, otherwise it will be useless.

i was googeling because ia have a ZTE MF626 USB modem and i already tried usb_modeswitch and modprobe usbserial and everithing worked fine... but the modem disconnected after 2 or 3 minutes... sometimes longer connections... may be signal... but the thing is that i sonetimes unplugged the device and plugged back and "lsusb" showed nothing... i tried "dmesg" and showed

[ 3408.164107] usb 1-2: new high speed USB device using ehci_hcd and address 21
[ 3408.276063] usb 1-2: device descriptor read/64, error -71
[ 3408.493089] usb 1-2: device descriptor read/64, error -71
[ 3408.708099] usb 1-2: new high speed USB device using ehci_hcd and address 22
[ 3408.821058] usb 1-2: device descriptor read/64, error -71
[ 3409.036085] hub 1-0:1.0: unable to enumerate USB device on port 2

and looking for the error messages i found a russian website with some interesting things... try google translator and it understands quite well... it seems to be that the kernel has some "UNUSUAL_DEV"... and the numbers...

# cat /usr/src/linux/drivers/usb/storage/unusual_devs.h
...

...UNUSUAL_DEV( 0x19d2, 0x2000, 0x0000, 0x0000,
                "Onda ET502HS",
                "USB MMC Storage",
                US_SC_DEVICE, US_PR_DEVICE, NULL,
                US_FL_IGNORE_DEVICE),

i think this is the kernel source and they edited (commented that devices) and rebuilded and rebooted... and it works fine or kind of... or at least dmesg don't show nasty messagges...

As a comment, after unplugged my usb modem, and waited like half an hour, y plugged it back and "lsusb" show the damn modem.... so i can use modeswitch and modprobe to get connected again...

is there any chance to get an update (after a fix for this off course)... that connects me automatically?

thanks,

hahaha, forgot the link to the russian forum... sorry

http://www.gentoo.ru/node/12140?page=1

cheers,

Another thing... after connecting the device... two minutes later... it spontaneously disconnected... this is the "dmesg"

              (here i plugged the modem...)

[ 5426.680063] usb 2-2: new full speed USB device using ohci_hcd and address 6
[ 5426.887282] usb 2-2: not running at top speed; connect to a high speed hub
[ 5426.907960] usb 2-2: configuration #1 chosen from 1 choice
[ 5426.923785] usb-storage: device ignored
               (until here is fine, but then...)

[ 6150.538432] usb 2-2: USB disconnect, address 6
[ 6156.260393] usb 1-2: new high speed USB device using ehci_hcd and address 32
               (and won't connect again...)
[ 6156.372080] usb 1-2: device descriptor read/64, error -71
[ 6156.588105] usb 1-2: device descriptor read/64, error -71
[ 6156.804074] usb 1-2: new high speed USB device using ehci_hcd and address 33
[ 6156.921067] usb 1-2: device descriptor read/64, error -71
[ 6157.137106] hub 1-0:1.0: unable to enumerate USB device on port 2

Regards,

Pawouek (pawouek) wrote :

Hi
I have got Toshiba g450 3g modem.
As Arne said - after plug in the device, system is mounting the memory disk in read-only (cdrom) mode.
After unmount and "sudo modprobe usbserial vendor=0x930 product=0xd45" it is possible to use the modem with wvdial, but not nm-manager.

Kamus (kamus) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.gnome.org/show_bug.cgi?id=594085

Changed in network-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in network-manager:
status: Unknown → Invalid
Przemek K. (azrael) wrote :

Ubuntu 9.10 (karmic) includes a modem-modeswitch tool, which works just like usb-modeswitch.
However, the modeswitch is not run automatically after connecting - users have to unmount the flash drive to use the modem.
I think that modem-modeswitch should be run automatically because these flash drives contain only windows drivers, which are useless for Ubuntu.

Przemek K. (azrael) wrote :

The issue that I've told about in my previous comment is currently being resolved in Bug #281335 (
ZeroCD devices (on 3G modems) are not ejected automatically).
I'm closing this bug now.
If you have a 3G modem that is not detected, then you should file a bug against "udev" package.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in network-manager:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.