apport package hook for network-manager

Bug #258552 reported by Matt Zimmerman on 2008-08-16
10
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Matt Zimmerman

Bug Description

Binary package hint: network-manager

I've created an initial apport hook for network-manager which will attach relevant system information to bug reports. This will be used for bugs submitted using the 'ubuntu-bug' command line tools as well as crash reports.

I'm submitting this bug itself using the hook so that you can see what it provides.

The hook should be installed as /usr/share/apport/package-hooks/source_network-manager.py

(this is an improved version of the one in bug 258546, apologies for the noise)

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
Package: network-manager 0.7~~svn20080720t224551+eni1-0ubuntu1
ProcEnviron:
 LC_COLLATE=C
 PATH=/home/username/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/sbin:/usr/sbin:/usr/games:/usr/lib/surfraw
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: network-manager
Uname: Linux 2.6.26-5-generic x86_64

Matt Zimmerman (mdz) wrote :
Matt Zimmerman (mdz) wrote :

It might also be useful to add:

'Gconf' : ['gconftool-2','-R','/system/networking']

to attach_commands.

Alexander Sack (asac) wrote :

Thanks. This is much appreciated.

1. I think the gconf output would be indeed worthwhile.
2. On top we might want the hal output for capabilities "modem" or "serial" which should catch most 3g devices.
3. Syslog could also contain "kernel:" output messages on top.
4. Also /var/log/wpasupplicant.log might be interesting to see (though given that it doesnt log timestamps - ouch - might not be as helpful as it could be).

Since we are on bzr, feel free to submit a bzr branch and request a merge through launchpad (which gets far higher prio in my mailbox). The development branch is:

 https://code.edge.launchpad.net/~network-manager/network-manager/ubuntu.0.7

If you want to implement the above, let me know. Otherwise, I'll take over from here.

Changed in network-manager:
importance: Undecided → Medium
status: New → Triaged
Alexander Sack (asac) wrote :

(milestoning to ensure that this gets into the archive on next push.)

Changed in network-manager:
milestone: none → intrepid-alpha-6
Matt Zimmerman (mdz) wrote :

I've published a branch at https://code.edge.launchpad.net/~mdz/network-manager/ubuntu.0.7 which includes #1, #3 and #4 (since they were easy).

#2 I added as a TODO in the script.

Changed in network-manager:
assignee: nobody → mdz
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.7~~svn20080908t183521+eni0-0ubuntu1

---------------
network-manager (0.7~~svn20080908t183521+eni0-0ubuntu1) intrepid; urgency=low

  [ Alexander Sack <email address hidden> ]
  * new upstream snapshot (Mon 2008-09-08 18:35:21 rev3504)
  * merge improved ifupdown system config implementation from main.eni branch;
    Mon 2008-09-08 20:47:20 +0200; rev 2828
  * Fix LP: #255839 - "0.7 N-M "system setting" does not work"; we create the
    /etc/NetworkManager/system-connections/ directory during package install now
    - update debian/network-manager.dirs
  * adjust patch due to changed ifupdown plugin source dir
    - update debian/patches/50_gcc43.patch
  * fix LP: #256480 - "network-manager 0.7 breaks resolvconf integration"; we
    pass --with-resolvconf=/sbin/resolvconf to configure.
    - update debian/rules
  * (proposed) fix LP: #259503 - "crashes when unplugging device (or unloading
    module)" - crash caused by idle handler accessing already freed device.
    We fix that for wireless and ethernet, which both were affected by
    properly refcounting the device gobjects.
    - add debian/patches/80_lp259503_access_to_freed_device_struct.patch
    - update debian/patches/series
  * drop ifupdown from Depends: - there is no sense to depend on replacements
    - update debian/control
  * drop patch applied upstream
    - delete debian/patches/05-debian_backend.patch
    - update debian/patches/series
  * Fix LP: #261688 - NetworkManager build dependency for "libdbus-glib-1-dev
    (>= 0.60)" incorrect; we adjust the version to >= 0.74.
    - update debian/control
  * bump shlibs requirements for libnm-util0 and libnm-glib0 packages to >=
    0.7~~svn20080908
    - update debian/rules
  * Fix - Networkmanager doesn't update resolv.conf when resolvconf is
    installed, but /etc/resolv.conf isnt a link; we fix that by honouring
    the resolvconf exit code and fall back to "normal" named behaviour in case
    it fails. This requires a resolvconf update which currently doesnt return
    a non-zero exit code when it fails in such a way.
    - add debian/patches/honour_resolvconf_exitcode.patch
    - update debian/patche/series

  [ Matt Zimmerman <email address hidden> ]
  * Add apport package hook (LP: #258552)
    - add debian/network-manager.links
    - add debian/source_network-manager.py
    - update debian/network-manager.install

 -- Alexander Sack <email address hidden> Tue, 09 Sep 2008 16:24:08 +0200

Changed in network-manager:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers