NM 0.7 - Nokia E70 is not detected

Bug #257725 reported by Andreas Schildbach on 2008-08-13
4
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Medium
Martin Pitt
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager

I'm testing network-manager 0.7~~svn20080720t224551+eni1-0ubuntu1 on Intrepid.

I'm trying to use a Nokia E70 for Dialup Networking, either through Bluetooth (preferred) or USB. None of the two is detected.

I'm expecting the E70 to show up under "VPN Connections / Configure VPN / Mobile Broadband". Strange place, seems to be a bug on its own. Why has "Mobile Broadband" got to do with VPN?

I've already paired the Phone, it shows up as "Bonded Devices" in the Bluetooth Prefs.

Alexander Sack (asac) wrote :

bluetooth is a different story. lets focus on USB for now.

is the lshal output the one you get while your phone is connected through USB? if not, pleaes attach that.

Further, attach the output of lsusb -v and lspci -v and your complete /var/log/syslog taken after you plugged in your phone and waited a while.

Thanks!

Changed in network-manager:
importance: Undecided → Medium
status: New → Incomplete
Andreas Schildbach (schildbach) wrote :

Ok, I'm now testing with USB cable attached and "PC Suite" selected on the phone (options: PC Suite, Data Transfer, IP Passthrough).

Andreas Schildbach (schildbach) wrote :
Andreas Schildbach (schildbach) wrote :
Andreas Schildbach (schildbach) wrote :
Andreas Schildbach (schildbach) wrote :
Changed in network-manager:
status: Incomplete → New
Alexander Sack (asac) wrote :

I uploaded a fixed hal-info package to the network-manager PPA. I uploaded to hardy and intrepid.

NetworkManager PPA is: https://edge.launchpad.net/~network-manager/+archive

Please verify that it works out of box now.

Changed in hal-info:
importance: Undecided → Medium
status: New → Fix Committed
Changed in network-manager:
status: New → Triaged
Andreas Schildbach (schildbach) wrote :

Thanks a lot. I upgraded to latest Intrepid + your PPA and tried again.

This time, I've got a GSM entry in the nm-applet pull-down menu and in the Mobile Broadband tab of VPN settings.

When I try to connect, I get a first green bullet all the time, sometimes a second, but always there is a Disconnect soon after that. I'm attaching a syslog of my tries.

Checking the settings for the GSM entry, I discovered that there is no UMTS connection type, only GPRS and GSM. Maybe that is a problem? I also tried to adapt the other settings, but that did no change the behaviour.

I'm also attaching a working wvdial.conf. This is what I use to connect to the Internet, although it is for connecting via Bluetooth. From my experience, the important settings for o2 Germany are the number to dial (*99***1#) and the Access Point (internet). Is there anything I need to change for USB?

Alexander Sack (asac) wrote :

maybe you need a dummy username/password for your provider. in case you find out what to set in the connection editor, please add that info to the provider info section on: https://wiki.ubuntu.com/NetworkManager/Hardware/3G

maybe look there for other options on how people got it to work

Alexander Sack (asac) wrote :

... of course, please keep us updated.

Alexander Sack (asac) wrote :

actually, please file an individual bug for your provider and then add that info to the provide table on https://wiki.ubuntu.com/NetworkManager/Hardware/3G.

This bug is about "detecting" ... which appears to be fixed by this hal-info patch. Thanks a lot!

Changed in network-manager:
status: Triaged → Fix Committed

Just for the records: After your patch, my device is detected as /dev/ttyACM0. I can do

$ gcom -d /dev/ttyACM0
SIM ready
Waiting for Registration..(120 sec max)
Registered on Home network: "26207"
Signal Quality: 11,99

This means that I can actually connect to the phone.

However, if I try to switch wvdial from Bluetooth (/dev/rfcomm0) over to /dev/ttyACM0, I get the following error:

$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyACM0: Device or resource busy
--> Cannot open /dev/ttyACM0: Device or resource busy
--> Cannot open /dev/ttyACM0: Device or resource busy

Maybe NetworkManager suffers from a similar problem? Anyway, I will open a new bug report as you requested.

Martin Pitt (pitti) wrote :

Patch needs to be taken from Alex' hardy PPA and commited to upstream and intrepid. Has the fdi been confirmed to work?

Changed in hal-info:
assignee: nobody → pitti
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

Setting to incomplete until verification that this worked, then I'll commit it upstream.

Changed in hal-info:
status: In Progress → Incomplete
Martin Pitt (pitti) wrote :

Nevermind, this model was also reported in bug 274952, committed upstream.

Changed in hal-info:
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20081001-0ubuntu1

---------------
hal-info (20081001-0ubuntu1) intrepid; urgency=low

  * New upstream snapshot with updated hardware data.
    - Add Lyra TH1100A music player. (LP: #213636)
    - Add Sony Walkman NWD-B105. (LP: #231470)
    - Add Samsung Q45 special keys. (LP: #212790)
  * Grabbed a bunch of Nokia/LG mobile modem FDIs contributed in Launchpad,
    cleaned them up, committed them upstream, add them as
    debian/patches/00upstream_mobile_modems.patch for now.
    (LP: #257045, #257725, #258197, #259041, #268482, #274952)
  * Drop 03_latitude_xt_tablet_keys.patch, upstream now.

 -- Martin Pitt <email address hidden> Thu, 02 Oct 2008 20:27:57 +0200

Changed in hal-info:
status: Fix Committed → Fix Released
Alexander Sack (asac) on 2008-10-03
Changed in network-manager:
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers