[ppa] nm-applet will not start

Bug #253948 reported by Matt Zimmerman on 2008-08-01
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

I upgraded to 0.7~~svn20080721t051503-0ubuntu1~nm1 from the network-manager PPA, and nm-applet no longer works. It displayed the attached error dialog (which repeated a few times) and then exited permanently.

Trying to start it from the command line, I see:

mizar:[~] nm-applet

** (nm-applet:27390): WARNING **: <WARN> applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service.
  Message: 'Connection ":1.5489" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file'

(nm-applet:27390): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
zsh: exit 1 nm-applet

ProblemType: Bug
Architecture: i386
Date: Fri Aug 1 13:29:56 2008
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: network-manager 0.7~~svn20080720t224551+eni1-0ubuntu1~nm2
PackageArchitecture: i386
ProcEnviron:
 LC_COLLATE=C
 PATH=/home/username/bin:/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/sbin:/usr/sbin:/usr/games:/usr/lib/surfraw
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: network-manager
Uname: Linux 2.6.26-4-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Matt Zimmerman (mdz) wrote :
Alexander Sack (asac) wrote :

did you upgrade the network-manager-gnome package as well?

Changed in network-manager:
status: New → Incomplete

On Thu, Aug 07, 2008 at 10:51:16AM -0000, Alexander Sack wrote:
> did you upgrade the network-manager-gnome package as well?

Yes, these were all standard upgrades. I haven't been able to reproduce the
problem, though. I think one of the underlying bits wasn't running
(NetworkManager, nm-system-settings, hal, ...)

--
 - mdz

Michael Rooney (mrooney) wrote :

Hello again asac; is there a reason this isn't Invalid in Ubuntu since the package is from a PPA? Or are we supporting this particular PPA via Launchpad? I can see where it might be valuable to you in your 0.7 progress, so I wasn't sure what you want BugSquaders to do with these bugs. Let me know, thanks, and great work so far on this! :)

tekstr1der (tekstr1der) wrote :

I get a similar error here:

marc@Megatron:~$ sudo nm-applet --sm-disable

** (nm-applet:6432): WARNING **: <WARN> applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service as it is already taken. Return: 3

(nm-applet:6432): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

Hi!

I get this error to if I run this command ("nm-applet --sm-disable") with my user.
But, if I run with "sudo", the applet start with this messages:

** (nm-applet:7378): WARNING **: No connections defined

** (nm-applet:7378): WARNING **: Could not retrieve dbus connections: Failed to execute program /lib/dbus-1.0/dbus-daemon-launch-helper: Success.

triklozoid (triklozoid) wrote :

Hello. For solution of this problem it is necessary to delete "superfluous" strings from/etc/network/interfaces. And to leave only:
auto lo
iface lo inet loopback

Alexander Sack (asac) wrote :

duplicate of bug 289466

Changed in network-manager:
status: Incomplete → Triaged
Alexander Sack (asac) wrote :

sorry misread ;). but i dont think that this bug still applies.

Changed in network-manager:
status: Triaged → Invalid
Alexander Sack (asac) wrote :

fwiw, if applet isnt showing up you might see #289466

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers