8.04 beta can not configure wifi WPA-PSK by GUI

Bug #217241 reported by Jury
4
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

Procedure:
 - 8.04 beta is loaded in LiveCD mode;
 - Wifi network requires WPA-PSK passphrase;

I tried to use GUI interface of Network Manager to connect to Wifi network.
The network is seen in networks list. GUI ask passphrase and try to connect. But can not establish the connection.

HW: ThinkPad Z60t (Atheros 11a/b/g Wireless LAN Mini PCI Express Adapter)

It is possible to connect the network by https://help.ubuntu.com/community/WifiDocs/WPAHowTo
but it is impossible by GUI.

After connection by WPAHowTo the Network Manager icon displays "not connected state" but the connection is present and works.

Revision history for this message
Caroline Ford (secretlondon) wrote :

Ubuntu->network-manager

Revision history for this message
Basilio Kublik (sourcercito) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the /var/log/syslog to your bug report as an attachment? Also you can submit more information for it by looking to https://wiki.ubuntu.com/DebuggingNetworkManager , Thanks in advance.

Changed in network-manager:
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Jury (jury-levykin) wrote :
Download full text (8.7 KiB)

/var/log/syslog is:
========================
May 11 15:36:28 ubuntu dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/ath0 for sub-path ath0.dbus.get.reason
May 11 15:36:28 ubuntu NetworkManager: <debug> [1210520188.507855] nm_device_802_11_wireless_get_activation_ap(): Forcing AP 'levnet'
May 11 15:36:28 ubuntu NetworkManager: <info> User Switch: /org/freedesktop/NetworkManager/Devices/ath0 / levnet
May 11 15:36:28 ubuntu NetworkManager: <info> Deactivating device ath0.
May 11 15:36:28 ubuntu avahi-daemon[8016]: Withdrawing address record for fe80::214:a4ff:fe36:966e on ath0.
May 11 15:36:28 ubuntu NetworkManager: <info> Device ath0 activation scheduled...
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0) started...
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) scheduled...
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) started...
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0) Stage 2 of 5 (Device Configure) scheduled...
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) complete.
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0) Stage 2 of 5 (Device Configure) starting...
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0/wireless): access point 'levnet' is encrypted, but NO valid key exists. New key needed.
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0) New wireless user key requested for network 'levnet'.
May 11 15:36:28 ubuntu NetworkManager: <info> Activation (ath0) Stage 2 of 5 (Device Configure) complete.
May 11 15:37:05 ubuntu NetworkManager: <info> Activation (ath0) New wireless user key for network 'levnet' received.
May 11 15:37:05 ubuntu NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) scheduled...
May 11 15:37:05 ubuntu NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) started...
May 11 15:37:05 ubuntu NetworkManager: <info> Activation (ath0) Stage 2 of 5 (Device Configure) scheduled...
May 11 15:37:05 ubuntu NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) complete.
May 11 15:37:05 ubuntu NetworkManager: <info> Activation (ath0) Stage 2 of 5 (Device Configure) starting...
May 11 15:37:05 ubuntu NetworkManager: <info> Activation (ath0/wireless): access point 'levnet' is encrypted, and a key exists. No new key needed.
May 11 15:37:07 ubuntu NetworkManager: <info> retry to connect to global supplicant socket (try=1)
May 11 15:37:07 ubuntu NetworkManager: <info> SUP: sending command 'INTERFACE_ADD ath0^I^Imadwifi^I/var/run/wpa_supplicant0^I'
May 11 15:37:07 ubuntu kernel: [ 953.795928] ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready
May 11 15:37:08 ubuntu kernel: [ 954.389092] NET: Registered protocol family 17
May 11 15:37:08 ubuntu NetworkManager: <info> SUP: response was 'OK'
May 11 15:37:08 ubuntu NetworkManager: <info> SUP: sending command 'AP_SCAN 1'
May 11 15:37:08 ubuntu NetworkManager: <info> SUP: response was 'OK'
May 11 15:37:08 ubuntu NetworkManager: <info> SUP: sending...

Read more...

Revision history for this message
Jury (jury-levykin) wrote :

My access point does not use DHCP. A static IP is used instead!

Revision history for this message
Alexander Sack (asac) wrote :

nm 0.7 in intrepid allows you lots of new things.

Changed in network-manager:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers