Ubuntu

Memory Leak in NetworkManager

Reported by Mehul J. Rajput on 2008-03-16
98
This bug affects 4 people
Affects Status Importance Assigned to Milestone
network-manager (Debian)
Fix Released
Unknown
network-manager (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by djtm
Hardy
Medium
Alexander Sack
Intrepid
Medium
Unassigned

Bug Description

Binary package hint: network-manager

I am using hardy on my laptop. If I keep it running for a day or two networkmanager takes close to 1GB of memory which I find wierd.

here is the output of my lspci.

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
15:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller

Alexander Sack (asac) wrote :

please attach your complete /var/log/syslog (taken when your network-manager process has been grown to ~1GB9.

Thanks,
 - Alexander

Changed in network-manager:
status: New → Incomplete

I can confirm the bug.I have the same wireless card (intel 3945). I can see clearly the amount of ram used by networkmanager growing steadily, about 80-100K every 30 seconds. Needless to say after one night, the amount of ram is a lot. It was using over 300 megs earlier today. Attached is my syslog.

Alexis ROBERT (alexis.robert) wrote :

I agree ! This is a VERY big issue. Here, I have 2 laptops : my old one, a core duo Macbook running Debian sid (1.25Go of RAM) and my brand new Dell XPS M1530 (4Go of RAM).

On the end of the day, on the Macbook, NetworkManager eats nearly all the RAM. On the end of the day, on the Dell XPS, NetworkManager eats 9.2% of the RAM, which result to 377Mo approx.

This means that the bug is not linked to Ubuntu, but more a global NetworkManager issue. Please note that I don't switch networks during this period : I stay on my WLAN using WPA2.

Please note that #214593 seems to be a duplicate of this bug.

Same thing here with the iwl3945 driver. After 3 days of uptime, NetworkManager uses 450MB of RAM on my system.

Changed in network-manager:
status: Incomplete → Confirmed
mosteo (public-mosteo) wrote :

Observed here too, in a Toshiba U200 laptop recently updated to Kubuntu Hardy. Didn't happened in Gutsy.

Attached is syslog when top reports this:

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
5332 root 20 0 379m 359m 1952 S 1 35.8 5:52.95 NetworkManager

I had suspended once a few minutes before sending this, but I have observed this without suspending or hibernating.

$ uname -a
Linux hostname 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
03:0b.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
03:0b.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
03:0b.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
03:0b.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller

I can confirm this bug. It uses 368 MB after 4 days uptime with a couple suspend/resumes.

Hardy,
b43 wireless
amd64
2.6.25.1-vanilla

Alexis ROBERT (alexis.robert) wrote :

Why are you all posting syslogs ? Don't you understand that here you have a *memory leak* which is generally a lack of some free()'s on some pointers ?

Btw, it's seems to be an upstream bug, not a bug in Ubuntu.

I *really* don't think that posting a syslog message will help.

mosteo (public-mosteo) wrote :

The second poster (who at least I presumed is some dev) requested them.

Alexis ROBERT (alexis.robert) wrote :

Ha ok, sorry.

Mike Williams (mikebwilliams) wrote :

Same problem here, with all updates applied. NetworkManager eats up as much RAM as I give it (I've seen +800MB). Using:
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Also, there's no need to reboot your computer, just:
sudo killall NetworkManager
sudo NetworkManager

I valgrind'ed it and it show some significant leaking, too.

otakuj462 (otakuj462) wrote :

Confirmed on my Inspiron 1300, WPA2, using an external USB adapter (not sure which chipset or drivers it's using). Computer has been on for over a week, no suspend or resume. NetworkManager is now consuming 1,736,628MB virtual memory.

jacob@jacob-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
jacob@jacob-laptop:~$ lsusb
Bus 005 Device 015: ID 062a:0000 Creative Labs Optical Mouse
Bus 005 Device 004: ID 079b:0062 Sagem
Bus 005 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 004: ID 041e:401f Creative Technology, Ltd Webcam Notebook
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 03f0:7e04 Hewlett-Packard
Bus 001 Device 001: ID 0000:0000
jacob@jacob-laptop:~$

otakuj462 (otakuj462) wrote :
Michael Gefen (gefenm11) wrote :

i would like to confirm the issue as well.
my system is up for 4 days, NetworkManager uses about 320MBytes om memory.

my devices:
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 82)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]
06:05.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
06:06.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

Bus 003 Device 005: ID 04d9:1400 Holtek Semiconductor, Inc.
Bus 003 Device 004: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 003 Device 003: ID 05e3:0605 Genesys Logic, Inc. USB 2.0 Hub [ednet]
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 001: ID 0000:0000

i don't attach syslog file, because mine is simmilar to the one posted above.

djtm (djtm) wrote :

This bug is more than three months old now. Does anyone know if something is being done about it? Is there a hotfix?

Could someone *please* try to make a patch so we can get out new packages?

Robert Knight (robertknight) wrote :

This may be related - Running NetworkManager under valgrind reported a memory leak
of about ~1MB after running NM for a few minutes with the return value of nm_dbus_escape_object_path_item,
which does not appear to be freed when called from nm_dbus_get_ap_from_object_path. Presumably this will increase
if left to run for an extended period of time with many access points available.

The size of the leak in this case will scale linearly depending on the number of access points.

Trivial patch attached.

Alexander Sack (asac) wrote :

fix by robert applied to development release branch.

Changed in network-manager:
status: New → Triaged
importance: Undecided → Medium
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.6.6-0ubuntu7

---------------
network-manager (0.6.6-0ubuntu7) intrepid; urgency=low

  * Fix LP: #124706 - "Cancel 'Wireles Key Required' dialog, can't connect on
    subsequent attempt"; we only blacklist and AP if receiving the secret
    ends up with a dbus error != NMI_DBUS_USER_KEY_CANCELED_ERROR
    - add debian/patches/44_lp124706_dont_blacklist_ap_on_user_cancel_key.patch
    - update debian/patches/series
  * Fix LP: #147119 - "network manager gives couldn't activate dialup service
    warning"; we properly set status to the return value of nm_spawn_process;
    thanks to bendis <email address hidden> for finding this glitch.
    - add debian/patches/45_debian_backend_fix_dialup.patch
    - update debian/patches/series
  * Fix LP: #203016 - "Memory Leak in NetworkManager"; Robert Knight found a
    leak the nm_dbus_net.c code.
    - add debian/patches/46_lp203016_nm_dbus_get_ap_from_object_path-leak-fix.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden> Thu, 26 Jun 2008 16:45:04 +0200

Changed in network-manager:
status: Fix Committed → Fix Released
djtm (djtm) wrote :

That seems to fix the problem for me in hardy as well. The package installs just fine.

Here you can read how to manually download the packages from intrepid repositories
http://linux-tipps.blogspot.com/2008/06/memory-leak-in-ubuntus-networkmanager.html

n1ywb (jeff-laughlin) wrote :

When an insignificant system daemon leaks 1gb of memory per day, it can have a significant impact on system performance and stability, and IMO it is not exactly "low" priority. When can we expect to see this fix released to updates?

I also have the same problem. 409 MiB after ~4 days uptime. I only have 512 MiB physical memory, and it really started to become a problem.

My wireless card is ipw2100,

$ sudo lspci |grep -i network
02:03.0 Network controller: Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04)

Glad to see the status is fixed in Ibex. Will it be backported to Hardy?

djtm (djtm) wrote :

I co-sign. We should get this into hardy quickly, as it's an old(since gutsy I believe) and very serious memory leak that almost every desktop user seems to experience and the fix available, tested and working.

Alexander, Robert could you please do something about it? Thanks!

I wrote a little Perl script which beeps and uses libnotify to show you when the leak is occurring (attached, argument is number of seconds between checks). I get a leak of about 4kb every 5 seconds, although there are periods of 20 seconds about once a minute where I get no leak.

It seems like the leak only happens when knetworkmanager is running. When I close knetworkmanager, the leak stops.

I found the best way to re-start network manager once it had grown too memory-hoggingly massive, was to do "sudo /etc/init.d/dbus restart". It will drop any wireless connections when you do this though. No idea what it does to Gnome and/or KDE - I've become addicted to fluxbox of late :-)

Robert Knight (robertknight) wrote :

> It seems like the leak only happens when knetworkmanager is running. When I close knetworkmanager, the leak stops.

As you can see from the patch above, the fault lies in part of the code that deals with communication between NM and other processes via DBus.

Changed in network-manager:
status: Unknown → New
Changed in network-manager:
status: New → Confirmed
Changed in network-manager:
status: Confirmed → Fix Released
Aaron Welch (welch-advomatic) wrote :

This completely swamps my macbook running hardy after about 5 hours (I'm in NY with a lot of access points around). I'll try connecting then shutting down knetworkmanager and see if that helps. I've seen it get as big as 500M resident, and >2G virtual! If I wait too long before rebooting or killing it, everything locks up and I have to force shutdown/reboot. Would be great to see that fix get applied to Hardy, what does the "Triaged" state mean? Is that purgatory, or is the fix in queue?

Jon Skanes (jon-skanes) wrote :

Please release the fix for Hardy. This is a real nuisance. Pppplllllllleeeeeeeaaaaaaaaaaaaaaassssssssssssssssssssseeeeeeeeeeeeeeeeeeeeeeeeeeeee.

Thanks,
Jon

I know this is a plattform for bugs, but it seems this major bug won't get fixed in hardy - please correct me if I'm wrong... that's why I post some lines for people who want to work with their Kubuntu without getting their memory eaten up... I recommend using wicd:

http://wicd.sourceforge.net/

I had no problems with it so far! It uses less memory and I reached all wireless lan's with it without problems!

Just add the following line to you /etc/apt/sources.list:

deb http://apt.wicd.net hardy extras

The only thing which you have to choose manually is the encryption of the wlan. Just start the GUI with:

/opt/wicd/gui.py

If you should have problems with it just restart the daemon and refresh the list with available wlans:

sudo /etc/init.d/wicd restart

djtm (djtm) wrote :

I have posted an easy quickfix: Just manually download and install the fixed packages as described here http://linux-tipps.blogspot.com/2008/06/memory-leak-in-ubuntus-networkmanager.html. A link to the amd64 package is included.

It would be nice if someone could post a link to the 32-bit package as well. Maybe it's possible to upload it here?

djtm (djtm) wrote :

I've found a 32-bit package as well and there are permanent links available on the post now (via rapidshare).

Rolf Kutz (vzsze) wrote :

I can confirm the bug and that the patch fixes the problem.

The Bishop (the-bishop) wrote :

why is the fix for the memory leak not backported to hardy?
it is a major issue when the machine is eaten up and a show stopper!
please update the hardy package soon!

djtm (djtm) wrote :

The maintainers *really* don't seem to care. We're pushing for it for months now. It's probably fixed in the next 8.10, but of course this is ridiculous.
Of course this qualifies as a bug fix for stable releases.

If more people would write about it maybe...
Everyone reading this:
Please blog about this bug or notify a Linux news page!

djtm (djtm) wrote :

Though I think I've said it before:
You can manually download and install the package version that fixes the problem.
Links to the fixed packages can be found here:
http://linux-tipps.blogspot.com/2008/06/memory-leak-in-ubuntus-networkmanager.html

djtm (djtm) wrote :

Oh and by the way:

There is absolutely no need to backport a patch, etc.

*all* that is necessary is to release the already available packages (version 0.6.6-0ubuntu7+) for hardy.
Nothing else. They work fine and fix the issue, the libraries are compatible.
They only need to be put into the right directory.

Using an up to date Intrepid i still have this bug as of september 26. Currently installed is networkmanager is 0.7 svn20080908t183521+eni0-0ubuntu4. About an hour after a reboot Network Manager is already eating 1.6gb of memory, and constantly using about 38% of my CPU (Athlon 64 x2 3800+)

I am using a wired connection, but a wireless card is installed on my system. output of lspci:

00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
03:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7300 GT] (rev a1)
04:05.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
04:09.0 Network controller: Texas Instruments ACX 111 54Mbps Wireless Interface

Oliver Horn (oliverhorn) wrote :

Hi everyone,

I confirm this Bug on Intrepid Final Release 64bit.

I have got 3,7GB RAM and 2GB Swap. In less than 1 hour Networkmanager fills the memory and freezes the computer. Only reset helps.

I shipped around it using wicd.

lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3300 Graphics
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
03:06.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
03:06.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
03:07.0 Network controller: Texas Instruments ACX 100 22Mbps Wireless Interface
03:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)

I used the wired gigabit ethernet, when the problem occured.

Beleriand

Alexander Sack (asac) on 2008-10-31
Changed in network-manager:
milestone: none → ubuntu-8.04.2
Arash (arashbi) wrote :

lenova T61
Such a big issue is not fixed after three months?

djtm (djtm) wrote :

It's a lot more than three months. The problem exists since 7.10.

registername (regname) wrote :

@Alexander Sack do you know how to get the bugfix you applied 5 months ago released for Hardy?

If you are not responsible then who is?

David Dallet (ddmdllt) wrote :

I noticed the same bug.

I'm running an up-to-date kubuntu 8.04 on the eee 901 (array.org's kernel).

Mykro (mykro76) wrote :

I can confirm this serious bug is still occurring on up-to-date Intrepid as of 2008-12-09.

Pentium 3.0Ghz hyperthreading 1GB RAM, 1.5GB swap, using wired but have wireless adaptor installed as well.

I was using Ubuntu 8.04 successfully. Did an upgrade to 8.10, and had this runaway NetworkManager problem. Since there were other issues related to a problematic upgrade, wiped hdd and installed a clean 8.10, which fixed the other issues but the NetworkManager problem reoccurred.

NetworkManager About dialog reports version 0.7.

Upon bootup NetworkManager process starts consuming memory, confirmed in System Monitor. Within 15-60 minutes it has consumed 600-800MB slowing the system to a crawl and eventually Ubuntu stops responding. Executing "sudo killall NetworkManager" before this point clears the consumed memory and returns the system to a stable ~200MB memory. Executing "sudo NetworkManager" causes the runaway memory problem to begin again.

Below is some output of /var/log/syslog when the NetworkManager process is running.

Dec 9 17:20:23 myksrv kernel: [ 463.776477] [<c02147d8>] ? cap_file_ioctl+0x8/0x10
Dec 9 17:20:23 myksrv NetworkManager: <WARN> nm_error_monitoring_device_link_state(): error monitoring wired ethernet link state: error occurred while waiting for data on socket
Dec 9 17:20:23 myksrv last message repeated 8 times
Dec 9 17:20:23 myksrv kernel: [ 463.776487] [<c01bf27b>] sys_ioctl+0x6b/0x70
Dec 9 17:20:23 myksrv NetworkManager: <WARN> nm_error_monitoring_device_link_state(): error monitoring wired ethernet link state: error occurred while waiting for data on socket
Dec 9 17:20:23 myksrv last message repeated 10 times
Dec 9 17:20:23 myksrv kernel: [ 463.776495] [<c0103f7b>] sysenter_do_call+0x12/0x2f
Dec 9 17:20:23 myksrv NetworkManager: <WARN> nm_error_monitoring_device_link_state(): error monitoring wired ethernet link state: error occurred while waiting for data on socket
Dec 9 17:20:23 myksrv last message repeated 6 times
Dec 9 17:20:23 myksrv kernel: [ 463.776503] =======================
Dec 9 17:20:23 myksrv NetworkManager: <WARN> nm_error_monitoring_device_link_state(): error monitoring wired ethernet link state: error occurred while waiting for data on socket
Dec 9 17:20:54 myksrv last message repeated 305320 times
Dec 9 17:21:44 myksrv last message repeated 495634 times
Dec 9 17:21:44 myksrv kernel: [ 543.947734] wlan0: association FAILED: peer sent Status Code 10 (Cannot support all requested capabilities in Capability Information field)
Dec 9 17:21:44 myksrv NetworkManager: <WARN> nm_error_monitoring_device_link_state(): error monitoring wired ethernet link state: error occurred while waiting for data on socket
Dec 9 17:22:00 myksrv last message repeated 159869 times

Mykro (mykro76) on 2008-12-09
Changed in network-manager:
status: Fix Released → Confirmed

On Tue, Dec 09, 2008 at 08:30:06AM -0000, Mykro wrote:
> ** Changed in: network-manager (Ubuntu Intrepid)
> Status: Fix Released => Confirmed
>

please dont reopen bugs ... i doubt you can confirm that this is
really the same bug ... (and its certainly not as the patch that fixed
this specific issue was applied).

Go aheade and open new bugs, but dont cause confusion by reopning
properly fixed things.

 affects ubuntu/network-manager
 status fixreleased

 - Alexander

djtm (djtm) wrote :

As much as you doubt he can confirm this is really the same bug
-- how can you be sure it's not?

network-manager is leaking memory for over a year now. We could start installing scripts that automatically track its memory usage and report leaks.
What about a generic "network-manager leaks memory" bug?
Then people can list all their different situations in separate bug reports.
I don't know if that'd make it a lot better...
I definitely understand the frustration this causes.

But hey, everyone - you hear him: open your own bugs. It can only bring more visibility to this issue...

How sad, though. Usually the open source process works pretty well... So anyone pulling his hair out over these annoying memory leaks: rest assured, this is an exception.

Alexander Sack (asac) wrote :

committed fix for 0.6.6 to hardy branch (rev 120); see related branches section of this bug for details.

Changed in network-manager:
assignee: nobody → asac
importance: Undecided → Medium
status: Triaged → In Progress
Alexander Sack (asac) wrote :
Changed in network-manager:
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

setting intrepid target to fix released again. The code has changed considerably and shouldnt be applicable.

Alexander Sack (asac) wrote :

uploaded network-manager_0.6.6-0ubuntu5.8.04.1 to ubuntu/hardy-proposed (rev 121 from lp:~ubuntu-core-dev/network-manager/ubuntu.0.6.x.hardy branch)

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in network-manager:
milestone: ubuntu-8.04.2 → none
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2008-12-17
Changed in network-manager:
milestone: none → ubuntu-8.04.2
Alexander Sack (asac) wrote :

On Tue, Dec 16, 2008 at 01:41:01AM -0000, djtm wrote:
> As much as you doubt he can confirm this is really the same bug
> -- how can you be sure it's not?
>
> network-manager is leaking memory for over a year now. We could start installing scripts that automatically track its memory usage and report leaks.
> What about a generic "network-manager leaks memory" bug?
> Then people can list all their different situations in separate bug reports.
> I don't know if that'd make it a lot better...
> I definitely understand the frustration this causes.
>
> But hey, everyone - you hear him: open your own bugs. It can only bring
> more visibility to this issue...
>
> How sad, though. Usually the open source process works pretty well... So
> anyone pulling his hair out over these annoying memory leaks: rest
> assured, this is an exception.
>

A fix for the "hardy" (0.6.x) memory leak should be in -proposed
now. Please help testing that package.

 - Alexander

Mykro (mykro76) wrote :

Sorry, I thought the branching mechanism at the top meant the issue could be tracked in multiple branches. I will move my comment and further discussion to #291074 which seems to be the Intrepid gathering place for this issue. Kind regards.

Alexander Sack (asac) wrote :

Mykro wrote:
> Sorry, I thought the branching mechanism at the top meant the issue
> could be tracked in multiple branches. I will move my comment and
> further discussion to #291074 which seems to be the Intrepid gathering
> place for this issue. Kind regards.
>
>

we still need someone to verify the -proposed package in hardy. if you
are running hardy and experience this, please upgrade to latest from
-proposed archive (instructions should be above).

Thanks!

Alexander Sack (asac) wrote :

ping ... anyone can confirm that the hardy-proposed package doesnt have the memory leak and still is as stable as before!

Thanks!!!

Adam Porter (alphapapa) wrote :

On Sat, Jan 3, 2009 at 13:06, Alexander Sack <email address hidden> wrote:
> ping ... anyone can confirm that the hardy-proposed package doesnt have
> the memory leak and still is as stable as before!

My system has enough memory that the leak was never a problem for me;
I only noticed it by accident. But I went ahead and installed the
package from hardy-proposed several days ago, and while I haven't been
checking for the leak, it seems ok right now. I can definitely
confirm that it's working perfectly, too.

Mehul J. Rajput (mehulrajput) wrote :

I am using intrepid and seems NetworkManager is no longer leaking. I have proposed and backport both enabled in my system.

Alexander Sack (asac) wrote :

On Sat, Jan 03, 2009 at 08:16:05PM -0000, Mehul J. Rajput wrote:
> I am using intrepid and seems NetworkManager is no longer leaking. I
> have proposed and backport both enabled in my system.
>

the request for testing was about hardy-proposed; not intrepid :)
... thanks anyway.

 - Alexander

PrinsEdje80 (eduardwestra) wrote :

If there is a memory leak remaining it's definitely not as bad as it was. I was severely affected by the leak and it seems to have been resolved.

Alexander Sack (asac) wrote :

On Sun, Jan 04, 2009 at 01:38:34AM -0000, PrinsEdje80 wrote:
> If there is a memory leak remaining it's definitely not as bad as it
> was. I was severely affected by the leak and it seems to have been
> resolved.
>

Guess we are ready to push this to -updates then ... thanks!

 - Alexander

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.6.6-0ubuntu5.8.04.1

---------------
network-manager (0.6.6-0ubuntu5.8.04.1) hardy-proposed; urgency=low

  * Fix LP: #203016 - "Memory Leak in NetworkManager"; Robert Knight found a
    leak the nm_dbus_net.c code.
    - add debian/patches/46_lp203016_nm_dbus_get_ap_from_object_path-leak-fix.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden> Tue, 16 Dec 2008 08:25:27 +0100

Changed in network-manager:
status: Fix Committed → Fix Released
David Dallet (ddmdllt) wrote :

I've taken it from -updates and it seems to work correctly now.

Thanks

David

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.