network-manager autokpgtest failure (nm.py)

Bug #2023183 reported by Roxana Nicolescu
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Status tracked in Noble
Lunar
Confirmed
Low
Unassigned
Mantic
Confirmed
Low
Unassigned
Noble
Fix Released
Low
Lukas Märdian

Bug Description

This fails only on arm64.

https://autopkgtest.ubuntu.com/results/autopkgtest-lunar/lunar/arm64/n/network-manager/20230522_141200_71ac4@/log.gz

To be determined if there is a bug in the package or linux kernel.

Related branches

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu Lunar):
status: New → Confirmed
Changed in network-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Danilo Egea Gondolfo (danilogondolfo) wrote :

As far as I can see, the only tests failing now are related to differences in MAC addresses on veth interfaces. I created an MP to address these failures. See more details in the related MP.

Changed in network-manager (Ubuntu Mantic):
status: New → Confirmed
Changed in network-manager (Ubuntu Lunar):
importance: Undecided → Low
Changed in network-manager (Ubuntu Mantic):
importance: Undecided → Low
Changed in network-manager (Ubuntu Noble):
importance: Undecided → Low
Revision history for this message
Lukas Märdian (slyon) wrote :

Thank you for your investigation. This sounds very related to this systemd/udev quirk:

https://github.com/canonical/netplan/commit/1413f0e7b8f4d068f817a009d998656de3224370

Lukas Märdian (slyon)
Changed in network-manager (Ubuntu Noble):
status: Confirmed → In Progress
assignee: nobody → Lukas Märdian (slyon)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.44.2-1ubuntu2

---------------
network-manager (1.44.2-1ubuntu2) noble; urgency=medium

  [ Lukas Märdian ]
  * network-manager.postinst: Skip unknown connection profiles (LP: #2039503)
  * d/network-manager.postinst: Drop reboot notification (LP: #2040292)

  [ Danilo Egea Gondolfo ]
  * debian/tests/nm_netplan.py
    Start Network Manager via systemd. The .service unit file sets
    ProtectSystem to true and we want to run the Netplan tests with this
    restriction enabled.
  * d/p/netplan/0003-Allow-the-NetworkManager-daemon-to-write-to-lib-netp.patch
    Allow-list /usr/lib/netplan so libnetplan can open files from that
    directory with writing permission. See LP: #2040153
  * debian/tests/control
    Add all the dependencies required by the nm_netplan.py tests.
  * debian/tests/network_test_base.py.
    Increase the waiting time between creating a veth pair and reading their
    MAC addresses. On arm64, the system is taking longer to change the MAC
    after creation, leading to failures due to differences in the expected
    and current MAC addresses. See LP: #2023183

 -- Lukas Märdian <email address hidden> Thu, 26 Oct 2023 11:48:18 +0200

Changed in network-manager (Ubuntu Noble):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.