[iwl3945] network manager not able to associate to hidden SSID (scan_capa = 0x0)

Bug #200950 reported by Rune Evjen on 2008-03-11
44
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.24 (Ubuntu)
High
Tim Gardner
Hardy
Medium
Tim Gardner
Intrepid
High
Tim Gardner
linux-ubuntu-modules-2.6.24 (Ubuntu)
High
Tim Gardner
Hardy
Medium
Stefan Bader
Intrepid
High
Tim Gardner
network-manager (Ubuntu)
High
Alexander Sack
Hardy
Undecided
Unassigned
Intrepid
High
Alexander Sack

Bug Description

SRU Justification:

Impact: The iwl3945 driver does not claim to be capable of scans (in the LUM code)

Fix: Take the fix used in LBM and Intrepid to LUM which adds the scan_capa framework.

Testcase: Wireless card is not able to connect to hidden SSIDs without this.

---

Binary package hint: network-manager

System:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

uname -a:
Linux rune-laptop 2.6.24-12-generic #1 SMP Sat Mar 8 02:29:24 UTC 2008 i686 GNU/Linux

After the latest network-manager update (early march 2008) using hardy, I cannot associate with any wireless networks.

network-manager version: 0.6.6-0ubuntu1.

Attatched is the logging to daemon.log by network-manager.

This happens on two laptops, one using Ubuntu hardy with ipw2200 wireless driver, and one using Kubuntu Hardy with iwl3945.
Logging attached is from the Kubuntu laptop.

Using the Ubuntu Hardy computer (running gnome), I sometimes can associate if I use the kill switch or disable and enable wireless. Seems like this all depends on timing though, I can only associate in something like one out of 10 tries.

Other computers have no problems associating with the AP.

Rune Evjen (rune-evjen) wrote :

using this bug to track the iwl3945 issue. maybe subscribe to bug 199679 which tracks the ipw2200 regression.

Thanks,
 - Alexander

Changed in network-manager:
status: New → Incomplete
Alexander Sack (asac) wrote :

importance high as its a hardware regression.

could you please attach your complete /var/log/syslog taken after a failed connect attempt?

Thanks.

Changed in network-manager:
importance: Undecided → High
Alexander Sack (asac) wrote :

... blocking hardy until i know if this is a problem for _all_ iwl3945 users.

Changed in network-manager:
milestone: none → ubuntu-8.04
Rune Evjen (rune-evjen) wrote :
stereoit (smol-robert) wrote :

Hi I believe I have very same problem. I CAN connect to open networks, but cannot to HIDDEN one (WEP+WPA). From the log I see it might be related to WPA supplicant:

Mar 11 22:56:35 rsmol-laptop NetworkManager: <info> Activation (wlan0_rename/wireless): access point 'NetTest' is encrypted, and a key exists.
  No new key needed.
Mar 11 22:56:37 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=1)
Mar 11 22:56:37 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=2)
Mar 11 22:56:37 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=3)
Mar 11 22:56:37 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=4)
Mar 11 22:56:38 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=5)
Mar 11 22:56:38 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=6)
Mar 11 22:56:38 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=7)
Mar 11 22:56:38 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=8)
Mar 11 22:56:39 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=9)
Mar 11 22:56:39 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=10)
Mar 11 22:56:39 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=11)
Mar 11 22:56:39 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=12)
Mar 11 22:56:40 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=13)
Mar 11 22:56:40 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=14)
Mar 11 22:56:40 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=15)
Mar 11 22:56:40 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=16)
Mar 11 22:56:41 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=17)
Mar 11 22:56:41 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=18)
Mar 11 22:56:41 rsmol-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=19)
Mar 11 22:56:41 rsmol-laptop NetworkManager: <info> Error opening supplicant global control interface.
Mar 11 22:56:41 rsmol-laptop NetworkManager: <WARN> real_act_stage2_config(): Activation (wlan0_rename/wireless): couldn't connect to the supplicant.

Rune Evjen (rune-evjen) wrote :

Note:

My wireless AP does not broadcast the SSID. I will test with Broadcast enabled to see if nm can associate.

Rune Evjen (rune-evjen) wrote :

Network Manager can associate fine with my AP after I enabled SSID broadcast.

Attached is the syslog after enabling SSID broadcast on the AP.

Regards

Rune

Rune Evjen (rune-evjen) wrote :

Note: Association problem described in the bug report for both computers (Kubuntu/iwl3945 and Ubuntu/ipw2200) are solved by enabling SSID broadcast.

Alexander Sack (asac) wrote :

iwl3945 driver appears to claim to not support scan_capa:

 "Mar 11 22:45:17 rune-laptop NetworkManager: <info> wlan0: driver does not support SSID scans (scan_capa 0x00). "

this appears to be a bug, because network manager falls back to stupid mode and sets "AP_SCAN 2" if the driver doesn't claim to support scan_capa. However AP_SCAN 1 should work for it from what i can tell and once the driver properly exposes that this should be fixed.

Adding linux-ubuntu-modules as target. and milestoning as well.

Thanks,
 - Alexander

Changed in network-manager:
status: Incomplete → Triaged
Alexander Sack (asac) wrote :

milestoning as this breaks connecting the hidden networks for network manager (which is a regression over gutsy)

Changed in linux-ubuntu-modules-2.6.24:
importance: Undecided → High
milestone: none → ubuntu-8.04
status: New → Confirmed
Alexander Sack (asac) wrote :

looks like iwlwifi ships its own mac80211 module, which hasn't received the scan_capa patch yet.

The bits missing might be:
(http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy.git;a=commitdiff;h=629606072001a6b3cae6f1e3790435558c385783)

Alexander Sack (asac) wrote :

tim, please take a look if using the iwlwifi_mac* module is really the right thing todo here (why can't we use the pristine kernel one?) ... if we have to use that, please include the scan_capa bits above.

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → timg-tpi
DSHR (s-heuer) wrote :

On my Lenovo X60s I cannot connect to my hidden network too.

I'm attaching the relevant part of my syslog (successful connect - AP not hidden)

Alexander,

Please note that I also have a problem with Hidden SSID on another computer,
running updated Ubuntu Hardy with the ipw2200 chipset, see bug
https://bugs.launchpad.net/bugs/199679.<https://bugs.launchpad.net/bugs/199679>

So I have the same problems with two different computers with different
Wireless chipsets after the n-m update.

Regards,

Rune

Martin Pool (mbp) wrote :

I changed my network to be non-hidden and to use WPA2 PSK. I still cannot connect using NM. I can connect by disabling nm then running wpa_supplicant and dhclient manually. (This is on an X61s with 3945ABG rev 2.)

Alexander Sack (asac) wrote :

martin, if your (non-hidden) issue persists even after reloading the iwl3945 module and restarting network manager, please open a separate bug and attach your complete /var/log/syslog of a failed connect attempt.

maybe msg me the bug id to get your bug a good triaging start :)

I have this problem with b43 chipset:
syslog:
Mar 22 13:33:42 daniele-laptop NetworkManager: <info> Activation (wlan0): waiting for device to cancel activation.
Mar 22 13:34:12 daniele-laptop last message repeated 29 times
Mar 22 13:35:12 daniele-laptop last message repeated 57 times
Mar 22 13:36:13 daniele-laptop last message repeated 58 times
Mar 22 13:37:13 daniele-laptop last message repeated 56 times
Mar 22 13:38:12 daniele-laptop last message repeated 54 times
Mar 22 13:39:01 daniele-laptop last message repeated 45 times
..
and network manager cant connect

lukeLuck (lucorsel) wrote :

It appears a known issue in the iwl3945 driver, committed patch 3/13/2008 in iwlwifi development.
patch seems potential add candidate for hardy. It does work in my case with Hidden SSID.

http://git.kernel.org/?p=linux/kernel/git/rchatre/iwlwifi-2.6.git;a=commit;h=6e6869e8aae7a6af8792e6f7b2ae2622ab201872

---cut
Indirect scanning ('iwlist scan') should report information about
hidden APs. When an AP is hidden it does not respond to active scanning,
we thus have to use passive scanning to locate these APs.

This fixes: http://bughost.org/bugzilla/show_bug.cgi?id=1499
---cut

Steve Langasek (vorlon) wrote :

Daniele,

What version of hal do you have installed? From your syslog it appears that network-manager is looping, so this is more likely to be bug #204768. In any case, your problem is not related to this bug, since you're using a different wireless driver.

Sasquatch (sasquatch) wrote :

This problem is Network manager related. I don't use Network manager and at home my ssid is hidden. It takes some time, but eventually wpa_supplicant can connect without any problem. This is with module 1.1.17kds from the 2.6.24-5 modules, and at http://www.linuxwireless.org/en/users/Download there is a newer version. With that module version, 1.2.26k, it works just fine. Scanning however doesn't if you use 'iwlist scan'. Scan results from wpa_supplicant do work.

Note:
Module 1.2.0 never worked for me.

Alexander Sack (asac) wrote :

please test the network manager branch now associated with this bug. it adds workarounds for iwl3945 and iwl4965 (among others).

Instructions on how to get it to your disc can be found at the branch url given

to build you can just run

 $ debuild -b

out of the branch directory. use dpkg -i to install the packages for testing.

If you still cannot connect to hidden SSID, please attach your complete /var/log/syslog to the bug and state clearly if you could connect to hidden networks in gutsy.

Alexander Sack (asac) wrote :

one more addition: to install the build dependencies to build the branch, run:

 sudo apt-get build-dep network-manager

Alexander Sack (asac) wrote :

note: the branch has been reported to fix hidden ssid for ipw2200 in bug 199679. please give feedback for your driver/chipset as well.

Changed in linux-ubuntu-modules-2.6.24:
assignee: timg-tpi → ben-collins
status: Confirmed → Fix Committed
DSHR (s-heuer) wrote :

After switching back to hidden SSID and rebooting, my wlan is now working!

Tested with iwl3945 on Lenovo Thinkpad X60s.

Do you need any syslog output?

Thanks a lot for your hard work on this!

Martin Pool (mbp) wrote :

Works for me, thanks very much!

Note to others who may be testing this: you will get an error at the end of the debuild due to being unable to sign the packages; you can still install them though.

Alexander Sack (asac) on 2008-03-26
Changed in network-manager:
assignee: nobody → asac
Reed Lipman (rmlipman) wrote :

I can confirm this working with my iwl3945 on a system76 gazp3.

Martin Pool (mbp) wrote :

My previous message was unclear: with the version I installed I could connect to an advertised wpa2 psk network, but _not_ to a hidden non-encrypted network. I was also unable to connect to a wired network, but rebooting fixed that and it might be a different problem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.6.6-0ubuntu4

---------------
network-manager (0.6.6-0ubuntu4) hardy; urgency=low

  * fix hidden networks for chipsets that do not have scan_capa enabled
    driver. (LP: #50214, #200950, #203793, #199679). The following
    behaviour is now implemented:
      * use scan_ssid 1 with AP_SCAN 1 for all scan_capa_ssid drivers
      * use scan_ssid 1 with AP_SCAN 1 for all drivers with buggy
        scan_capa_ssid and buggy ap_scan and explicitly set essid through
        wireless extensions to help driver to find bssids of hidden ssid
          Drivers with buggy scan_capa_ssid: ipw2200
          Drivers with buggy ap_scan 2: iwl3945, iwl4965
      * use AP_SCAN 2 for all other drivers and set essid through wireless
        extensions forcefully.
        - update debian/patches/42b_fix_ap_scan_hidden.patch
    - add debian/patches/42b_fix_ap_scan_hidden.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden> Fri, 28 Mar 2008 10:38:42 +0100

Changed in network-manager:
status: Triaged → Fix Released
Steve Langasek (vorlon) on 2008-03-28
Changed in linux-ubuntu-modules-2.6.24:
milestone: ubuntu-8.04 → none
Tim Gardner (timg-tpi) wrote :

Updated iwlwifi to 1.2.25. Note the move to linux-backports-modules. This version contains LED support as well as SCAN_CAPA.

Changed in linux-ubuntu-modules-2.6.24:
assignee: ben-collins → timg-tpi
milestone: none → ubuntu-8.04
Steve Langasek (vorlon) on 2008-03-28
Changed in linux-backports-modules-2.6.24:
milestone: ubuntu-8.04 → none
Brian Burg (bburg) wrote :
Download full text (7.9 KiB)

Also confirming newest iwl3945 driver (1.2.26k) fixes hidden network connections by implementing SCAN_CAPA. So the workaround doesn't really do anything with the new driver, I guess.

Mar 30 12:45:01 bburg-laptop NetworkManager: <info> Device eth1 activation scheduled...
Mar 30 12:45:01 bburg-laptop NetworkManager: <info> Activation (eth1) started...
Mar 30 12:45:01 bburg-laptop NetworkManager: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
Mar 30 12:45:01 bburg-laptop NetworkManager: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) started...
Mar 30 12:45:01 bburg-laptop NetworkManager: <info> Activation (eth1) Stage 2 of 5 (Device Configure) scheduled...
Mar 30 12:45:01 bburg-laptop NetworkManager: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) complete.
Mar 30 12:45:01 bburg-laptop NetworkManager: <info> Activation (eth1) Stage 2 of 5 (Device Configure) starting...
Mar 30 12:45:01 bburg-laptop NetworkManager: <info> Activation (eth1/wireless): access point 'PAL2.0' is encrypted, and a key exists. No new key needed.
Mar 30 12:45:02 bburg-laptop kernel: [ 738.766726] ACPI: PCI interrupt for device 0000:0c:00.0 disabled
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: sending command 'INTERFACE_ADD eth1^I^Iwext^I/var/run/wpa_supplicant0^I'
Mar 30 12:45:02 bburg-laptop kernel: [ 738.854942] ACPI: PCI Interrupt 0000:0c:00.0[A] -> GSI 17 (level, low) -> IRQ 17
Mar 30 12:45:02 bburg-laptop kernel: [ 738.855086] PM: Writing back config space on device 0000:0c:00.0 at offset 1 (was 100102, writing 100106)
Mar 30 12:45:02 bburg-laptop kernel: [ 740.750121] ADDRCONF(NETDEV_UP): eth1: link is not ready
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: response was 'OK'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> kernel_driver for non broadcast check: iwl3945 (has_scan_capa_ssid=1)
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> Fully supported scan_capa_ssid mode.
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: sending command 'AP_SCAN 1'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: response was 'OK'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: sending command 'ADD_NETWORK'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: response was '0'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 scan_ssid 1'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: response was 'OK'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 ssid 50414c322e30'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: response was 'OK'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 proto WPA'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: response was 'OK'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 key_mgmt WPA-EAP'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: response was 'OK'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 eap PEAP'
Mar 30 12:45:02 bburg-laptop NetworkManager: <info> SUP: respo...

Read more...

Alexander Sack (asac) wrote :

good. i'll remove the hacks once i have received positive feedback for iwl4965 as well.

Alexander Sack (asac) wrote :

oh ... since its in backport modules we have to keep the tweaks.

bardusco (bardusco) wrote :

I can confirm this working with my iwl4965 since today's(Apr, 1, 2008) update.

HP Compaq 6910p
Ubuntu Hardy Beta, updated from a fresh install of 7.10
Linux bardusco-laptop 2.6.24-12-generic #1 SMP Wed Mar 12 23:01:54 UTC 2008 i686 GNU/Linux

network-manager 0.6.6-0ubuntu5
libnm-glib0 0.6.6-0ubuntu5
libnm-util0 0.6.6-0ubuntu5
wpasupplicant 0.6.0+0.5.8-0ubuntu2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.24 - 2.6.24-14.11

---------------
linux-backports-modules-2.6.24 (2.6.24-14.11) hardy; urgency=low

  [Ben Collins]

  * iwlwifi: Update to iwlwifi-1.2.25 and mac80211-10.0.4
    - LP: #200950
  * ubuntu: Slight cleanups to module hiearchy and Makefiles
  * mac80211: Enable LED triggers
  * iwlwifi: Add LED trigger support (rx and tx only)
    - LP: #176090

 -- <email address hidden> Wed, 02 Apr 2008 06:59:04 -0600

Changed in linux-backports-modules-2.6.24:
status: Fix Committed → Fix Released
Ryan Novosielski (novosirj) wrote :

Wanted to comment on this, as what I'm reading here does not totally match my experience.

[ 121.966837] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.25

First off, NetworkManager does not report scan_capa, even though above I read that this driver now supports it:

NetworkManager: <info> wlan0: Device is fully-supported using driver 'iwl3945'.
NetworkManager: <info> wlan0: driver does not support SSID scans (scan_capa 0x00).

In addition, LP #176090 claims that now iwlwifi has LED trigger (RX and TX support). On my machine, the LED does come on (which is really a first for iwlwifi, so I'm happy about that), but it does not do anything once it has come on. In addition, it does not appear as if the kill switch actually is able to kill the wireless -- flipping the switch leaves the light on, but it does disable networking.

bronto (mmarongiu) wrote :

Hello

I erroneously reported in #200952. Please bear with me, it was my first bug report!

Same problem here with Intel 3945 ABG. I am using an HP Compaq nx7400. The wireless button LED is on.

I am configuring a network with a given ESSID and WEP hex key using network manager. The AP is hidden, and since is our company's wireless network, I can't unhide it to test.

We have two cases here I am trying to isolate.

Case 1) Despite the interface gets a valid configuration (addresses for DNS servers and gateway are correct; interface IP, netmask and broadcast addresses are correct, too), I can't even ping the gateway (ping results in an "Destination host unreachable" error).

Case 2) the network interface doesn't even get a valid address

Doing a /etc/init.d/networking restart makes the wireless interface usable

Please ask me anything useful to solve this bug (files, command outputs...) and I'll be happy to help.

Ciao
--Marco

bronto (mmarongiu) wrote :

Forgot to say: I am using Hardy, so the bug is still there in the final release...

Ciao
--Marco

I'm still having this issue. I'm running

linux-backports-modules-hardy - 2.6.24.19.21
network-manager - 0.6.6-0ubuntu5

Reading the daemon.log file it still reports
wlan0: Device is fully-supported using driver 'iwl3945'
wlan0: driver does not support SSID scans (scan_capa 0x00)

The following is the relevant output from lspci:
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Any ideas on how I can fix this?

On Thu, Jun 12, 2008 at 12:44:54AM -0000, peitschie wrote:
> I'm still having this issue. I'm running
>
> linux-backports-modules-hardy - 2.6.24.19.21
> network-manager - 0.6.6-0ubuntu5
>
> Reading the daemon.log file it still reports
> wlan0: Device is fully-supported using driver 'iwl3945'
> wlan0: driver does not support SSID scans (scan_capa 0x00)
>
> The following is the relevant output from lspci:
> 05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
>

> Any ideas on how I can fix this?

Have you tried the non-backports module?

 - Alexander

Alexander Sack (asac) wrote :

reopen, as the scan_capa patch apparently didnt make it into the iwlwifi_mac80211 module (only into kernel mac80211)

Changed in linux-backports-modules-2.6.24:
status: Fix Released → Triaged
Alexander Sack (asac) wrote :

LUM should get scan_capa too.

Changed in linux-ubuntu-modules-2.6.24:
importance: Undecided → High
status: New → Triaged
assignee: nobody → timg-tpi
Alexander Sack (asac) wrote :

hardy LTS could deserve scan_capa in LUM and LBM.

Changed in linux-backports-modules-2.6.24:
importance: Undecided → Medium
status: New → Triaged
Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → timg-tpi
importance: Undecided → Medium
status: New → Triaged
Changed in linux-backports-modules-2.6.24:
assignee: nobody → timg-tpi
Alexander Sack (asac) wrote :

NM in hardy has the workaround. scan_capa would would improve situation for iwl3xxx at least.

Changed in network-manager:
status: New → Fix Released
Steve Langasek (vorlon) on 2008-06-16
Changed in linux-backports-modules-2.6.24:
milestone: none → ubuntu-8.04.2
Changed in linux-ubuntu-modules-2.6.24:
milestone: none → ubuntu-8.04.2
Steve Langasek (vorlon) wrote :

lbm-2.6.24 does not apply to intrepid.

Changed in linux-backports-modules-2.6.24:
status: Triaged → Invalid
Steve Langasek (vorlon) wrote :

lum-2.6.24 is also not present in intrepid. If this bug still applies to intrepid, please open a new task on the relevant package.

Changed in linux-ubuntu-modules-2.6.24:
status: Triaged → Invalid
Steve Langasek (vorlon) wrote :

Tim, is this still on the roadmap for fixing in SRU?

Changed in linux-backports-modules-2.6.24:
milestone: ubuntu-8.04.2 → ubuntu-8.04.3
Changed in linux-ubuntu-modules-2.6.24:
milestone: ubuntu-8.04.2 → ubuntu-8.04.3
John B. (jbuncher) wrote :

Has there been a regression on this bug with the update to 2.6.24-23? I ask because going from -22 to -23 caused me to no longer be able to connect to a hidden SSID WPA Enterprise network on campus, as reported in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/317976 . Running -22 still allows me to connect. Thanks for any info that can be provided!

Alexander Sack (asac) wrote :

On Sat, Jan 24, 2009 at 03:33:59PM -0000, John B. wrote:
> Has there been a regression on this bug with the update to 2.6.24-23? I
> ask because going from -22 to -23 caused me to no longer be able to
> connect to a hidden SSID WPA Enterprise network on campus, as reported
> in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/317976 .
> Running -22 still allows me to connect. Thanks for any info that can be
> provided!
>

Could you please file new bug against linux package for this regression?

 - Alexander

John B. (jbuncher) wrote :

Alexander,

Sorry for the delay in responding, I thought I had subscribed to this bug. Should I just file a bug for the "linux" package?

Alexander Sack (asac) wrote :

On Fri, Feb 06, 2009 at 06:33:03AM -0000, John B. wrote:
> Alexander,
>
> Sorry for the delay in responding, I thought I had subscribed to this
> bug. Should I just file a bug for the "linux" package?
>

Yes, this bug is a general bug; the regression you see is worth a bug
on its own. Please go ahead and file a new bug.

 - Alexander

John B. (jbuncher) wrote :

Alexander,

Thanks for the info. Is there something wrong with the bug I had already filed and linked to above? ( http://bugs.launchpad.net/ubuntu/+source/linux/+bug/317976 ) I believe it is filed against the correct package. If there is more information needed or the source package is not correct, could you let me know in the comments to that bug? I'll stop posting here as tehy bugs may not be related.

--John

Stefan Bader (smb) wrote :

To me it looks like the scan_capa change was included for LBM in the following update which was released with LBM-2.6.24-21.27.

commit 9b54fcc116680915844994b3412168490a1e9b93
Author: Tim Gardner <email address hidden>
Date: Mon Sep 8 11:23:28 2008 -0600
    UBUNTU: iwlwifi backport from Intel
    Includes Shirley Peak (iwlwifi 5000).

Changed in linux-backports-modules-2.6.24 (Ubuntu Hardy):
status: Triaged → Fix Released
Stefan Bader (smb) wrote :

For LUM the following patch might add the required interface. I placed some test packages on
http://people.ubuntu.com/~smb/bug200950/ but I am not sure whether it is possible to get them tested in time to make the 8.04.3 goal...

Stefan Bader (smb) wrote :

Though I am not really sure why I already committed the patch, it seems to be around in LBM and Intrepid it must have looked sensible enough. If possible we should poke people for a verification.

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu Hardy):
assignee: Tim Gardner (timg-tpi) → Stefan Bader (stefan-bader-canonical)
status: Triaged → Fix Committed
milestone: ubuntu-8.04.3 → ubuntu-8.04.4
Stefan Bader (smb) on 2009-09-08
description: updated
Martin Pitt (pitti) wrote :

Accepted linux-ubuntu-modules-2.6.24 into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ubuntu-modules-2.6.24 - 2.6.24-24.41

---------------
linux-ubuntu-modules-2.6.24 (2.6.24-24.41) hardy-proposed; urgency=low

  [Stefan Bader]

  * SAUCE: igb-next: Fix up the makefile to actually do a build
    - LP: #352440

linux-ubuntu-modules-2.6.24 (2.6.24-24.40) hardy-proposed; urgency=low

  [AceLan Kao]

  * SAUCE: Fix the MIC of the Lenovo webcam problem
    - LP: #310760

  [Stefan Bader]

  * Merge WEXT scan capabilities to iwlwifi
    - LP: #200950
  * SAUCE: Add support in e1000e for a couple of ICH10 PCI IDs
    - LP: #322737
  * Add standalone Intel igb driver as igb-next to support 82576 cards
    - LP: #352440

 -- Stefan Bader <email address hidden> Mon, 14 Sep 2009 21:05:16 +0200

Changed in linux-ubuntu-modules-2.6.24 (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.