ipw2200: no wireless networks after installation in network-manager

Bug #198355 reported by boskicinek on 2008-03-04
4
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: network-manager

Hi,
I have this problem since feisty. When I'm using kubuntu LiveCD network manager works fine - I can see wireless networks, connect to them, etc. However, after I install kubuntu to my hdd stops working - knetworkmanager doesn't display any wireless networks, Connection Status shows me "No active device", disabling/enabling Wireless doesn't work either making network manager completly useless for me. I can setup wireless network in kubuntu system settings, I can connect to any wireless network with Wireless Assistant app, but knetworkmanager (and also nm-applet from Gnome) just simply doesn't work.
The only thing I'm changing during installation is host name.
Here's some additional info:
Computer mode: HP Compaq NX6110
Wireless Card: Intel Ipw2200
Number of NIC's: 2 (eth0: Broadcom BCM4401-B0 100Base-TX, eth1: Intel Corporation PRO/Wireless 2200BG)

$ uname -a
Linux boskilaptop 2.6.24-11-386 #1 Fri Feb 29 21:28:00 UTC 2008 i686 GNU/Linux

lspci -vv: See attachment

boskicinek (boski-cinek) wrote :
Alexander Sack (asac) wrote :

please try gutsy. this is most likely a driver issue, which likely is fixed for more recent drivers.

Changed in network-manager:
status: New → Incomplete
boskicinek (boski-cinek) wrote :

I'm afraid I was misunderstood. I have this problem since feisty, but now I'm using Hard Heron Alpha (since Alpha 3) and the problem is still here.

Alexander Sack (asac) wrote :

please attach your complete /var/log/syslog (taken after a failed connect attempt).

Thanks,

 - Alexander

boskicinek (boski-cinek) wrote :

Well, I can't do this, because there is no failed connect attempt - since I just don't see ANY wireless networks in knetworkmanager I simply can't make that attempt. Anyway I attached my syslog.

Alexander Sack (asac) wrote :

please attac'h your /etc/network/interfaces file as well then.

boskicinek (boski-cinek) wrote :

Here it is:
#############
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

iface eth1 inet dhcp
wireless-essid MYTYESSIDR
wireless-key s:xxxxxxxxxxxxx

auto eth1
#############

boskicinek (boski-cinek) wrote :

Why this is still marked as "Incomplete"? I provided all requested data.

boskicinek (boski-cinek) wrote :

I provided all requested data, so it's now "Incomplete" anymore.

Changed in network-manager:
status: Incomplete → New
Basilio Kublik (sourcercito) wrote :

Hi there
do you still experience this under an up-to-date Hardy Heron system, could you please check, but before that, comment out the lines referring to your wireless interface in the /etc/network/interfaces file.

Thanks in advance.

Changed in network-manager:
importance: Undecided → Low
status: New → Incomplete
boskicinek (boski-cinek) wrote :

Well, sort of. After commenting out /etc/network/interfaces I can see and connect to wireless network, but I'm unable to get on boot connection, because it appears that setting my home wireless network as activated on boot with "Manual configuration" option doesn't work - Kubuntu simply doesn't store any of my settings.

And one more thing: Now, when I'm using knetworkmanager, I'm getting disconnected from time to time. I didn't notice this behaviour before.

ThiloPfennig (tpfennig) wrote :

I can confirm this bug on a Thinkpad R52. I have the inter ipw2200 and and additional Ralink RT61 based cared as PCMCIA.

The ipw2200 can connect to WEP networks but not to WPA2. But the Ralink can connect to the same WPA2 network.

ThiloPfennig (tpfennig) wrote :

Why is importance low on this. Do we want to ignore everybody using Intel 2200BG not being able to connect?

ThiloPfennig (tpfennig) wrote :

this is still the case for Intreprid! But I think this is rather a kernel issue.

Changed in network-manager:
status: Incomplete → New
ThiloPfennig (tpfennig) wrote :

$ uname -r
2.6.27-5-generic

ThiloPfennig (tpfennig) wrote :

It really was a MAC filter of the router in my case. Marking this as back to Incomplete again. Sorry for bad investitation on my part.

Alexander Sack (asac) wrote :

this is fixed in 0.7 for sure.

Changed in network-manager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers