autopkgtests all fail on s390x

Bug #1855009 reported by Dan Streetman on 2019-12-03
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Dan Streetman
Xenial
Medium
Unassigned
Bionic
Medium
Dan Streetman
Disco
Medium
Dan Streetman
Eoan
Medium
Dan Streetman
Focal
Medium
Dan Streetman

Bug Description

[impact]

all autopkgtests fail on s390x

[test case]

check autopkgtest logs, e.g.
http://autopkgtest.ubuntu.com/packages/network-manager

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal/focal/s390x/n/network-manager/20191130_001946_a5512@/log.gz

autopkgtest [00:19:32]: @@@@@@@@@@@@@@@@@@@@ summary
wpa-dhclient FAIL non-zero exit status 1
nm.py FAIL non-zero exit status 1
killswitches-no-urfkill FAIL non-zero exit status 1
urfkill-integration FAIL non-zero exit status 1

[regression potential]

this essentially skips all the autopkgtests for network-manager on s390x, so regressions could occur now or in the future due to lack of testing on s390x. However, all the tests already fail on s390x and have since xenial (or earlier), so there hasn't been any useful test coverage on s390x before; this doesn't change that.

[other info]

as mentioned in comment 2, wireless networking is specifically excluded on s390 systems:

menuconfig WIRELESS
        bool "Wireless"
        depends on !S390
        default y

The 'wpa-dhclient' test is specific to wireless, and both 'killswitches-no-urfkill' and 'urfkill-integration' require rfkill which requires wireless, so none of those tests are valid on s390x, since it doesn't have any wireless support.

However the 'nm.py' test does have some test cases that don't rely on wireless capability, but it would be much more intrusive to update the test to split out wired vs. wireless testing, and that might introduce test regressions on other archs. The use case for network-manager on s390x in general is questionable, since s390x has no wireless support and obviously is never 'mobile', which are 2 main reasons to use network-manager instead of systemd-networkd. Additionally, all tests are currently skipped on armhf due to the requirement for machine isolation (and armhf tests run in containers), so s390x is not the first arch to simply skip all network-manager autopkgtests.

Dan Streetman (ddstreet) on 2019-12-03
Changed in network-manager (Ubuntu Xenial):
status: New → In Progress
Changed in network-manager (Ubuntu Bionic):
status: New → In Progress
Changed in network-manager (Ubuntu Focal):
status: New → In Progress
importance: Undecided → Medium
Changed in network-manager (Ubuntu Bionic):
importance: Undecided → Medium
assignee: nobody → Dan Streetman (ddstreet)
Changed in network-manager (Ubuntu Eoan):
assignee: nobody → Dan Streetman (ddstreet)
Changed in network-manager (Ubuntu Xenial):
assignee: nobody → Dan Streetman (ddstreet)
Changed in network-manager (Ubuntu Disco):
assignee: nobody → Dan Streetman (ddstreet)
Changed in network-manager (Ubuntu Eoan):
importance: Undecided → Medium
Changed in network-manager (Ubuntu Disco):
importance: Undecided → Medium
Changed in network-manager (Ubuntu Xenial):
importance: Undecided → Medium
Changed in network-manager (Ubuntu Disco):
status: New → In Progress
Changed in network-manager (Ubuntu Eoan):
status: New → In Progress
Changed in network-manager (Ubuntu Focal):
assignee: nobody → Dan Streetman (ddstreet)
Dan Streetman (ddstreet) wrote :

Most of the failures are due to s390x kernel configuration setting RFKILL=n

Dan Streetman (ddstreet) wrote :

Re: RFKILL=n, wireless networking is specifically excluded on s390 systems:

menuconfig WIRELESS
        bool "Wireless"
        depends on !S390
        default y

so there's no sense in building RFKILL. The wpa-dhclient tests fails because it can't load cfg80211, which is due to s390 never including wireless networking support.

Dan Streetman (ddstreet) on 2019-12-04
description: updated
description: updated
description: updated
Dan Streetman (ddstreet) on 2019-12-06
tags: added: block-proposed-bionic block-proposed-disco block-proposed-eoan block-proposed-xenial

Hello Dan, or anyone else affected,

Accepted network-manager into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.20.4-2ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in network-manager (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.20.4-2ubuntu3

---------------
network-manager (1.20.4-2ubuntu3) focal; urgency=medium

  * d/t/killswitches-no-urfkill, d/t/urfkill-integration,
    d/t/wpa-dhclient, d/t/nm.py, d/t/control:
    - skip tests on s390 due to missing wireless kernel support
      (LP: #1855009)
    - skip tests on i386 since there is no i386 kernel anymore,
      so we can't build our custom rfkill test module
      (LP: #1855183)

 -- Dan Streetman <email address hidden> Wed, 04 Dec 2019 12:17:37 -0500

Changed in network-manager (Ubuntu Focal):
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

Hello Dan, or anyone else affected,

Accepted network-manager into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.16.0-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in network-manager (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed-disco
Brian Murray (brian-murray) wrote :

Hello Dan, or anyone else affected,

Accepted network-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.10.6-2ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in network-manager (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Changed in network-manager (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Dan, or anyone else affected,

Accepted network-manager into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.2.6-0ubuntu0.16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

All autopkgtests for the newly accepted network-manager (1.2.6-0ubuntu0.16.04.4) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

nplan/0.32~16.04.7 (i386)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

All autopkgtests for the newly accepted network-manager (1.16.0-0ubuntu2.1) for disco have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/unknown (armhf)
network-manager/1.16.0-0ubuntu2.1 (ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/disco/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

All autopkgtests for the newly accepted network-manager (1.20.4-2ubuntu2.1) for eoan have finished running.
The following regressions have been reported in tests triggered by the package:

netplan.io/0.98-0ubuntu1 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/eoan/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

All autopkgtests for the newly accepted network-manager (1.10.6-2ubuntu1.3) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/237-3ubuntu10.33 (ppc64el)
systemd/unknown (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Dan Streetman (ddstreet) wrote :

s390x tests are all now 'neutral' (since no tests are actually run, as explained in description).

Dan Streetman (ddstreet) wrote :

e.g. see test results for s390x across releases:
http://autopkgtest.ubuntu.com/packages/network-manager

tags: added: verification-done verification-done-bionic verification-done-disco verification-done-eoan verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan verification-needed-xenial
Dan Streetman (ddstreet) wrote :

autopkgtest analysis:

the network-manager test on disco/ppc64el fails, being tracked in bug 1733321, and unrelated to this bug.

tags: removed: block-proposed-eoan

Hello Dan, or anyone else affected,

Accepted network-manager into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.20.4-2ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-eoan
removed: verification-done verification-done-eoan
Dan Streetman (ddstreet) wrote :

autopkgtests are now all skipped on s390.

tags: added: verification-done-eoan
removed: verification-needed
tags: removed: verification-needed-eoan

The verification of the Stable Release Update for network-manager has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.20.4-2ubuntu2.2

---------------
network-manager (1.20.4-2ubuntu2.2) eoan; urgency=medium

  [ José Manuel Santamaría Lema ]
  * d/p/lp1858092-fix_updating_agent_vpn_secrets.patch:
    - fix VPN password storing (LP: #1858092)

network-manager (1.20.4-2ubuntu2.1) eoan; urgency=medium

  * d/t/killswitches-no-urfkill, d/t/urfkill-integration,
    d/t/wpa-dhclient, d/t/nm.py, d/t/control:
    - skip tests on s390 due to missing wireless kernel support
      (LP: #1855009)
    - skip tests on i386 since there is no i386 kernel anymore,
      so we can't build our custom rfkill test module
      (LP: #1855183)

 -- Dan Streetman <email address hidden> Wed, 08 Jan 2020 08:45:30 -0500

Changed in network-manager (Ubuntu Eoan):
status: Fix Committed → Fix Released

Hello Dan, or anyone else affected,

Accepted network-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.10.6-2ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done-bionic

All autopkgtests for the newly accepted network-manager (1.10.6-2ubuntu1.4) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/237-3ubuntu10.39 (i386)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Dan Streetman (ddstreet) wrote :

autopkgtests on s390x now pass (well, are 'neutral'):
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/s390x/n/network-manager/20200303_120208_f754d@/log.gz

also since this is now bundled with a non-autopkgtest-only change, i'll remove the block-proposed tag

tags: added: verification-done verification-done-bionic
removed: block-proposed-bionic verification-needed verification-needed-bionic
Dan Streetman (ddstreet) wrote :

as this will never leave disco-proposed, marking wontfix for disco

Changed in network-manager (Ubuntu Disco):
status: Fix Committed → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.10.6-2ubuntu1.4

---------------
network-manager (1.10.6-2ubuntu1.4) bionic; urgency=medium

  * d/p/start-ip-conf-when-master-carrier-goes-up.patch: device: start IP
    configuration when master carrier goes up (LP: #1794478)

network-manager (1.10.6-2ubuntu1.3) bionic; urgency=medium

  * d/t/control: nm test requires dnsmasq-base (LP: #1850267)
  * d/t/killswitches-no-urfkill, d/t/urfkill-integration,
    d/t/wpa-dhclient, d/t/nm, d/t/control:
    - skip tests on s390 due to missing wireless kernel support
      (LP: #1855009)

 -- Seyeong Kim <email address hidden> Wed, 19 Feb 2020 14:59:10 +0900

Changed in network-manager (Ubuntu Bionic):
status: Fix Committed → Fix Released

All autopkgtests for the newly accepted network-manager (1.2.6-0ubuntu0.16.04.4) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/229-4ubuntu21.23 (arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Dan Streetman (ddstreet) on 2020-11-17
Changed in network-manager (Ubuntu Xenial):
assignee: Dan Streetman (ddstreet) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers