autopkgtest 'nm' fails because it can't find dnsmasq

Bug #1850267 reported by Dan Streetman
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned
Bionic
Low
Dan Streetman

Bug Description

[impact]

test 'nm' fails because dnsmasq-base isn't installed

[test case]

see test results
http://autopkgtest.ubuntu.com/packages/network-manager/bionic/amd64

[regression potential]

low, test fix only

[other info]

The d/t/control file 'nm' test section, for bionic, needs to include dnsmasq-base in its dep list.

disco and later already include dnsmasq-base in test dep packages, and in xenial network-manager directly depends on dnsmasq-base. So this is needed only for bionic.

Dan Streetman (ddstreet)
Changed in network-manager (Ubuntu Bionic):
importance: Undecided → Low
Changed in network-manager (Ubuntu):
status: New → Fix Released
Dan Streetman (ddstreet)
Changed in network-manager (Ubuntu Bionic):
assignee: nobody → Dan Streetman (ddstreet)
status: New → In Progress
Dan Streetman (ddstreet)
description: updated
Dan Streetman (ddstreet)
description: updated
description: updated
Dan Streetman (ddstreet)
tags: added: block-proposed-bionic
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Dan, or anyone else affected,

Accepted network-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.10.6-2ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in network-manager (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (network-manager/1.10.6-2ubuntu1.3)

All autopkgtests for the newly accepted network-manager (1.10.6-2ubuntu1.3) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/237-3ubuntu10.33 (ppc64el)
systemd/unknown (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Dan Streetman (ddstreet) wrote :
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Dan, or anyone else affected,

Accepted network-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.10.6-2ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done verification-done-bionic
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (network-manager/1.10.6-2ubuntu1.4)

All autopkgtests for the newly accepted network-manager (1.10.6-2ubuntu1.4) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/237-3ubuntu10.39 (i386)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Dan Streetman (ddstreet) wrote :

autopkgtests now pass:
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/amd64/n/network-manager/20200303_121053_bbc2d@/log.gz

also since this is now bundled with a non-autopkgtest-only change, i'll remove the block-proposed tag

tags: added: verification-done verification-done-bionic
removed: block-proposed-bionic verification-needed verification-needed-bionic
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.10.6-2ubuntu1.4

---------------
network-manager (1.10.6-2ubuntu1.4) bionic; urgency=medium

  * d/p/start-ip-conf-when-master-carrier-goes-up.patch: device: start IP
    configuration when master carrier goes up (LP: #1794478)

network-manager (1.10.6-2ubuntu1.3) bionic; urgency=medium

  * d/t/control: nm test requires dnsmasq-base (LP: #1850267)
  * d/t/killswitches-no-urfkill, d/t/urfkill-integration,
    d/t/wpa-dhclient, d/t/nm, d/t/control:
    - skip tests on s390 due to missing wireless kernel support
      (LP: #1855009)

 -- Seyeong Kim <email address hidden> Wed, 19 Feb 2020 14:59:10 +0900

Changed in network-manager (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for network-manager has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers