username is not saved in openconnect connection dialog

Bug #1838838 reported by GeekSmith
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
GNOME Shell
New
Unknown
NetworkManager
Fix Released
Unknown
gnome-shell (Ubuntu)
Low
Unassigned
network-manager (Ubuntu)
Low
Unassigned

Bug Description

Same issue as https://bugs.launchpad.net/ubuntu/+source/network-manager-openconnect/+bug/1609700

This was marked resolved. The report of its reappearance in Ubuntu 19.04 and 19.10 has not been acknowledged.

This was working for me in 18.10, but a fresh install of 19.04 and 19.10 show that it is back. The password is saved when the option to save passwords is selected, but the username must be entered manually upon connection.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-openconnect (Ubuntu):
status: New → Confirmed
Revision history for this message
GeekSmith (lixo-geeksmith) wrote :

Please refer to all the comments on this closed bug: https://bugs.launchpad.net/ubuntu/+source/network-manager-openconnect/+bug/1609700

This issue affects many Ubuntu users and hasn't received any attention since it was reported again.

dwmw2 (dwmw2)
affects: network-manager-openconnect (Ubuntu) → network-manager (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-openconnect (Ubuntu):
status: New → Confirmed
Yannis Tsop (ogiannhs)
tags: added: eoan
Revision history for this message
dwmw2 (dwmw2) wrote :

I moved it to NetworkManager because that's where the regression is. There's not a lot we can do about it in NetworkManager-openconnect.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Could someone having the issue report it upstream on
https://gitlab.freedesktop.org/NetworkManager/NetworkManager/issues ?

Revision history for this message
Yannis Tsop (ogiannhs) wrote :
dwmw2 (dwmw2)
affects: network-manager-openconnect (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell:
status: Unknown → New
Changed in network-manager (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in network-manager (Ubuntu):
importance: Undecided → Low
Changed in network-manager:
status: Unknown → New
Revision history for this message
kkivi (kkivi) wrote :

Not only it doesn't connect username, but it saves
one time password instead

Revision history for this message
GeekSmith (lixo-geeksmith) wrote :

Still present after upgrading 19.10 -> 20.04.

Revision history for this message
GeekSmith (lixo-geeksmith) wrote :

Here's a workaround from the RedHat folks.
https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/2105

nmcli con mod VPNNAME vpn.secrets 'form:main:username=USERNAME','save_passwords=yes'

Revision history for this message
tellapu (tellapu) wrote :

@GeekSmith Thanks for sharing this working! Wonderful!

tags: added: focal
removed: eoan
Changed in network-manager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.