Can't create new wireless network using mac80211 based drivers

Bug #183303 reported by Rafael Arco Arredondo on 2008-01-15
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetworkManager
Unknown
Medium
linux (Ubuntu)
Undecided
Unassigned
network-manager (Debian)
Fix Released
Unknown
network-manager (Ubuntu)
Low
Unassigned
wpasupplicant (Ubuntu)
Undecided
Unassigned

Bug Description

I am trying to create a new wireless network (particularly, with no encryption) with the gnome applet. However, I just get the message "Trying to connect to wireless network «(null)»". Then, after a couple of minutes or so, it gets back to the cabled connection and no wireless connection is created.

I am using Gutsy, network-manager 0.6.5-0ubuntu16.7.10.0 and network-manager-gnome 0.6.5-0ubuntu11~7.10.0.

Updated description: The original reporter used ipw2200, but for that driver a bug has already been reported for this isse: Bug #75358.
This bug now addresses users with mac20811-based drivers, since the majority of the commenters have such cards/drivers.

The bug has persisted in Gutsy, Hardy, Intrepid and even Jaunty RC...

Basilio Kublik (sourcercito) wrote :

Hi there
do you still experience this issue with the current version of the application?, could you please try to reproduce this using the live environment of the Desktop CD of the development release - Hardy Heron.

Thanks in advance

Changed in network-manager:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete
Hansi Raber (super-superduper) wrote :

sorry, can't do live cd testing, don't have a blanks here...

but i'm on hardy testing release with the latest updates,
using a belkin g usb stick,
network-manger 0.6.6-0ubuntu1
network-manager 0.6.6-0ubuntu1

the issue is still the same.

Brian Pitts (bpitts) wrote :

I can't create one either using up-to-date Hardy on a Dell Inspiron 1420N. I've attached an excerpt from daemon.log

Changed in network-manager:
status: Unknown → New
rihasant (riku.hs) wrote :

Same problems appears here also. Using rtl8187 card.
This is what iwconfig exports while creating unencrypted network:

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"vm-tesmachine"
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

... and after it fails:

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Hansi Raber (super-superduper) wrote :

creating networks is a very convenient feature for file transfer and gaming quickies.
i'd love to see importance bumped up to medium.

dnel (dave.nelson) wrote :

I'm also experiencing this problem on Hardy Beta (updated 19/04/08), gives message "attempting to connect to wireless network 'null'" and doesn't change.

Same for both WEP enabled and disabled.

Driver: RaLink RT2600 802.11 MIMO
Card: Edimax EW-7628IG (PCI)

Hans van den Bogert (hbogert) wrote :

same for me with 8187, mentioned symptoms apply to me too

Same here, Hardy released version

T43 with IPW2200 wireless built-in.

Motin (motin) wrote :
Download full text (5.0 KiB)

Same here. I have been attempting the in Feisty, Gutsy and now Hardy without success.

Attached is the relevant messages log from Network Manager.

In short, the important messages are:
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Creating network 'motin-laptop' on device '/org/freedesktop/NetworkManager/Devices/wlan0'.
Jun 28 17:59:01 motin-laptop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.reason
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Device wlan0 activation scheduled...
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Activation (wlan0) started...
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jun 28 17:59:01 motin-laptop NetworkManager: <info> Activation (wlan0/wireless): access point 'motin-laptop' is unencrypted, no key needed.
Jun 28 17:59:03 motin-laptop NetworkManager: <info> retry to connect to global supplicant socket (try=1)
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: sending command 'INTERFACE_ADD wlan0^I^Iwext^I/var/run/wpa_supplicant0^I'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: response was 'OK'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: sending command 'AP_SCAN 2'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: response was 'OK'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: sending command 'ADD_NETWORK'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: response was '0'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 ssid 6d6f74696e2d6c6170746f70'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: response was 'OK'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 mode 1'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: response was 'OK'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 frequency 2412'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: response was 'OK'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: sending command 'SET_NETWORK 0 key_mgmt NONE'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: response was 'OK'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: sending command 'ENABLE_NETWORK 0'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> SUP: response was 'OK'
Jun 28 17:59:03 motin-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.

Followed by repeated:
Jun 28 18:00:20 motin-laptop kernel: [11976.775999] wlan0: Initial auth_alg=0
Jun 28 18:00:20 motin-laptop kernel: [11976.776011] wlan0: ...

Read more...

Motin (motin) wrote :

The idea to fix this bug was just submitted to Ubuntu Brainstorm: http://brainstorm.ubuntu.com/idea/10428/

Please help promote the idea! Cheers all!

komputes (komputes) wrote :

I have also tried to create ad-hoc networks. No Broadcast Ad Hoc node is created. I have even tries setting two computers to the same information to see if they would sync up but nothing. I have tried this in Feisty, Gutsy and Hardy, let's hope we get ad-hoc networking with WPA in Intrepid.

Motin (motin) wrote :

I just upgrade to network manager 0.7-svn (http://ubuntuforums.org/showthread.php?t=797059) but the bug persists... Now reported upstream at least: http://bugzilla.gnome.org/show_bug.cgi?id=541816

Changed in network-manager:
status: Unknown → New
Motin (motin) wrote :

Even though the Linux Terminal Server project may be affected by this bug, it is not where this bug originates.

Changed in ltsp:
status: New → Invalid
Changed in network-manager:
assignee: sourcercito → nobody
status: Incomplete → Invalid
Motin (motin) wrote :

After receiving a very informative comment from NetworkManager Dan Williams (see the upstreams linked bugreport: http://bugzilla.gnome.org/show_bug.cgi?id=541816#c2 ), it is very likely this bug is really a combination of one or many mac80211-based driver bugs as well as bugs in wpa_supplicant.

@Brian Pitts, @rihasant, @dnel,@dlgandalf:
You all seem to be using mac80211-based cards/drivers, which makes it even more viable.

@Francesco:
Since you are using ipw2200, Bug #75358 may be more appropriate for you. Dan Williams also replied in a similar manner here, but mentions a ipw2200 patch suggestion as well: http://www.nabble.com/NM-0.6.5-Great-Problem-td18027324.html

kernel (wireless-testing.git):
872ba53395b2a8be08c3ea2d39e225e5b4a8cb40 mac80211: decrease IBSS creation
latency
507b06d0622480f8026d49a94f86068bb0fd6ed6 mac80211: send association event on
IBSS create

Two following four patches was suggested to be able to create Ad Hoc networks using 80211-based drivers:
wpa_supplicant:
[PATCH] wpa_supplicant: give adhoc associations a bit more time - http://lists.shmoo.com/pipermail/hostap/2008-June/017908.html
[PATCH v2] wext: handle mode switches correctly for mac80211 - http://lists.shmoo.com/pipermail/hostap/2008-June/017907.html

According to the following changelog, the two mac80211 patches has been incorporated into the mainline kernel by 2.6.25.6-1:
http://lists.rpath.org/pipermail/foresight-commits/2008-June/024368.html

The wpa_supplicant patches seemed to have been applied since version 0.6.3-2 (https://launchpad.net/ubuntu/+source/wpasupplicant):
  * Add 52_handle_mac80211_mode_switch.patch to enhance handling of mode
    switching for mac80211 using interfaces.
  * Add 53_give_adhoc_assoc_more_time.patch to give adhoc associations a bit
    more time.

Thus, it would be very interesting to hear if this problem persists in the current Intrepid development version (it oughtn't...)! Do we have any brave Intrepid tester that can confirm or approve that these patches have fixed the issue?

description: updated
Brian Pitts (bpitts) wrote :

@Motin: Thanks for your attention to this bug.

"Do we have any brave Intrepid tester that can confirm or approve that these patches have fixed the issue?"

Once the Alpha 2 live cds arrive later this week, sure.

Motin (motin) wrote :

@Brian: No probs!

Can't wait for the Alpha 2 live cds... I'm so excite. Really - so I'll try to get ahead of things by just having started retrieval and compilation of the 2.6.25.10 kernel through the one-click "kernelcheck" script (http://www.ubuntu-unleashed.com/2007/09/upgrade-to-latest-kernelorg-kernel-with.html) as well as a backported version of wpa_supplicant/wext using prevu:
sudo apt-get install prevu
sudo prevu-init
prevu https://launchpad.net/ubuntu/intrepid/+source/wpasupplicant/0.6.3-2/+files/wpasupplicant_0.6.3-2.dsc

Hopefully everything will be built when I wake up.
Night all!

Motin (motin) wrote :

Interesting. It just became evident that wpa_supplicant v0.6.3-2 was already installed along with network manager 0.7: "How to: Install Network Manager 0.7 SVN on Hardy - Ubuntu Forums" - http://ubuntuforums.org/showthread.php?t=797059

No need for prevu this time I guess... Still gotta wait for the kernel to download and compile however.
Night!

Changed in network-manager:
status: New → Invalid
Motin (motin) wrote :

Hmm... no wireless devices were available when booting into the new kernel, and iwl4965 nor mac80211 was not buildable using module-assistant - frankly I don't know how to build modules / drivers in other ways...

So, in the end, I was barely able to get sound (also modules), nvidia graphics and my 3g modem setup using the new kernel, but then I started getting intermittent total system freezes.

I guess I, too will be waiting for Intrepid Alpha 2. However, once it is confirmed to work with those versions I really hope we can find a way to backport the fixes to Hardy...

Cheers all!

To get wireless working in Intrepid try installing 'linux-restricted-modules-common'. Worked for me. I haven't tried the actual bug issues above yet.
see: http://ubuntuforums.org/showthread.php?t=844261&page=2
/m

Motin (motin) wrote :

Alpha 2 never shipped with any live cds so I haven't been able to try this, but do we have any brave Intrepid tester that can confirm that the bug doesn't exist in the Intrepid kernel?

I just tried an "prevu http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux_2.6.26-4.11.dsc", but it wouldn't succeed (output is attached).
How would one backport the Intrepid kernel to Hardy - anyone know?

Motin (motin) wrote :

Anyone check if this is fixed in Intrepid Alpha 3?

Brian Pitts (bpitts) wrote :

It wasn't.

Intrepid Alpha4 was most recently released. Would anyone who has this bug care to test? http://www.ubuntu.com/testing . Please let us know your results. Thanks.

Changed in linux:
status: New → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Reinhard Tartler (siretart) wrote :

intrepid now ships wpasupplicant_0.6.4, so I assume the requested patches have been applied now. please reopen a new bug with details if and what patches are missing now.

Changed in wpasupplicant:
status: New → Fix Released
Motin (motin) wrote :

Ok so now it is all up to the kernel. The relevant patches _should_ have been included in .26, but according to reports above, it wasn't solved in Intrepid Alpha 3.

I'll try the Alpha 5 LiveCD as soon as I can download it with my slow connection...

Motin (motin) wrote :

Bad news - just fired up Intrepid Alpha 5 and couldn't create an AdHoc network - it goes well up until stage 5 (iptables are even modified by this point) and then fails with the following syslog messages:

Sep 18 11:52:06 ubuntu NetworkManager: <WARN> nm_device_activate_stage5_ip_config_commit(): Activation (wlan0) Stage 5 of 5 (IP Configure Commit) start sharing failed.
Sep 18 11:52:06 ubuntu NetworkManager: <info> (wlan0): device state change: 7 -> 9
Sep 18 11:52:06 ubuntu NetworkManager: <info> Activation (wlan0) failed for access point (MotinAdHocTest)
Sep 18 11:52:06 ubuntu NetworkManager: <info> Marking connection 'MotinAdHocTest' invalid.
Sep 18 11:52:06 ubuntu NetworkManager: <info> Activation (wlan0) failed.
Sep 18 11:52:06 ubuntu NetworkManager: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Sep 18 11:52:06 ubuntu NetworkManager: <info> (wlan0): device state change: 9 -> 3
Sep 18 11:52:06 ubuntu NetworkManager: <info> (wlan0): deactivating device.
Sep 18 11:52:06 ubuntu kernel: [ 510.892731] wlan0: disassociating by local choice (reason=3)
Sep 18 11:52:06 ubuntu NetworkManager: <WARN> nm_device_wifi_set_ssid(): error setting SSID to '(null)' for device wlan0: Invalid argument
Sep 18 11:52:06 ubuntu avahi-daemon[7278]: Withdrawing address record for 10.42.45.1 on wlan0.
Sep 18 11:52:06 ubuntu avahi-daemon[7278]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 10.42.45.1.
Sep 18 11:52:06 ubuntu avahi-daemon[7278]: Interface wlan0.IPv4 no longer relevant for mDNS.
Sep 18 11:52:06 ubuntu NetworkManager: <WARN> nm_device_wifi_set_mode(): error setting card wlan0 to mode 2: Device or resource busy

Is this attached syslog output enough for the kernel / mac80211 devs to take a deeper look at this problem?

Please tell me what more we can supply to help solving this bug.

Motin (motin) wrote :

As the failure previously happened at Stage 2, there is a chance that the original bugs are fixed, but creating new wireless networks is still not possible but now due to a new bug.

Someone more qualified that can make an assumption in this matter?

Changed in linux:
status: Incomplete → New
jonmjames (jonathanmjames) wrote :
Download full text (6.2 KiB)

Hey all,
I just tried out the Intrepid Ibex Alpha 6 and was able to create an ad-hoc network out of the box, but not through NetworkManager.

My setup, MacBook 2,1 Atheros Communications Inc. AR5418 802.11abgn Wireless PCI Express Adapter [168c:0024] (rev 01) card.

At first I tried setting wlan0 to ad-hoc mode and creating the network through NetworkManager, but the closest I got was stage 5, where it would fail:
[code]Sep 28 07:12:48 ubuntu NetworkManager: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) started...
Sep 28 07:12:48 ubuntu avahi-daemon[6921]: Withdrawing address record for 169.254.5.255 on wlan0.
Sep 28 07:12:48 ubuntu avahi-daemon[6921]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 169.254.5.255.
Sep 28 07:12:48 ubuntu avahi-daemon[6921]: Interface wlan0.IPv4 no longer relevant for mDNS.
Sep 28 07:12:48 ubuntu avahi-daemon[6921]: Joining mDNS multicast group on interface wlan0.IPv4 with address 10.42.44.1.
Sep 28 07:12:48 ubuntu avahi-autoipd(wlan0)[8273]: A routable address has been configured.
Sep 28 07:12:48 ubuntu avahi-autoipd(wlan0)[8273]: Callout UNBIND, address 169.254.5.255 on interface wlan0
Sep 28 07:12:48 ubuntu avahi-daemon[6921]: New relevant interface wlan0.IPv4 for mDNS.
Sep 28 07:12:48 ubuntu avahi-daemon[6921]: Registering new address record for 10.42.44.1 on wlan0.IPv4.
Sep 28 07:12:48 ubuntu avahi-autoipd(wlan0)[8274]: client: RTNETLINK answers: Cannot assign requested address
Sep 28 07:12:48 ubuntu avahi-autoipd(wlan0)[8274]: Script execution failed with return value 2
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert INPUT --in-interface wlan0 --protocol tcp --destination-port 53 --jump ACCEPT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert INPUT --in-interface wlan0 --protocol udp --destination-port 53 --jump ACCEPT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert INPUT --in-interface wlan0 --protocol tcp --destination-port 67 --jump ACCEPT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert INPUT --in-interface wlan0 --protocol udp --destination-port 67 --jump ACCEPT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert FORWARD --in-interface wlan0 --jump REJECT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert FORWARD --out-interface wlan0 --jump REJECT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert FORWARD --in-interface wlan0 --out-interface wlan0 --jump ACCEPT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert FORWARD --source 10.42.44.0/255.255.255.0 --in-interface wlan0 --jump ACCEPT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table filter --insert FORWARD --destination 10.42.44.0/255.255.255.0 --out-interface wlan0 --match state --state ESTABLISHED,RELATED --jump ACCEPT
Sep 28 07:12:49 ubuntu NetworkManager: <info> Executing: /sbin/iptables --table na...

Read more...

jonmjames (jonathanmjames) wrote :

Update:
   Connection to the ad-hoc network lasted for about 15 mins, then it lost connection. Checked the syslog and noticed it started scanning all of the different channels repeatedly. I'll post the msg if I can recreate it. Again this was Intrepid Ibex Alpha 6, Live CD, creating ad-hoc network using terminal NOT NetworkManager.

-- jon

Motin (motin) wrote :

@jonmjames: Very interesting. Would you mind trying out Wicd's create network feature? Chances are that it will work perfectly when using Wicd (this was the case for ipw2200 on my old laptop), and that would clearly denote a bug in NetworkManager as well as confirm that the bug(s) are fixed in the current Intrepid kernel.

Thanks man!

Changed in linux:
status: New → Incomplete
Motin (motin) wrote :
Download full text (12.9 KiB)

Leann: You asked about testing this in Intrepid. When nobody returned with feedback it was set as "Incomplete". I just tested this in Jaunty RC and it has not been fixed still... Please don't set to Incomplete again without specifying what we can do in order to make the report complete. Thanks.

syslog during network creation attempt:
Apr 17 15:04:24 motin-xps NetworkManager: <info> (wlan0): device state change: 8 -> 3
Apr 17 15:04:24 motin-xps NetworkManager: <info> (wlan0): deactivating device (reason: 0).
Apr 17 15:04:24 motin-xps NetworkManager: <info> wlan0: canceled DHCP transaction, dhcp client pid 6817
Apr 17 15:04:24 motin-xps NetworkManager: <info> Clearing nscd hosts cache.
Apr 17 15:04:24 motin-xps kernel: [ 3006.525406] wlan0: disassociating by local choice (reason=3)
Apr 17 15:04:24 motin-xps dnsmasq[3688]: reading /etc/resolv.conf
Apr 17 15:04:24 motin-xps dnsmasq[3688]: using nameserver 80.251.201.178#53
Apr 17 15:04:24 motin-xps dnsmasq[3688]: using nameserver 80.251.201.177#53
Apr 17 15:04:24 motin-xps NetworkManager: <info> Clearing nscd hosts cache.
Apr 17 15:04:24 motin-xps NetworkManager: <info> Policy set '3' (ppp0) as default for routing and DNS.
Apr 17 15:04:24 motin-xps NetworkManager: <WARN> check_one_route(): (wlan0) error -34 returned from rtnl_route_del(): Sucess
Apr 17 15:04:24 motin-xps avahi-daemon[5075]: Withdrawing address record for 192.168.1.2 on wlan0.
Apr 17 15:04:24 motin-xps avahi-daemon[5075]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.2.
Apr 17 15:04:24 motin-xps kernel: [ 3006.537061] wlan0: deauthenticated
Apr 17 15:04:24 motin-xps avahi-daemon[5075]: Interface wlan0.IPv4 no longer relevant for mDNS.
Apr 17 15:04:24 motin-xps NetworkManager: <info> Activation (wlan0) starting connection 'MotinXPS'
Apr 17 15:04:24 motin-xps NetworkManager: <info> (wlan0): device state change: 3 -> 4
Apr 17 15:04:24 motin-xps NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Apr 17 15:04:24 motin-xps NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Apr 17 15:04:24 motin-xps NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Apr 17 15:04:24 motin-xps NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Apr 17 15:04:24 motin-xps NetworkManager: <info> (wlan0): supplicant connection state: completed -> disconnected
Apr 17 15:04:24 motin-xps NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Apr 17 15:04:24 motin-xps NetworkManager: <info> (wlan0): device state change: 4 -> 5
Apr 17 15:04:24 motin-xps NetworkManager: <info> Activation (wlan0/wireless): connection 'MotinXPS' requires no security. No secrets needed.
Apr 17 15:04:24 motin-xps NetworkManager: <info> Config: added 'ssid' value 'MotinXPS'
Apr 17 15:04:24 motin-xps NetworkManager: <info> Config: added 'mode' value '1'
Apr 17 15:04:24 motin-xps NetworkManager: <info> Config: added 'frequency' value '2412'
Apr 17 15:04:24 motin-xps NetworkManager: <info> Config: added 'key_mgmt' value 'NONE'...

Changed in linux (Ubuntu):
status: Incomplete → New
description: updated
Keng-Yu Lin (lexical) wrote :

Unfortunately it seems this bug is still an issue. Can you confirm this issue exists with the most recent Jaunty Jackalope 9.04 release - http://www.ubuntu.com/news/ubuntu-9.04-desktop . Please let us know your results. Thanks.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in network-manager:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in network-manager (Debian):
status: New → Fix Released
Po-Hsu Lin (cypressyew) wrote :

Closing this bug with Won't fix as this kernel is no longer supported.
Please feel free to open a new bug report if you're still experiencing this on a newer release (Bionic 18.04.3 / Disco 19.04)
Thanks!

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
no longer affects: ltsp (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.