Ubuntu

Can't set static IP --network manager--

Reported by SeRpEnT on 2007-12-26
26
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Undecided
Unassigned
network-manager (Ubuntu)
Low
Unassigned

Bug Description

Hardy Heron.
After I had set the static IP, subnet mask and gateway, clicking 'ok' appears the window with the message 'changing interface configuration'.
I Wait 40 minutes but the window with the message 'changing interface configuration' doesn't disappears and the network configuration didn't change....

SeRpEnT (superbes) on 2007-12-26
description: updated
Basilio Kublik (sourcercito) wrote :

Hi there
do you still experience this issue with the current version of the application?, could you please try to reproduce this using the live environment of the Desktop CD of the development release - Hardy Heron.

Thanks in advance

Changed in network-manager:
importance: Undecided → Low
status: New → Incomplete

I'm using Gutsy Gibbon and I use the GUI in Network Manager to set a static ip (and gateway and subnet mask, etc.) for one of my ethernet interfaces. Unlike the original post, there is no message that says "changing interface configuration". I just hit OK, and then I close the dialog.

After doing the above steps, my internet no longer works. Before setting my ethernet device to a static ip, it was on roaming mode, and that worked fine. When I would run ifconfig -a on roaming mode, my ethernet device had a valid inet address, but after switching to static, I lose that. I'm not sure what other commands I should run to check to see what effect setting static ip had.

Also, I think there is a separate bug in NetworkManager, because when I change the said ethernet device back to roaming mode (to try to regain access to the internet) and close the dialog, it doesn't work immediately. I have to "sudo killall NetworkManager" and then "sudo NetworkManager" in order to restore my internet connection.

So I really have two problems:
* setting the static ip through the GUI in NetworkManager fails to work (and does not tell me how it is failing)
* Setting an ethernet device to roaming mode does not take effect until after I reboot NetworkManager

Note: I'm not sure how relevant this is, but I have two ethernet devices. Only one is connected with a live ethernet cable.

Also, here is the output of ifup:

sudo ifup eth0
SIOCADDRT: No such process
Failed to bring up eth0.

And ifdown
sudo ifdown eth0
ifdown: interface eth0 not configured

Those commands were run after the eth0 was set to static ip.

patrickw.hall (patrickw-hall) wrote :

Same problem as Robert Toscano, if I do a sudo ifup eth0 it will start working, but will not work with static IP address.

Sitsofe Wheeler (sitsofe) wrote :

The problem appears to be that interfaces that are not marked auto in /etc/network/interfaces will not be touched by various system scripts and NetworkManager will not touch them either. From /etc/init.d/networking :
     if ifup -a; then
  log_action_end_msg $?
     else
  log_action_end_msg $?
     fi

From the ifup manpage -a means "affect all interfaces marked auto."

If you look at udev rules you can see something similar. From /etc/udev/rules.d/85-ifupdown.rules :
ACTION=="add", RUN+="/sbin/start-stop-daemon --start --background --pidfile /var/run/network/bogus --startas /sbin/ifup -- --allow auto $env{INTERFACE}"
--allow auto is effectively only allowing interfaces in the auto class which appears to be similar to -a .

If a user manually does ifup <interfacename> then the interface appears to be brought up and configured correctly.

Now either NetworkManger needs to be taught to configure static/manual interfaces that lack auto ( which apparently does for Fedora http://bugzilla.gnome.org/show_bug.cgi?id=518189 ) or whatever is writing /etc/network/interfaces (often gnome-system-tools ) needs to add auto to interfaces when they are configured manually. Until this is done manual/static interfaces will continue to be broken on boot.

Sitsofe Wheeler (sitsofe) wrote :

Setting to confirmed.

Changed in network-manager:
status: Incomplete → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

I've added a gnome-system-tools component to this too until both NetworkManager AND gnome-system-tools agree how the interface should be managed.

Description of the problem:
Setting an interface to be manually configured will prevent the interface from being brought up on boot.

Steps to reproduce:
(assuming all your interfaces are initially set to roaming)
1. Left click on nm-applet .
2. Click on "Manual configuration...".
3. Click on Unlock.
4. Type password and click on Authenticate.
5. Select "Wireless connection (wlan0)" and then click on Properties.
6. Untick "Enable roaming mode".
7. Fill in ESSID box, network password (if required) and set the Configuration to "Automatic configuration (DHCP)".
8. Click OK.
9. Click on Close.
10. Reboot the computer.
11. Wait for Ubuntu Hardy to start, log in and start a terminal.
12. Run the following:
host ubuntu.com

Expected results:
Something like:
ubuntu.com has address 91.189.94.158
ubuntu.com mail is handled by 10 mx.canonical.com.
to be shown.

Actual results:
;; connection timed out; no servers could be reached

How reproducible is this problem?
It is reproducible every time.

Additional information:
Doing
ifup wlan0
results in the interface being correctly started. Interfaces could be manually configured in Gutsy and started on boot. If NetworkManager starts configuring manual interfaces too this will probably resolve bug #106508 too.

Version information:
Ubuntu hardy (development branch)
network-manager 0.6.6-0ubuntu5
gnome-system-tools 2.22.0-0ubuntu7

SeRpEnT (superbes) wrote :

Today I've download from here http://cdimage.ubuntulinux.org/daily-live/current/ the lastest image of Hardy...

I've tried from live cd to set the static IP of my router using WIRED connection (that on dapper works very well) but after I had set the IP, the gatway and the mask (the same I have set on dapper) I can't still connect to internet!!!
Don't appare any error windows or similar...

Kjell Braden (afflux) wrote :

Is this bug a duplicate of bug 185854?

Sitsofe Wheeler (sitsofe) wrote :

Kjell:
I believe them to be the same issue but this one was filed back in December...

Kjell Braden (afflux) wrote :

It does not matter which one was filed first but which one has more information and already duplicates. As bug 185854 has already duplicates, I'll mark this one too.

Chow Loong Jin (hyperair) wrote :

They are separate bugs. In this one, the window with the moving bar never goes away. In the other, the progress bar disappears, and all looks fine on the surface, but the /e/n/i file is missing the "auto <iface>" line. This bug is no longer around, but did exist at some point in the past. I'm marking it as fix released.

Changed in network-manager:
status: Confirmed → Fix Released
Chow Loong Jin (hyperair) wrote :

Sorry, I marked the wrong package as fix released. This bug never affected network-manager in the first place. I'm marking it as invalid.

Changed in network-manager:
status: Fix Released → Invalid
Changed in gnome-system-tools:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.