[SRU] WoWLAN settings are not supported

Bug #1781597 reported by Alfonso Sanchez-Beato on 2018-07-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Wishlist
Unassigned
Bionic
Wishlist
Sebastien Bacher
Cosmic
Undecided
Unassigned

Bug Description

[Impact]

WoWLAN lets us wake up the system by sending wake packets over the wifi connection. This is something requested by some OEM projects, for bionic server images.

NM 1.12 supports configuring this feature, so this can be achieved by backporting that support to 1.10 (bionic version). These are the MPs for cosmic and bionic:

https://code.launchpad.net/~alfonsosanchezbeato/network-manager/+git/network-manager/+merge/349468
https://code.launchpad.net/~alfonsosanchezbeato/network-manager/+git/network-manager/+merge/349465

[Test Case]

First, the wifi card must support WoWLAN. This can be checked by running

$ iw phy

and searching for "WoWLAN support:" in the output. If it is supported, with the patch applied a connection configured with wowlan can be created with:

$ sudo nmcli d wifi connect <ssid> password <password>
$ sudo nmcli c modify <ssid> 802-11-wireless.wake-on-wlan 8
$ sudo nmcli c down <ssid>
$ sudo nmcli c up <ssid>

We can check with 'iw' that WoWLAN is active for the connection:

$ iw phy phy0 wowlan show
WoWLAN is enabled:
 * wake up on magic packet

In this case we have configured the connection to wake up the system when a 'magic' packet is received. We can then suspend the system with

$ sudo systemctl suspend

And we should be able to wake the system from another device with the command

$ sudo etherwake -i <wifi_iface> <destination_MAC_address>

[Regression Potential]

Although the patch is not especially small, it is a backport of changes that have been merged upstream, with very little modifications to make it compile in 1.10. It is also a rather isolated feature that should not conflict with existing ones. The feature will be activated only if configured from the command line, so the risk of regressions should be small. Note also that the patch will be removed as soon as Ubuntu moves to NM 1.12.

Related branches

summary: - WoWLAN settings are not supported
+ [SRU] WoWLAN settings are not supported
Tony Espy (awe) on 2018-10-04
Changed in network-manager (Ubuntu):
status: New → Confirmed
Changed in network-manager (Ubuntu):
importance: Undecided → Wishlist
Changed in network-manager (Ubuntu Bionic):
importance: Undecided → Wishlist
status: New → Triaged
Changed in network-manager (Ubuntu):
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

Uploaded to disco and cosmic now, the bionic SRU is coming next

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.12.6-0ubuntu2

---------------
network-manager (1.12.6-0ubuntu2) disco; urgency=medium

  [ Robie Basak ]
  * debian/tests:
    - Make dep8 nm test directly invokable

 -- Sebastien Bacher <email address hidden> Mon, 10 Dec 2018 22:03:01 +0100

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released

Hello Alfonso, or anyone else affected,

Accepted network-manager into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.12.4-1ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

description: updated
Changed in network-manager (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic

Verified on cosmic, using network-manager 1.12.4-1ubuntu1.2:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic

$ apt policy network-manager
network-manager:
  Installed: 1.12.4-1ubuntu1.2
  Candidate: 1.12.4-1ubuntu1.2
  Version table:
 *** 1.12.4-1ubuntu1.2 500
        500 http://es.archive.ubuntu.com/ubuntu cosmic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.12.4-1ubuntu1.1 500
        500 http://es.archive.ubuntu.com/ubuntu cosmic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu cosmic-security/main amd64 Packages
     1.12.4-1ubuntu1 500
        500 http://es.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Łukasz Zemczak (sil2100) wrote :

There is a series of systemd related autopkgtest regressions listed for this upload. At first glance those seem to be unrelated as the test suite is generally flaky, but I'd like someone to take a look at those and double confirm before we release this to the world.

@sil2100, where can I take a look at those?

Iain Lane (laney) wrote :

@alfonsosanchezbeato, linked from https://people.canonical.com/~ubuntu-archive/pending-sru.html

@seb128, assigning you to the bionic task since it sounds like you are going to sponsor it (comment #1) and this is one of the bugs showing as unassigned on rls-bb-tracking, feel free to unassign/find someone else if you won't do this

Changed in network-manager (Ubuntu Bionic):
assignee: nobody → Sebastien Bacher (seb128)
Sebastien Bacher (seb128) wrote :

@Alfonso, the sru page http://people.canonical.com/~ubuntu-archive/pending-sru.html , one log example is
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic/cosmic/amd64/s/systemd/20181219_195906_de75b@/log.gz

The test failing is TEST-22-TMPFILES b ut that doesn't seem to have to do with the n-m SRU since the kmod SRU is showing a similar problem

Łukasz Zemczak (sil2100) wrote :

Ok, then indeed this doesn't likely seem to be any regression. Releasing. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.12.4-1ubuntu1.2

---------------
network-manager (1.12.4-1ubuntu1.2) cosmic; urgency=medium

  [ Alfonso Sanchez-Beato ]
  * Import some WoWLAN patches from the newer stable serie
    (LP: #1781597)

 -- Sebastien Bacher <email address hidden> Mon, 10 Dec 2018 22:19:07 +0100

Changed in network-manager (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for network-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers