Bionic Beaver - not able to connect to WPA Enterprise EAP-TLS

Bug #1761003 reported by Kitsab on 2018-04-03
102
This bug affects 20 people
Affects Status Importance Assigned to Milestone
NetworkManager
Confirmed
Medium
network-manager (Ubuntu)
High
Unassigned

Bug Description

Hello,

since update to Bionic Beaver I can't connect to my WPA2-Entertrise EAP TLS network. Running Freeradius 2.29 on a DDWRT router. In 16.04 it worked, in the dual boot Windows 10 environment it is still working with the same certificates.
It is a hidden network, adding it by "connect to a hidden network" entering SSID, UserID, ca.pem as CA cert, user cert xxx.p12 file and user certificate password.
Tried a lot not getting it working. The password entry dialog for the network is always popping up upon connection trials. The password is for sure the correct one, checked it very often.
If I'm able to I'll attach a syslog and kern.log of error occurense.

Thanks for investigation and inputs.

Best regards

Kitsab

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-control-center 1:3.28.0-0ubuntu6
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Apr 3 23:52:23 2018
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2015-02-14 (1144 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Kitsab (kitsab) wrote :
Kitsab (kitsab) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

affects: gnome-control-center (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
importance: Undecided → High
Kitsab (kitsab) wrote :

Hello,

thank you fro taking care about this, I created a bug report at gnome bugzilla as requested:

https://bugzilla.gnome.org/show_bug.cgi?id=794988

Additional Information:
Maybe the bug reporting tool reported a wrong package, eventually the wpa-supplicant package is causing this issue (not sure).
I've recognized the status info is possibly wrong:UpgradeStatus: No upgrade log present (probably fresh install)
I performed an upgrade from 16.04, and 16.04. was upgraded from 14.04, (and I think 14.04 from 12.04 - not sure)

Best regards

Kitsab

Changed in network-manager (Ubuntu):
status: New → Triaged
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Confirmed
Gabriel (gabrielpoliveira) wrote :

Bug is also happening 18.10

emarkay (mrk) wrote :

Yes, may be related to Bug #1748839 reported by Petr Michalec on 2018-02-12! Almost a year ago!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.