[Dell XPS 9360] NetworkManager fails to detect wifi device in 17.04 Zesty

Bug #1681884 reported by spike speigel on 2017-04-11
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Upon a "clean" upgrade (No software installed except base system from ISO, then upgrade) from 16.04 LTS -> 16.10 -> 17.04 on a Dell 9360, Network Manager fails to detect wiFi device in 17.04 Zesty after a few boots/updates. Wifi works initially. I apply Zesty updates. I autoremoved some packages. I reboot. Wifi is killed. I cannot report the bug using "ubuntu-bug" because I have no network connectivity.

The wifi device was not detected despite re-enabling Dell's Xenial repos after upgrades.

I have a Dell DA200 adapter USB-C to HDMI/VGA/Ethernet/USB 3.0. Plugging ethernet cable into that does not work either. It seemed the adapter was "half" recognized. Something did show up in Network Manager after fiddling with settings, but no network connectivity ever occurred. I can create a separate bug for that if needed.

I subsequently had to revert back to 16.04 LTS with a clean install to report the bug. I'm not so familiar with what the Dell repos provide for Xenial. Do they provide the drivers needed for the wifi? Or is that supplied through the kernel? Could the autoremove have caused the wifi drivers to be removed?

tags: added: latest-bios-1.3.2
summary: - [Dell 9360] NetworkManager fails to detect wifi device in 17.04 Zesty
+ [Dell XPS 9360] NetworkManager fails to detect wifi device in 17.04
+ Zesty
spike speigel (frail-knight) wrote :

Both the onboard wifi and ethernet through the Dell DA200 USB-C adapter work properly in 16.04 LTS running the following kernel:

$ uname -a
Linux blackhole 4.10.0-19-generic #21~16.04.1-Ubuntu SMP Fri Apr 7 08:20:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

spike speigel (frail-knight) wrote :

Could this be the same issue as bug #1676547 ??

macat (attila-maczak) wrote :

I'm experiencing the same issue. Tried to restart NetworkManager, but the applet does not show devices. I was able to get working network connection using a dell ethernet dongle with dhcpclient.

macat (attila-maczak) wrote :

After dpgk purging NetworkManager + reinstalling and rebooting 3 times WiFi networks show up at least. NM still does not manage wired network.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Thomas Hansen (xen-q) wrote :

I've just upgraded to Zesty. Here's what I experienced:

I too lost wifi, but discovered that "sudo modprobe ath10k_pci" would bring it back. I can't remember if it hit me at 16.10 or 17.04 though.

Tonight I thought I'd look into why it didn't load automatically as it used to. I found that the workaround-qca6174-ath10k-delay-load package which comes pre-installed from Dell, contains a /lib/modprobe.d/blacklist-ath10k.conf that blacklists the ath10k_pci module so it wont get loaded when the kernel discovers the hardware.

The package also contains a /lib/systemd/system/ath10k-delay-load.service which sleeps 4 seconds and modprobes the module, and is set to run after the NetworkManager service.

However, when I rebooted in order to try and see what systemd thought of the service just after logging in, wifi came up just as it should have.

I've tried finding some history on workaround-qca6174-ath10k-delay-load, but without much success. I was wondering whether the workaround might have been rendered unnecessary by the latest kernel, but haven't had the nerve to uninstall it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers