[packaging] Missing dnsmasq-base dependency causes wifi hotspot/network sharing feature broken

Bug #1678606 reported by 林博仁(Buo-ren, Lin) on 2017-04-02
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Unassigned
Zesty
High
Unassigned

Bug Description

Impact
=======
In Ubuntu 17.04, the dnsmasq-base dependency has been dropped from network-manager, and the wifi network sharing feature failed to work because of this:

NetworkManager[874]: <error> [1491134643.1581] device (wlp3s0): share: (wlp3s0) failed to start dnsmasq: Could not find "dnsmasq" binary

In my opinion it should at least in Recommends, refer following for related info:

Bug #992411 “network-manager: Please don't Depend on dnsmasq-bas...” : Bugs : network-manager package : Ubuntu
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/992411

This recommends was dropped here:
https://launchpadlibrarian.net/279417634/network-manager_1.2.2-0ubuntu6_1.2.2-0ubuntu7.diff.gz

Test Case
=========
Install the update and ensure that dnsmasq-base is installed (it is a recommends so it should be pulled in automatically by this update).

This test case requires a laptop (or desktop with Wi-Fi hardware) running Ubuntu 17.04 with an ethernet connection to the Internet.

Open a terminal and run journalctl -f

Then open the Settings app (unity-control-center if running Unity, gnome-control-center if running GNOME) and click the Network panel.

Enable the Wi-Fi hotspot.

Use another device to connect to the Wi-Fi hotspot with the Access Point name and the password presented. Use the Internet on the other device.

There should not be any warnings in the journal output in the terminal about "could not find dnsmasq"

Regression Potential
====================

Other Info
==========
This change was agreed upon by the Ubuntu Desktop Team and Martin Pitt who spearheaded the resolved transition for Ubuntu 17.04.

https://irclogs.ubuntu.com/2017/07/25/%23ubuntu-desktop.html#t13:27
(until 14:45)

This drops a diff with Debian because Debian already recommends dnsmasq-base.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: network-manager 1.4.4-1ubuntu3
ProcVersionSignature: Ubuntu 4.10.0-14.16-generic 4.10.3
Uname: Linux 4.10.0-14-generic x86_64
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Sun Apr 2 20:28:25 2017
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2017-03-30 (2 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Beta amd64 (20170321)
IpRoute:
 default via 192.168.1.1 dev enp4s0f2 proto static metric 100
 10.42.0.0/24 dev wlp3s0 proto kernel scope link src 10.42.0.1 metric 600
 169.254.0.0/16 dev wlp3s0 scope link metric 1000
 192.168.1.0/24 dev enp4s0f2 proto kernel scope link src 192.168.1.119 metric 100
NetworkManager.conf:
 [main]
 plugins=ifupdown,keyfile

 [ifupdown]
 managed=false
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
ProcEnviron:
 LANGUAGE=zh_TW:zh
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=zh_TW.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 enp4s0f2 ethernet connected /org/freedesktop/NetworkManager/Devices/1 由 DHCP 伺服器自動配發 IP 地址的網路 66cd739f-4bfd-4cbc-909f-1cd96e9ec8bb /org/freedesktop/NetworkManager/ActiveConnection/8
 wlp3s0 wifi connected /org/freedesktop/NetworkManager/Devices/2 林博仁的模擬 Wi-Fi 網路 2547ce2c-a517-4d31-83a2-4bb38fc704cb /org/freedesktop/NetworkManager/ActiveConnection/14
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/0 -- -- --
nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.4.4 connected started full enabled enabled enabled enabled enabled

tags: added: packaging
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-07-25
Changed in network-manager (Ubuntu):
importance: Undecided → High
Jeremy Bicha (jbicha) on 2017-07-25
summary: - [packaging] Missing dnsmasq-tools dependency causes wifi hotspot/network
+ [packaging] Missing dnsmasq-base dependency causes wifi hotspot/network
sharing feature broken
Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
Jeremy Bicha (jbicha) on 2017-07-26
Changed in network-manager (Ubuntu Zesty):
importance: Undecided → High
status: New → Triaged
Jeremy Bicha (jbicha) on 2017-07-26
Changed in network-manager (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2017-07-26
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.8.2-1ubuntu2

---------------
network-manager (1.8.2-1ubuntu2) artful; urgency=medium

  * Restore dnsmasq-base recommends. This was dropped on switching to
    resolved but is still needed for creating Ad-hoc connections and
    connection sharing. (LP: #1678606)

 -- Jeremy Bicha <email address hidden> Wed, 26 Jul 2017 09:22:49 -0400

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers