No Internet access with default of Automatic (DHCP)

Bug #1654918 reported by Doug McMahon on 2017-01-09
90
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
NetworkManager
Invalid
Undecided
Unassigned
systemd
Fix Released
Undecided
Unassigned
network-manager (Ubuntu)
High
Unassigned

Bug Description

Fresh 17.04 install, wireless router connects without any issue but there is no internet connection/access.
This continues thru disconnecting, reconnecting, rebooting ect, Nothing..

If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses only & manually add Google DNS nameservers: then internet is enabled. screen attached
Note this also affects ethernet, not just wireless
Hardware is:
description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wlp8s0
       version: 73
       serial: xxxxxxxx
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4 latency=0 link=ye s multicast=yes wireless=IEEE 802.11
       resources: irq:32 memory:c2400000-c2401fff

To note: this hardware works perfectly in 14.04 > 16.04
Add. note; issue doesn't arise with 4.11.x kernel

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: network-manager 1.4.2-2ubuntu4
ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
Uname: Linux 4.9.0-11-generic x86_64
ApportVersion: 2.20.4-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Jan 8 22:08:26 2017
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2017-01-09 (0 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170108)
IpRoute:
 default via 192.168.1.1 dev wlp8s0 proto static metric 600
 169.254.0.0/16 dev wlp8s0 scope link metric 1000
 192.168.1.0/24 dev wlp8s0 proto kernel scope link src 192.168.1.4 metric 600
NetworkManager.conf:
 [main]
 plugins=ifupdown,keyfile

 [ifupdown]
 managed=false
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlp8s0 wifi connected /org/freedesktop/NetworkManager/Devices/2 06F21A fb815a75-4091-455e-b73d-2c1f2d97220f /org/freedesktop/NetworkManager/ActiveConnection/0
 enp7s0 ethernet unavailable /org/freedesktop/NetworkManager/Devices/1 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/0 -- -- --
nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.4.2 connected started full enabled enabled enabled enabled enabled

Doug McMahon (mc3man) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, so that's a DNS issue? Do you have libnss-resolve installed? That might have to do with the changes from https://blueprints.launchpad.net/ubuntu/+spec/foundations-y-local-resolver

Changed in network-manager (Ubuntu):
importance: Undecided → High
Paweł Jarosz (paweljaroszit) wrote :

I can confirm this bug on ubuntu 17.04 armhf.

It seems dhcp client doesn't acquire dns adresses when first time connected.
Running dhclient cmd workarounds issue to next reboot.

/etc/resolv.conf contains in my case:

# Generated by NetworkManager
nameserver 127.0.1.1

and after dhclient cmd run:

nameserver 194.204.159.1
nameserver 194.204.152.34

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

The best fix here for Both wireless & ethernet is to set to google nameservers as in attached screen

description: updated
description: updated
Doug McMahon (mc3man) wrote :

Adding linux as also seems resolved using the latest kernel, tested with 4.11.0-041100rc4-generic #201703261831 from mainline

summary: - No Internet access with default of Automatic (DHCP)
+ No Internet access with default of Automatic (DHCP) & current kernel
Doug McMahon (mc3man) on 2017-03-27
description: updated
Doug McMahon (mc3man) wrote :

While much better the 4.11 kernel is reported fail occasionally in this regard. This is in contrast to current kernel in 17.04 (4.10.x) where this happens all the time either right away or after the first reboot or so..

summary: - No Internet access with default of Automatic (DHCP) & current kernel
+ No Internet access with default of Automatic (DHCP)
B@MB@M (bart-bamweb) wrote :

It could also be because of DNSsec. I have seen HTTP working, though HTTPS failing.

When adding the Google nameservers before the default (127.0.0.53, systemd-resolver) everything works as expected.

$ systemd-resolve --status
Global
         DNS Servers: 8.8.8.8
          DNSSEC NTA: 10.in-addr.arpa
                      16.172.in-addr.arpa
                      168.192.in-addr.arpa
                      17.172.in-addr.arpa
                      18.172.in-addr.arpa
                      19.172.in-addr.arpa
                      20.172.in-addr.arpa
                      21.172.in-addr.arpa
                      22.172.in-addr.arpa
                      23.172.in-addr.arpa
                      24.172.in-addr.arpa
                      25.172.in-addr.arpa
                      26.172.in-addr.arpa
                      27.172.in-addr.arpa
                      28.172.in-addr.arpa
                      29.172.in-addr.arpa
                      30.172.in-addr.arpa
                      31.172.in-addr.arpa
                      corp
                      d.f.ip6.arpa
                      home
                      internal
                      intranet
                      lan
                      local
                      private
                      test

Link 2 (enp0s3)
      Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: allow-downgrade
    DNSSEC supported: yes
         DNS Servers: 10.0.2.3

B@MB@M (bart-bamweb) wrote :

$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 8.8.8.8
nameserver 127.0.0.53

David Oser (mirmos192) wrote :

I'm also experiencing this exact bug.
Upgrading from 16.10 to 17.04 did not display the problem, but fresh install of Ubuntu 17.04 does

hrvooje (hrvooje-gmail) wrote :

How can this be unassigned? So important thing like internet connection and bug is from January?

Download full text (3.6 KiB)

Regret to inform that an upgrade from 16.04 is also displaying the bug.
Reduced to using Google DNS on ipv4 (8.8.8.8) in order to work around it
David

On 14 Apr 2017 14:11, "David Oser" <email address hidden> wrote:

I'm also experiencing this exact bug.
Upgrading from 16.10 to 17.04 did not display the problem, but fresh
install of Ubuntu 17.04 does

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1654918

Title:
  No Internet access with default of Automatic (DHCP)

Status in Linux:
  New
Status in NetworkManager:
  New
Status in network-manager package in Ubuntu:
  Confirmed

Bug description:
  Fresh 17.04 install, wireless router connects without any issue but there
is no internet connection/access.
  This continues thru disconnecting, reconnecting, rebooting ect, Nothing..

  If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses
only & manually add Google DNS nameservers: then internet is enabled.
screen attached
  Note this also affects ethernet, not just wireless
  Hardware is:
  description: Wireless interface
         product: Wireless 7260
         vendor: Intel Corporation
         physical id: 0
         bus info: pci@0000:08:00.0
         logical name: wlp8s0
         version: 73
         serial: xxxxxxxx
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress bus_master cap_list ethernet
physical wireless
         configuration: broadcast=yes driver=iwlwifi
driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4
latency=0 link=ye s multicast=yes wireless=IEEE 802.11
         resources: irq:32 memory:c2400000-c2401fff

  To note: this hardware works perfectly in 14.04 > 16.04
  Add. note; issue doesn't arise with 4.11.x kernel

  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: network-manager 1.4.2-2ubuntu4
  ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
  Uname: Linux 4.9.0-11-generic x86_64
  ApportVersion: 2.20.4-0ubuntu1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sun Jan 8 22:08:26 2017
  IfupdownConfig:
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2017-01-09 (0 days ago)
  InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170108)
  IpRoute:
   default via 192.168.1.1 dev wlp8s0 proto static metric 600
   169.254.0.0/16 dev wlp8s0 scope link metric 1000
   192.168.1.0/24 dev wlp8s0 proto kernel scope link src 192.168.1.4
metric 600
  NetworkManager.conf:
   [main]
   plugins=ifupdown,keyfile

   [ifupdown]
   managed=false
  NetworkManager.state:
   [main]
   NetworkingEnabled=true
   WirelessEnabled=true
   WWANEnabled=true
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)
  nmcli-dev:
   DEVICE TYPE STATE DBUS-PATH
  CONNECTION CON-UUID CON-PATH
   wlp8s0 wifi connected /org/freedesktop/NetworkManager/Devices/2
06F21A fb815a75-4091-455e-b73d-2c1f2d97220f /org/freedesktop/
NetworkManager/ActiveConnection/0
   enp7s0 ethernet unavailable /org/freedesktop/Netw...

Read more...

Doug McMahon (mc3man) wrote :

Another 'fix' suggested is to
Open
/etc/NetworkManager/NetworkManager.conf

add lines
[device]
wifi.scan-rand-mac-address=no

then
sudo service network-manager restart

I'm fine with just changing the nameservers as previously mentoned, in any event users shouldn't have to do anything. (even with a limited support period release like 17.04

Doug McMahon (mc3man) wrote :

Noting that above suggestion probably doesn't help ethernet..

David Oser (mirmos192) wrote :
Download full text (4.5 KiB)

Actually there seem to be two related or unrelated issues. One seems to be
purely DNS and the other Network Manager... Dunno. My original issue was
Network Manager. Now ok for no reason i can see. The more sticky one with
my latest upgrade was no problem linking to my WiFi but no internet when
linked. Using Google's 8.8.8.8 address in IPV4 solved that, which seemed to
be caused by resolvconf solutions or workarounds have been posted but turn
out to be temporary fixes that then become unfixed again ... On reboot...
And sometimes even without reboot.
Ho ... Hum...

On 16 Apr 2017 23:35, "Doug McMahon" <email address hidden> wrote:

> Another 'fix' suggested is to
> Open
> /etc/NetworkManager/NetworkManager.conf
>
> add lines
> [device]
> wifi.scan-rand-mac-address=no
>
> then
> sudo service network-manager restart
>
> I'm fine with just changing the nameservers as previously mentoned, in
> any event users shouldn't have to do anything. (even with a limited
> support period release like 17.04
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1654918
>
> Title:
> No Internet access with default of Automatic (DHCP)
>
> Status in Linux:
> New
> Status in NetworkManager:
> New
> Status in network-manager package in Ubuntu:
> Confirmed
>
> Bug description:
> Fresh 17.04 install, wireless router connects without any issue but
> there is no internet connection/access.
> This continues thru disconnecting, reconnecting, rebooting ect, Nothing..
>
> If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses
> only & manually add Google DNS nameservers: then internet is enabled.
> screen attached
> Note this also affects ethernet, not just wireless
> Hardware is:
> description: Wireless interface
> product: Wireless 7260
> vendor: Intel Corporation
> physical id: 0
> bus info: pci@0000:08:00.0
> logical name: wlp8s0
> version: 73
> serial: xxxxxxxx
> width: 64 bits
> clock: 33MHz
> capabilities: pm msi pciexpress bus_master cap_list ethernet
> physical wireless
> configuration: broadcast=yes driver=iwlwifi
> driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4
> latency=0 link=ye s multicast=yes wireless=IEEE 802.11
> resources: irq:32 memory:c2400000-c2401fff
>
> To note: this hardware works perfectly in 14.04 > 16.04
> Add. note; issue doesn't arise with 4.11.x kernel
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.04
> Package: network-manager 1.4.2-2ubuntu4
> ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
> Uname: Linux 4.9.0-11-generic x86_64
> ApportVersion: 2.20.4-0ubuntu1
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sun Jan 8 22:08:26 2017
> IfupdownConfig:
> # interfaces(5) file used by ifup(8) and ifdown(8)
> auto lo
> iface lo inet loopback
> InstallationDate: Installed on 2017-01-09 (0 days ago)
> InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170108)
> IpRoute:
> default via 192.168.1.1 dev wlp8s0 proto static metric 600
> 169.254...

Read more...

harry brijs (harryb-scarlet) wrote :

i installed from iso file
internet is avail upon goodwill of the system
or whatever.
It comes but most of the time it does not stay.
I did not yet correlate this behaviour
2

David Oser (mirmos192) wrote :
Download full text (3.7 KiB)

Yup... Me, I'm reverting back to 16.10
D

On 17 Apr 2017 15:51, "harry brijs" <email address hidden> wrote:

> i installed from iso file
> internet is avail upon goodwill of the system
> or whatever.
> It comes but most of the time it does not stay.
> I did not yet correlate this behaviour
> 2
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1654918
>
> Title:
> No Internet access with default of Automatic (DHCP)
>
> Status in Linux:
> New
> Status in NetworkManager:
> New
> Status in network-manager package in Ubuntu:
> Confirmed
>
> Bug description:
> Fresh 17.04 install, wireless router connects without any issue but
> there is no internet connection/access.
> This continues thru disconnecting, reconnecting, rebooting ect, Nothing..
>
> If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses
> only & manually add Google DNS nameservers: then internet is enabled.
> screen attached
> Note this also affects ethernet, not just wireless
> Hardware is:
> description: Wireless interface
> product: Wireless 7260
> vendor: Intel Corporation
> physical id: 0
> bus info: pci@0000:08:00.0
> logical name: wlp8s0
> version: 73
> serial: xxxxxxxx
> width: 64 bits
> clock: 33MHz
> capabilities: pm msi pciexpress bus_master cap_list ethernet
> physical wireless
> configuration: broadcast=yes driver=iwlwifi
> driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4
> latency=0 link=ye s multicast=yes wireless=IEEE 802.11
> resources: irq:32 memory:c2400000-c2401fff
>
> To note: this hardware works perfectly in 14.04 > 16.04
> Add. note; issue doesn't arise with 4.11.x kernel
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.04
> Package: network-manager 1.4.2-2ubuntu4
> ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
> Uname: Linux 4.9.0-11-generic x86_64
> ApportVersion: 2.20.4-0ubuntu1
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sun Jan 8 22:08:26 2017
> IfupdownConfig:
> # interfaces(5) file used by ifup(8) and ifdown(8)
> auto lo
> iface lo inet loopback
> InstallationDate: Installed on 2017-01-09 (0 days ago)
> InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170108)
> IpRoute:
> default via 192.168.1.1 dev wlp8s0 proto static metric 600
> 169.254.0.0/16 dev wlp8s0 scope link metric 1000
> 192.168.1.0/24 dev wlp8s0 proto kernel scope link src 192.168.1.4
> metric 600
> NetworkManager.conf:
> [main]
> plugins=ifupdown,keyfile
>
> [ifupdown]
> managed=false
> NetworkManager.state:
> [main]
> NetworkingEnabled=true
> WirelessEnabled=true
> WWANEnabled=true
> SourcePackage: network-manager
> UpgradeStatus: No upgrade log present (probably fresh install)
> nmcli-dev:
> DEVICE TYPE STATE DBUS-PATH
> CONNECTION CON-UUID CON-PATH
> wlp8s0 wifi connected /org/freedesktop/NetworkManager/Devices/2
> 06F21A fb815a75-4091-455e-b73d-2c1f2d97220f /org/freedeskto...

Read more...

hrvooje (hrvooje-gmail) wrote :

This morning I got dnsutils and bind9-host updates. Could this be the fix? So far so good, no disconecting last hour.

David Oser (mirmos192) wrote :
Download full text (3.9 KiB)

Fortunately I had retained 17.04 full installation on a USB stick.
Downloaded new update via Google DNS on IPV4, then deleted 8.8.8.8 and
tested. Seems to be working. So far so good.... Thanks for the heads-up
hrvooje!
Best
David

On 18 April 2017 at 07:09, hrvooje <email address hidden> wrote:

> This morning I got dnsutils and bind9-host updates. Could this be the
> fix? So far so good, no disconecting last hour.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1654918
>
> Title:
> No Internet access with default of Automatic (DHCP)
>
> Status in Linux:
> New
> Status in NetworkManager:
> New
> Status in network-manager package in Ubuntu:
> Confirmed
>
> Bug description:
> Fresh 17.04 install, wireless router connects without any issue but
> there is no internet connection/access.
> This continues thru disconnecting, reconnecting, rebooting ect, Nothing..
>
> If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses
> only & manually add Google DNS nameservers: then internet is enabled.
> screen attached
> Note this also affects ethernet, not just wireless
> Hardware is:
> description: Wireless interface
> product: Wireless 7260
> vendor: Intel Corporation
> physical id: 0
> bus info: pci@0000:08:00.0
> logical name: wlp8s0
> version: 73
> serial: xxxxxxxx
> width: 64 bits
> clock: 33MHz
> capabilities: pm msi pciexpress bus_master cap_list ethernet
> physical wireless
> configuration: broadcast=yes driver=iwlwifi
> driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4
> latency=0 link=ye s multicast=yes wireless=IEEE 802.11
> resources: irq:32 memory:c2400000-c2401fff
>
> To note: this hardware works perfectly in 14.04 > 16.04
> Add. note; issue doesn't arise with 4.11.x kernel
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.04
> Package: network-manager 1.4.2-2ubuntu4
> ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
> Uname: Linux 4.9.0-11-generic x86_64
> ApportVersion: 2.20.4-0ubuntu1
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sun Jan 8 22:08:26 2017
> IfupdownConfig:
> # interfaces(5) file used by ifup(8) and ifdown(8)
> auto lo
> iface lo inet loopback
> InstallationDate: Installed on 2017-01-09 (0 days ago)
> InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170108)
> IpRoute:
> default via 192.168.1.1 dev wlp8s0 proto static metric 600
> 169.254.0.0/16 dev wlp8s0 scope link metric 1000
> 192.168.1.0/24 dev wlp8s0 proto kernel scope link src 192.168.1.4
> metric 600
> NetworkManager.conf:
> [main]
> plugins=ifupdown,keyfile
>
> [ifupdown]
> managed=false
> NetworkManager.state:
> [main]
> NetworkingEnabled=true
> WirelessEnabled=true
> WWANEnabled=true
> SourcePackage: network-manager
> UpgradeStatus: No upgrade log present (probably fresh install)
> nmcli-dev:
> DEVICE TYPE STATE DBUS-PATH
> CONNECTION CON-UUID CON-PATH
> wlp8s0 ...

Read more...

David Oser (mirmos192) wrote :
Download full text (4.9 KiB)

On second thoughts, despite 'dnsutils' and 'bind9-host' updates 17.04 is
still buggy on my two Toshiba laptops (one ancient, one less so). Can take
up to three attempts to resolve all repositories with 'sudo apt update'
after boot. Alternatively, on first attempts, browsers (Firefox, Chromium)
do not connect to sites - but then, after a while do so. Bizarre.
Been using Ubuntu since 9.x - never encountered this irritation before. So
it's not because I'm using USB stick installations. However, I am, as ever
using copper wire at 16-20 Mbit/s - but that's never beena problem before...
To actually receive the updates I needed to use the Google DNS 8.8.8.8 on
IPV4 - thereafter deleting this.
I'm now using two (full install, not 'live) USB sticks with 17.04 booting
to them on either laptop - but am holding off upgrading from 16.10 on my
main (newer uefi) machine until the issue is fully resolved.

On 18 April 2017 at 10:22, David Oser <email address hidden> wrote:

> Fortunately I had retained 17.04 full installation on a USB stick.
> Downloaded new update via Google DNS on IPV4, then deleted 8.8.8.8 and
> tested. Seems to be working. So far so good.... Thanks for the heads-up
> hrvooje!
> Best
> David
>
> On 18 April 2017 at 07:09, hrvooje <email address hidden> wrote:
>
>> This morning I got dnsutils and bind9-host updates. Could this be the
>> fix? So far so good, no disconecting last hour.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1654918
>>
>> Title:
>> No Internet access with default of Automatic (DHCP)
>>
>> Status in Linux:
>> New
>> Status in NetworkManager:
>> New
>> Status in network-manager package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> Fresh 17.04 install, wireless router connects without any issue but
>> there is no internet connection/access.
>> This continues thru disconnecting, reconnecting, rebooting ect,
>> Nothing..
>>
>> If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses
>> only & manually add Google DNS nameservers: then internet is enabled.
>> screen attached
>> Note this also affects ethernet, not just wireless
>> Hardware is:
>> description: Wireless interface
>> product: Wireless 7260
>> vendor: Intel Corporation
>> physical id: 0
>> bus info: pci@0000:08:00.0
>> logical name: wlp8s0
>> version: 73
>> serial: xxxxxxxx
>> width: 64 bits
>> clock: 33MHz
>> capabilities: pm msi pciexpress bus_master cap_list ethernet
>> physical wireless
>> configuration: broadcast=yes driver=iwlwifi
>> driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4
>> latency=0 link=ye s multicast=yes wireless=IEEE 802.11
>> resources: irq:32 memory:c2400000-c2401fff
>>
>> To note: this hardware works perfectly in 14.04 > 16.04
>> Add. note; issue doesn't arise with 4.11.x kernel
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 17.04
>> Package: network-manager 1.4.2-2ubuntu4
>> ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
>> Uname: Linux 4.9.0-11-generic x86_64
>> ...

Read more...

hrvooje (hrvooje-gmail) wrote :

All day at work no problems. Neither WiFi or ethernet. At home after a while can't load a website. After restarting service network-manager it works again. It is interesting that in that time torrents download/upload worked and I could ping 8.8.8.8 and other IPs on the Internet. Just couldn't load websites. It is not my broadcom card driver problem, I can access my router.

IrishGuy (colm-bennett) wrote :

Same thing on an upgrade from 16.04 to 17.04. Some internet immediately after the upgrade, same issue as noted above with software updates needing multiple tries to access the repos, currently internet completely dead even with a reboot.

Note this was a Software Updater suggested dist upgrade - I think that should be pulled, 17.04 shouldn't be auto suggesting for users in this state.

Jacek Misiurewicz (jmisiure) wrote :

Ubuntu 17.04 on a Dell E6530, fresh install with copying of some networkmanager setup in /etc/ from good old Ubuntu 16.04.01 LTS and using the same home partition.

My version of this bug is really miraculous. It was here for a week, today disappeared.

For a week I had problems with ONE of the four locations where I connect to the net:
- home-wifi (OK)
- home-cable (OK)
- work-cable (BAD)
- work-wifi (OK).
Problems only with 17.04, 16.04 working flawlessly.

Problem was repeatable - nslookup working until I started firefox. Firefox showing Google home page ONCE, then all requests showing "unavailable", even reloading the home page. Also any later nslookup failing with "REFUSED".

Two days ago I upgraded following to "zesty-proposed", but it did NOT help for yesterday. Maybe it needed time????

Upgraded the following packages:
libnss-resolve (232-21ubuntu2) to 232-21ubuntu3
libpam-systemd (232-21ubuntu2) to 232-21ubuntu3
libsystemd0 (232-21ubuntu2) to 232-21ubuntu3
libsystemd0:i386 (232-21ubuntu2) to 232-21ubuntu3
libudev1 (232-21ubuntu2) to 232-21ubuntu3
systemd (232-21ubuntu2) to 232-21ubuntu3
systemd-sysv (232-21ubuntu2) to 232-21ubuntu3
udev (232-21ubuntu2) to 232-21ubuntu3

Maybe today (Sat) my work net services are less/more overloaded, so DNS query timing is different? I will see again on Mon.

Anyway, strange - it seems that some timing or some combination of circumstances break the local DNS system....

Jacek Misiurewicz (jmisiure) wrote :

Regarding my previous post (#24)...

 Seems that everything is back to abnormal. After logging out and re-logging again bug was back. This time soft disconnecting and reconnecting network (from NManager) helped to regain access to network, but this was not always the remedy.

David Oser (mirmos192) wrote :

Temporary workaround which seems to work most of the time (though,
'timing' - as you are suggesting - sometimes is an issue, requiring a
couple of 'sudo apt update' attempts in Terminal to successfully resolve
all repositories) enter 8.8.8.8 (Google's DNS) into the relevant
'alternate DNS' in IPV4 box. I agree, it is most puzzling how the issue
seems to come and go, despite (eventually) successfully receiving and
deploying all updates to date . I'm still not confident enough to move
from 16.10 to 17.04 on my main machine.
(Sigh...)
David

On 22/04/2017 16:46, Jacek Misiurewicz wrote:
> Regarding my previous post (#24)...
>
> Seems that everything is back to abnormal. After logging out and re-
> logging again bug was back. This time soft disconnecting and
> reconnecting network (from NManager) helped to regain access to network,
> but this was not always the remedy.
>

hrvooje (hrvooje-gmail) wrote :
Download full text (4.8 KiB)

For me:
work-wire OK
work-wifi OK
home-wifi FAIL
I don't use a wire at home so I didn't try

Then I do sudo service network-manager restart and I can surf again. In
that time while I can't sufr the internet I get ping 8.8.8.8 and other
IP's. Torrent dowloading is also working in that time. So, this is
obviously a dns and network-manager issue.

On 22 April 2017 at 19:09, David Oser <email address hidden> wrote:

> Temporary workaround which seems to work most of the time (though,
> 'timing' - as you are suggesting - sometimes is an issue, requiring a
> couple of 'sudo apt update' attempts in Terminal to successfully resolve
> all repositories) enter 8.8.8.8 (Google's DNS) into the relevant
> 'alternate DNS' in IPV4 box. I agree, it is most puzzling how the issue
> seems to come and go, despite (eventually) successfully receiving and
> deploying all updates to date . I'm still not confident enough to move
> from 16.10 to 17.04 on my main machine.
> (Sigh...)
> David
>
> On 22/04/2017 16:46, Jacek Misiurewicz wrote:
> > Regarding my previous post (#24)...
> >
> > Seems that everything is back to abnormal. After logging out and re-
> > logging again bug was back. This time soft disconnecting and
> > reconnecting network (from NManager) helped to regain access to network,
> > but this was not always the remedy.
> >
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1654918
>
> Title:
> No Internet access with default of Automatic (DHCP)
>
> Status in Linux:
> New
> Status in NetworkManager:
> New
> Status in network-manager package in Ubuntu:
> Confirmed
>
> Bug description:
> Fresh 17.04 install, wireless router connects without any issue but
> there is no internet connection/access.
> This continues thru disconnecting, reconnecting, rebooting ect, Nothing..
>
> If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses
> only & manually add Google DNS nameservers: then internet is enabled.
> screen attached
> Note this also affects ethernet, not just wireless
> Hardware is:
> description: Wireless interface
> product: Wireless 7260
> vendor: Intel Corporation
> physical id: 0
> bus info: pci@0000:08:00.0
> logical name: wlp8s0
> version: 73
> serial: xxxxxxxx
> width: 64 bits
> clock: 33MHz
> capabilities: pm msi pciexpress bus_master cap_list ethernet
> physical wireless
> configuration: broadcast=yes driver=iwlwifi
> driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4
> latency=0 link=ye s multicast=yes wireless=IEEE 802.11
> resources: irq:32 memory:c2400000-c2401fff
>
> To note: this hardware works perfectly in 14.04 > 16.04
> Add. note; issue doesn't arise with 4.11.x kernel
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.04
> Package: network-manager 1.4.2-2ubuntu4
> ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
> Uname: Linux 4.9.0-11-generic x86_64
> ApportVersion: 2.20.4-0ubuntu1
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sun Jan 8 22:08:26 2017
> IfupdownC...

Read more...

hrvooje (hrvooje-gmail) wrote :

For me:
work-wire OK
work-wifi OK
home-wifi FAIL
I don't use a wire at home so I didn't try

Then I do sudo service network-manager restart and I can surf again. In that time while I can't sufr the internet I get ping 8.8.8.8 and other IP's. Torrent dowloading is also working in that time. So, this is obviously a dns and network-manager issue.

David Oser (mirmos192) wrote :
Download full text (4.5 KiB)

OK - complete solution/workaround is to be found here... But you must read
the whole lot before doing anything at all because the last edit makes the
first part redundant...
http://www.hecticgeek.com/2017/04/ubuntu-17-04-systemd-dns-issues/
The issue involves systemd within which the developers have turned on some
dns security aspect which had been turned off in earlier versions of
Ubuntu. But the author finds a way for users to keep it turned on but to
solve the problem at the same time via something called 'unbound'.
Anyway - read and try. Worked for me.
Best
David

On 23 April 2017 at 22:57, hrvooje <email address hidden> wrote:

> For me:
> work-wire OK
> work-wifi OK
> home-wifi FAIL
> I don't use a wire at home so I didn't try
>
> Then I do sudo service network-manager restart and I can surf again. In
> that time while I can't sufr the internet I get ping 8.8.8.8 and other
> IP's. Torrent dowloading is also working in that time. So, this is
> obviously a dns and network-manager issue.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1654918
>
> Title:
> No Internet access with default of Automatic (DHCP)
>
> Status in Linux:
> New
> Status in NetworkManager:
> New
> Status in network-manager package in Ubuntu:
> Confirmed
>
> Bug description:
> Fresh 17.04 install, wireless router connects without any issue but
> there is no internet connection/access.
> This continues thru disconnecting, reconnecting, rebooting ect, Nothing..
>
> If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses
> only & manually add Google DNS nameservers: then internet is enabled.
> screen attached
> Note this also affects ethernet, not just wireless
> Hardware is:
> description: Wireless interface
> product: Wireless 7260
> vendor: Intel Corporation
> physical id: 0
> bus info: pci@0000:08:00.0
> logical name: wlp8s0
> version: 73
> serial: xxxxxxxx
> width: 64 bits
> clock: 33MHz
> capabilities: pm msi pciexpress bus_master cap_list ethernet
> physical wireless
> configuration: broadcast=yes driver=iwlwifi
> driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4
> latency=0 link=ye s multicast=yes wireless=IEEE 802.11
> resources: irq:32 memory:c2400000-c2401fff
>
> To note: this hardware works perfectly in 14.04 > 16.04
> Add. note; issue doesn't arise with 4.11.x kernel
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.04
> Package: network-manager 1.4.2-2ubuntu4
> ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
> Uname: Linux 4.9.0-11-generic x86_64
> ApportVersion: 2.20.4-0ubuntu1
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sun Jan 8 22:08:26 2017
> IfupdownConfig:
> # interfaces(5) file used by ifup(8) and ifdown(8)
> auto lo
> iface lo inet loopback
> InstallationDate: Installed on 2017-01-09 (0 days ago)
> InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170108)
> IpRoute:
> default via 192.168.1.1 dev wlp8s0 proto static metric 600
> 169.254...

Read more...

hrvooje (hrvooje-gmail) wrote :

@David I did what you told and it happend to me again. However, my message from sudo systemd-resolved returned REFUSED error with that domain I tried to open. My systemd is 232-21ubuntu3 and when IP address is set to automatic it why it didn't try different one when first refused?

Poettering fixed this here
https://github.com/systemd/systemd/issues/4264

David Oser (mirmos192) wrote :
Download full text (4.3 KiB)

I'm sorry @hrvooje - it worked for me.
But I have now risked upgrading my main laptop from 16.10 to 17.04 and it
appears to be working perfectly without the necessity for tweaks or
workaronds or alternative of 8.8.8.8 , etc, etc. I guess the latest in-situ
upgrade contained its own bugfix.
David

On 24 April 2017 at 18:24, hrvooje <email address hidden> wrote:

> @David I did what you told and it happend to me again. However, my
> message from sudo systemd-resolved returned REFUSED error with that
> domain I tried to open. My systemd is 232-21ubuntu3 and when IP address
> is set to automatic it why it didn't try different one when first
> refused?
>
> Poettering fixed this here
> https://github.com/systemd/systemd/issues/4264
>
> ** Bug watch added: github.com/systemd/systemd/issues #4264
> https://github.com/systemd/systemd/issues/4264
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1654918
>
> Title:
> No Internet access with default of Automatic (DHCP)
>
> Status in Linux:
> New
> Status in NetworkManager:
> New
> Status in network-manager package in Ubuntu:
> Confirmed
>
> Bug description:
> Fresh 17.04 install, wireless router connects without any issue but
> there is no internet connection/access.
> This continues thru disconnecting, reconnecting, rebooting ect, Nothing..
>
> If I edit the connection > IPv4 Settings to Automatic (DCHP) addresses
> only & manually add Google DNS nameservers: then internet is enabled.
> screen attached
> Note this also affects ethernet, not just wireless
> Hardware is:
> description: Wireless interface
> product: Wireless 7260
> vendor: Intel Corporation
> physical id: 0
> bus info: pci@0000:08:00.0
> logical name: wlp8s0
> version: 73
> serial: xxxxxxxx
> width: 64 bits
> clock: 33MHz
> capabilities: pm msi pciexpress bus_master cap_list ethernet
> physical wireless
> configuration: broadcast=yes driver=iwlwifi
> driverversion=4.9.0-11-generic firmware=17.352738.0 ip=192.168.1.4
> latency=0 link=ye s multicast=yes wireless=IEEE 802.11
> resources: irq:32 memory:c2400000-c2401fff
>
> To note: this hardware works perfectly in 14.04 > 16.04
> Add. note; issue doesn't arise with 4.11.x kernel
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.04
> Package: network-manager 1.4.2-2ubuntu4
> ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
> Uname: Linux 4.9.0-11-generic x86_64
> ApportVersion: 2.20.4-0ubuntu1
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Sun Jan 8 22:08:26 2017
> IfupdownConfig:
> # interfaces(5) file used by ifup(8) and ifdown(8)
> auto lo
> iface lo inet loopback
> InstallationDate: Installed on 2017-01-09 (0 days ago)
> InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170108)
> IpRoute:
> default via 192.168.1.1 dev wlp8s0 proto static metric 600
> 169.254.0.0/16 dev wlp8s0 scope link metric 1000
> 192.168.1.0/24 dev wlp8s0 proto kernel scope link src 192.168.1.4
> metric 600
> NetworkManager.conf...

Read more...

Doug McMahon (mc3man) wrote :

This is fixed with updated systemd package so marking as such. The install image is broken but I guess 4+ months wasn't enough time to get it together...

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in linux:
status: New → Invalid
Changed in network-manager:
status: New → Invalid
Changed in systemd:
status: New → Fix Released
Changed in network-manager (Ubuntu):
status: Fix Released → Invalid
Pedro Jimenez (pedrojimenezp) wrote :

I updated my Ubuntu from 16.10 to 17.04 and the network work as expected.

But then I made a fresh install of both systems (Ubuntu 17.04 and Ubuntu Gnome 17.04) and I couldn't connect to the wifi anymore.

However the solution that Doug McMahon on the comment #14 works for me.

Thanks for the fix.

Lubuntu 17.04 is giving me this bug on an Asus EEE 1005HAB netbook, im installing the latest update at the moment, which may fix it. But before the update i could not connect to the internet, we will see if the update fixes it

Latest update has infact fixed the issue for me!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.