network-manager after suspend showing arrow icon instead of wifi icon and showing no wifi networks

Bug #1636282 reported by rjb
212
This bug affects 44 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Unassigned

Bug Description

As requested by Mathieu Trudel-Lapierre (cyphermox) in bug #1589401 I'm creating my own bug report.

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
$ lsb_release -rd
Description: Ubuntu 16.04.1 LTS
Release: 16.04

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
$ apt-cache policy network-manager
network-manager:
  Installiert: 1.2.2-0ubuntu0.16.04.3
  Installationskandidat: 1.2.2-0ubuntu0.16.04.3
  Versionstabelle:
 *** 1.2.2-0ubuntu0.16.04.3 500
        500 http://ch.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.1.93-0ubuntu4 500
        500 http://ch.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

3) What you expected to happen
I'm connected by WiFi only, not by a wired connection. I expect to see the WiFi icon anytime while being connected to my WiFi network. Also, I expect to see all the WiFi networks around me (at least one other network with good reception and about 3 with bad reception).

4) What happened instead
After waking up the laptop from suspend, there appears the ethernet icon (arrow symbols) instead of the WiFi icon.
Also, in this state there are no other WiFi networks visible in the network-manager.
However, the laptop is still connected with my WiFi and the connection works as usual.
Using "service network-manager restart" in the console I can get the wireless icon back and all the other networks around me are visible again.
This can be reproduced anytime and with 100% "success rate". The problem appeared with Ubuntu 16.10 and was persistent since.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: network-manager 1.2.2-0ubuntu0.16.04.3
ProcVersionSignature: Ubuntu 4.4.0-45.66-generic 4.4.21
Uname: Linux 4.4.0-45-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Oct 24 20:06:09 2016
EcryptfsInUse: Yes
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2016-05-15 (161 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
IpRoute:
 default via 192.168.1.1 dev wlo1 proto static metric 600
 169.254.0.0/16 dev wlo1 scope link metric 1000
 192.168.1.0/24 dev wlo1 proto kernel scope link src 192.168.1.244 metric 600
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlo1 wifi connected /org/freedesktop/NetworkManager/Devices/2 WiNet 2 162de978-4466-46b0-957b-5f9c141d702a /org/freedesktop/NetworkManager/ActiveConnection/1
 eno1 ethernet unavailable /org/freedesktop/NetworkManager/Devices/0 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/1 -- -- --
nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.2.2 connected started full enabled enabled enabled enabled enabled

Revision history for this message
rjb (ron-buehler) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Hansen (moteprime) wrote :

I confirm this on buntu 16.04.1 LTS

Lenovo L450 Core i5
Network controller: Intel Corporation Wireless 7265 (rev 59)

network-manager:
  Installed: 1.2.2-0ubuntu0.16.04.3
  Candidate: 1.2.2-0ubuntu0.16.04.3
  Version table:
 *** 1.2.2-0ubuntu0.16.04.3 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.1.93-0ubuntu4 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

After reawakening from suspend nm-applet has crashed show ethernet double arrows instead of nm-applet indicator.
Restarting nm-applet with 'killall nm-applet ; nm-applet' as workaround fixes it.

This bug has been reported twice before, affects more than 100 users but hasn't been fixed and it seems that nobody are working on it.

Revision history for this message
rjb (ron-buehler) wrote :

correction: in my description I was referring to Ubuntu 16.10, however it's 16.04.1 as seen on the lsb_release output.

So I have found some anomaly in this bug:
After a fresh boot, when I suspend the machine, there will be arrows after waking up.
If I do "service network-manager restart" once, I'll get the WiFi icon back. From now on I can suspend as many times I like, the WiFi icon will stay there after wake-up!
However, the next time I reboot all this magic is gone.

Revision history for this message
rjb (ron-buehler) wrote :

After performing some more tests:

The triggers for the network-manager showing the arrow icon and no WiFi networks are:
- Suspend mode (suspend/wake up)
- Hardware wireless button (turn WiFi off/an)
- Wireless network in network-manager GUI (deactivate/activate)
- Network in network-manager GUI (deactivate/activate)

btw: Lock screen has no influence.

When I do "service network-manager restart" once (independent of network-manager state) I'm getting rid of the problem. After this I can do everything listed above without loosing the WiFi icon and I'm always able to see the wireless networks around.

As soon as I do any of this, it's back to default (meaning that next time you do anything of the listed actions above, the arrow icon will appear and you won't be able to see other wireless networks:
- reboot
- shut down and boot
- log out and log in

Again: Lock screen has no influence.

Revision history for this message
Dan Large (dlarge-awesomejar) wrote :

I seeing the same as rjb, when I do the "service network-manager restart" once, I see the WiFi icon return and see nearby WiFi networks as well, however I have some VPNs set up and they don't reappear in network manager. I have to go to System Settings -> Network and turn them on there and then they won't show as "connected" when in fact they are. Very annoying.

Revision history for this message
Hansen (moteprime) wrote :

What happens if you

killall nm-applet
nm-applet

As two different alt+F2 commands ?

Changed in network-manager (Ubuntu):
importance: Undecided → High
Revision history for this message
rjb (ron-buehler) wrote :

@Hansen:
killall nm-applet and then run nm-applet needs to be applied after every suspend or wifi off/on switch while "service network-manager restart" applied once will resolve the problem until the next reboot or logon.

Revision history for this message
Hansen (moteprime) wrote :

@rjb Oh, did understand that difference. thx.

Revision history for this message
guillaume ramelet (guillaume-ramelet) wrote :

I confirm the same with yakkey on DELL XPS 13 developer edition (2015)

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.10
Release: 16.10
Codename: yakkety

LANG=C apt-cache policy network-manager
network-manager:
  Installed: 1.2.4-0ubuntu1
  Candidate: 1.2.4-0ubuntu1
  Version table:
 *** 1.2.4-0ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
        100 /var/lib/dpkg/status

as a temporary work around I put a script here:

/etc/pm/sleep.d/99_restart_network_manager

That contains:

#! /bin/sh

case $1 in
  suspend|suspend_hybrid|hibernate)
  service network-manager restart
  ;;
  resume|thaw)
  # No need to do anything here
  :
  ;;
esac

As said before, it works only once after a suspend.

Paul White (paulw2u)
tags: added: yakkety
Revision history for this message
guillaume ramelet (guillaume-ramelet) wrote :

Unfortunately my workaround doesn't work anymore since 10 days. Looks like the script is not executed anymore when resuming from sleep.

Revision history for this message
Paul Gear (paulgear) wrote :

I'm seeing this on xenial on a Lenovo ThinkPad X230, but not consistently. It only occurs occasionally - most resumes from suspend are fine.

Revision history for this message
Jeremy LaCroix (j-jlacroix) wrote :

I still run into this problem from time to time. On my end, I resolve it by running the following command:

sudo iwlist [wifi interface] scan

Once I did that, it immediately connected.

I'm under the impression that when resuming from suspend, Network Manager isn't automatically scanning for access points.

Revision history for this message
Hansen (moteprime) wrote :

I still run a script to restart nm-applet several times a day. Why are nobody helping us with this?

Revision history for this message
guillaume ramelet (guillaume-ramelet) wrote :

I still have the problem and I have maybe identified a culprit.

in journalctl -xe, I have seen : ● wifi-resume.service loaded failed failed Restart networkmanager at resume

-- L'unité (unit) NetworkManager.service a commencé à démarrer.
janv. 26 19:43:09 XPS kernel: nfs: server newnas not responding, timed out
janv. 26 19:43:15 XPS kernel: nfs: server newnas not responding, timed out
janv. 26 19:43:39 XPS kernel: nfs: server newnas not responding, timed out

Looks like a timeout on my NAS Synology. NFS shares are mounted using autofs. Looks like at resume it tries to reconnect before having the connection ?

Don't know how to fix it. But it may ring a bell for you.

Revision history for this message
rjb (ron-buehler) wrote :

I have several NFS shares mounted as well. I do using fstab.
However I can't find any such messages as you posted.

Revision history for this message
Hansen (moteprime) wrote :

There's a guy on bugzilla that have found out the is he check the option: "All useres may connect to this network", nm-applet doesn't crash upon returning from suspend. I'm testing it now, it look's like it working.

Revision history for this message
guillaume ramelet (guillaume-ramelet) wrote :

I have removed docker (docker.io) and ubuntu-fan and since then I can resume with working wifi.
(so far so good)

will kee you updated if it fails again.

Revision history for this message
guillaume ramelet (guillaume-ramelet) wrote :

After one week, I have not seen this issue anymore.
Looks like solved for me.

Revision history for this message
Dimon2242 (dimon2242) wrote :

I have this problem too on 16.04.2.

Revision history for this message
Ragnar Dunbar (zaroff) wrote :

The problem persists in 16.04.3

Revision history for this message
Ragnar Dunbar (zaroff) wrote :

To kill and start nm-applet after resume does work. The error message after resume, when the arrow (ethernet) symbol is shown, is the following:

(nm-applet:6460): nm-applet-CRITICAL **: get_menu_item_for_ap: assertion 'dup_data.hash != NULL' failed

Revision history for this message
Dimon2242 (dimon2242) wrote :

I fix it on my acer extensa 2510g with custom wifi card (atheros ar9285).
I create /etc/systemd/system/wireless-resume.service contains it (ath9k is my wireless kernel module, replace it with your):
[Unit]
Description=Wireless Resume
After=suspend.target hibernate.target hybrid-sleep.target
#After=hibernate.target
#After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/sbin/modprobe -r ath9k
ExecStart=/sbin/modprobe ath9k

[Install]
WantedBy=suspend.target hibernate.target hybrid-sleep.target
#WantedBy=
#WantedBy=

Revision history for this message
Dimon2242 (dimon2242) wrote :

After needs "sudo systemctl enable wireless-resume.service" for enable this.

Revision history for this message
rjb (ron-buehler) wrote :

This bug is solved in 18.04 LTS.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for the update, closing!

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers