from alternate lubuntu installs network manager does not manage devices or give network info

Bug #1617063 reported by Lyn Perrine
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce on an alternate install complete the install with ethernet plugged in and boot into the new install and log into to the lubuntu desktop and move over to the nm-applet and notice it says that your ethernet device is not managed and showing connectoin information fails

 Description: Ubuntu Yakkety Yak (development branch)
Release: 16.10
network-manager:
  Installed: 1.2.2-0ubuntu8
  Candidate: 1.2.2-0ubuntu8
  Version table:
 *** 1.2.2-0ubuntu8 500
        500 http://us.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
        100 /var/lib/dpkg/status
I expected to be able to show connection info in network manager and connect disconnet to ethernet with this network manager with software.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: network-manager 1.2.2-0ubuntu8
ProcVersionSignature: Ubuntu 4.4.0-9134.53-generic 4.4.15
Uname: Linux 4.4.0-9134-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: LXDE
Date: Thu Aug 25 14:11:11 2016
InstallationDate: Installed on 2016-08-25 (0 days ago)
InstallationMedia: Lubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160825.1)
IpRoute:
 default via 192.168.122.1 dev ens3
 192.168.122.0/24 dev ens3 proto kernel scope link src 192.168.122.84
IwConfig:
 lo no wireless extensions.

 ens3 no wireless extensions.
NetworkManager.conf:
 [main]
 plugins=ifupdown,keyfile,ofono

 [ifupdown]
 managed=false
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
RfKill:

SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT AUTOCONNECT-PRIORITY READONLY DBUS-PATH ACTIVE DEVICE STATE ACTIVE-PATH
 Wired connection 1 f8fb3e0c-4ddc-4d20-9585-954d34538369 802-3-ethernet 0 never yes 0 no /org/freedesktop/NetworkManager/Settings/0 no -- -- --
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 ens3 ethernet unmanaged /org/freedesktop/NetworkManager/Devices/0 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/1 -- -- --
nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.2.2 connected started none enabled enabled enabled enabled enabled

Revision history for this message
Lyn Perrine (walterorlin) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1617063

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Udara Madubhashana (udara) wrote :

Seems like this problem with network manager applet

I think this fixes the network manager applet

sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf

Try this and Reboot :)

Revision history for this message
sudodus (nio-wiklund) wrote :

Hi Brendan,

Is this really a a duplicate of bug #1616400? I guess you can check, if the bug has been squashed. If it is still alive, it is a separate bug.

I suspect it is still alive, but you wrote the bug report, so please check if the bug you reported is still there.

Revision history for this message
Lyn Perrine (walterorlin) wrote : Re: [Bug 1617063] Re: from alternate lubuntu installs network manager does not manage devices or give network info
Download full text (3.9 KiB)

On Mon, 12 Sep 2016 06:08:47 -0000
sudodus <email address hidden> wrote:

> *** This bug is a duplicate of bug 1616400 ***
> https://bugs.launchpad.net/bugs/1616400
>
> Hi Brendan,
>
> Is this really a a duplicate of bug #1616400? I guess you can check, if
> the bug has been squashed. If it is still alive, it is a separate bug.
>
> I suspect it is still alive, but you wrote the bug report, so please
> check if the bug you reported is still there.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1617063
>
> Title:
> from alternate lubuntu installs network manager does not manage
> devices or give network info
>
> Status in network-manager package in Ubuntu:
> Confirmed
>
> Bug description:
> To reproduce on an alternate install complete the install with
> ethernet plugged in and boot into the new install and log into to the
> lubuntu desktop and move over to the nm-applet and notice it says that
> your ethernet device is not managed and showing connectoin information
> fails
>
> Description: Ubuntu Yakkety Yak (development branch)
> Release: 16.10
> network-manager:
> Installed: 1.2.2-0ubuntu8
> Candidate: 1.2.2-0ubuntu8
> Version table:
> *** 1.2.2-0ubuntu8 500
> 500 http://us.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
> 100 /var/lib/dpkg/status
> I expected to be able to show connection info in network manager and connect disconnet to ethernet with this network manager with software.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.10
> Package: network-manager 1.2.2-0ubuntu8
> ProcVersionSignature: Ubuntu 4.4.0-9134.53-generic 4.4.15
> Uname: Linux 4.4.0-9134-generic x86_64
> ApportVersion: 2.20.3-0ubuntu7
> Architecture: amd64
> CurrentDesktop: LXDE
> Date: Thu Aug 25 14:11:11 2016
> InstallationDate: Installed on 2016-08-25 (0 days ago)
> InstallationMedia: Lubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160825.1)
> IpRoute:
> default via 192.168.122.1 dev ens3
> 192.168.122.0/24 dev ens3 proto kernel scope link src 192.168.122.84
> IwConfig:
> lo no wireless extensions.
> I arrive at a red screen with the text: "No network interfaces were found ..."

> ens3 no wireless extensions.
> NetworkManager.conf:
> [main]
> plugins=ifupdown,keyfile,ofono
>
> [ifupdown]
> managed=false
> NetworkManager.state:
> [main]
> NetworkingEnabled=true
> WirelessEnabled=true
> WWANEnabled=true
> RfKill:
>
> SourcePackage: network-manager
> UpgradeStatus: No upgrade log present (probably fresh install)
> nmcli-con:
> NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT AUTOCONNECT-PRIORITY READONLY DBUS-PATH ACTIVE DEVICE STATE ACTIVE-PATH
> Wired connection 1 f8fb3e0c-4ddc-4d20-9585-954d34538369 802-3-ethernet 0 never yes 0 no /org/freedesktop/NetworkManager/Settings/0 no -- -- --
> nmcli-dev:
> DEVICE TYPE S...

Read more...

Revision history for this message
sudodus (nio-wiklund) wrote :

> Actually it went away with the fix of the master bug of the networking for beta 1.

That's great :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers