NetworkManager looking for signal strength in 'wlan0' instead of the apropriate 'wlxc46e1f1abe34"

Bug #1594814 reported by Set Hallstrom on 2016-06-21
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Low
network-manager (Ubuntu)
Low
Unassigned

Bug Description

I get this error in my log a lot:
"Jun 21 15:04:00 basspistol NetworkManager[834]: <warn> [1466514240.9769] (wlan0): error getting signal strength: No such device"

My wireless device (TP-Link 150Mbps Wireless N Nano USB Adapter) is getting a very funky name: "wlxc46e1f1abe34". It's not too much of a problem since the connection is established and working, but it renders the wifi-strength icon as if it was receiving maximum signal strength.

Restarting the network-manager with: "sudo systemctl restart network-manager.service" solves the problem.

Not sure if it is related, but i am also affected by this bug:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1589401
Even after upgrading to: network-manager-gnome:amd64 (1.2.0-0ubuntu0.16.04.1, 1.2.0-0ubuntu0.16.04.3) on 2016-06-19

Let me know if there is any complementary information i can provide.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: network-manager 1.2.0-0ubuntu0.16.04.2
ProcVersionSignature: Ubuntu 4.4.0-24.43-lowlatency 4.4.10
Uname: Linux 4.4.0-24-lowlatency x86_64
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Jun 21 15:04:46 2016
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2016-04-21 (60 days ago)
InstallationMedia: Ubuntu-Studio 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
IpRoute:
 default via 10.42.0.1 dev wlxc46e1f1abe34 proto static metric 600
 10.42.0.0/24 dev wlxc46e1f1abe34 proto kernel scope link src 10.42.0.22 metric 600
 169.254.0.0/16 dev wlxc46e1f1abe34 scope link metric 1000
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
RfKill:

SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlxc46e1f1abe34 wifi connected /org/freedesktop/NetworkManager/Devices/0 sakrecoer 1 7bfae379-b282-4335-8bfe-f1f55229ad51 /org/freedesktop/NetworkManager/ActiveConnection/0
 enp3s0 ethernet unavailable /org/freedesktop/NetworkManager/Devices/1 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/2 -- -- --
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

Set Hallstrom (sakrecoer) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in network-manager (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed

Can you clarify to whom/where exactly the bug should be reported?
I'm experiencing the exact same issue.

This problem occurred on my system (with NetworkManager) after an update.

I solved it by changing a parameter in the configuration file.

In file:

NetworkManager.conf (/etc)

under [main] change:

dhcp=dhclient

to

dhcp=internal

It seems that systemd does not longer correctly configure dhcclient.

Sebastien Bacher (seb128) wrote :

@Jhonny, on http://bugzilla.gnome.org see the previous comment for details

Changed in network-manager:
importance: Unknown → Low
status: Unknown → Incomplete
Changed in network-manager:
status: Incomplete → Confirmed
Changed in network-manager:
status: Confirmed → Fix Released
Craig Furman (craigfurman) wrote :

It seems like a fix was released for NetworkManager a few months ago, when can we expect it to be released into the Ubuntu repositories?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.