Unable to establish DSL connection

Bug #1586409 reported by Adam Basfop Cavendish on 2016-05-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Environment: Ubuntu 16.04

Reproduce the bug:

    Connect to my DSL connection (configuration the same as what it was like in Ubuntu 14.04), failed

Collecting Debug Information:

    # Start NetworkManager in DEBUG mode
    sudo systemctl mask NetworkManager.service
    sudo systemctl stop NetworkManager.service
    sudo NM_PPP_DEBUG=1 /usr/sbin/NetworkManager --no-daemon

    # Connect to your DSL via NetworkManager GUI

    # Debug Information shown here:
    Plugin rp-pppoe.so loaded.
    Plugin /usr/lib/pppd/2.4.7/nm-pppd-plugin.so loaded.
    nm-pppd-plugin-Message: nm-ppp-plugin: (plugin_init): initializing
    nm-pppd-plugin-Message: nm-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection'
    Send PPPOE Discovery V1T1 PADI session 0x0 length 12
     dst ff:ff:ff:ff:ff:ff src 5c:f9:dd:5f:86:04
     [service-name] [host-uniq 31 6f 00 00]
    Recv PPPOE Discovery V1T1 PADO session 0x0 length 40
     dst 5c:f9:dd:5f:86:04 src ac:4e:91:64:55:d3
     [service-name] [host-uniq 31 6f 00 00] [AC-name SH-SH-FT-BAS-1.MAN.ME60X]
    Send PPPOE Discovery V1T1 PADR session 0x0 length 12
     dst ac:4e:91:64:55:d3 src 5c:f9:dd:5f:86:04
     [service-name] [host-uniq 31 6f 00 00]
    Recv PPPOE Discovery V1T1 PADS session 0x5894 length 12
     dst 5c:f9:dd:5f:86:04 src ac:4e:91:64:55:d3
     [service-name] [host-uniq 31 6f 00 00]
    PADS: Service-Name: ''
    PPP session is 22676
    Connected to ac:4e:91:64:55:d3 via interface enp3s0
    using channel 9
    Using interface ppp0
    Connect: ppp0 <--> enp3s0
    nm-pppd-plugin-Message: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
    sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xd5cccece>]
    rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0xd5cccece>]
    sent [LCP ConfReq id=0x1 <mru 1492> <magic 0xd5cccece>]
    rcvd [LCP ConfReq id=0x2 <mru 1492> <auth pap> <magic 0x9cf8645d>]
    sent [LCP ConfAck id=0x2 <mru 1492> <auth pap> <magic 0x9cf8645d>]
    rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0xd5cccece>]
    sent [LCP EchoReq id=0x0 magic=0xd5cccece]
    nm-pppd-plugin-Message: nm-ppp-plugin: (nm_phasechange): status 6 / phase 'authenticate'
    nm-pppd-plugin-Message: nm-ppp-plugin: (get_credentials): passwd-hook, requesting credentials...

    (process:28465): nm-pppd-plugin-WARNING **: nm-ppp-plugin: (get_credentials): could not get secrets: GDBus.Error:org.freedesktop.NetworkManager.Settings.Failed: The connection was modified since activation
    sent [PAP AuthReq id=0x1 user="11122057@shu" password=<hidden>]
    rcvd [LCP EchoRep id=0x0 magic=0x9cf8645d]
    sent [PAP AuthReq id=0x2 user="11122057@shu" password=<hidden>]
    sent [PAP AuthReq id=0x3 user="11122057@shu" password=<hidden>]
    sent [PAP AuthReq id=0x4 user="11122057@shu" password=<hidden>]
    sent [PAP AuthReq id=0x5 user="11122057@shu" password=<hidden>]
    sent [PAP AuthReq id=0x6 user="11122057@shu" password=<hidden>]
    rcvd [PAP AuthNak id=0x6 "No response"]
    Remote message: No response
    PAP authentication failed
    nm-pppd-plugin-Message: nm-ppp-plugin: (nm_phasechange): status 10 / phase 'terminate'
    nm-pppd-plugin-Message: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
    sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]
    rcvd [LCP TermReq id=0x3]
    sent [LCP TermAck id=0x3]
    Modem hangup
    nm-pppd-plugin-Message: nm-ppp-plugin: (nm_phasechange): status 11 / phase 'disconnect'
    Connection terminated.
    Failed to disconnect PPPoE socket: 114 Operation already in progress
    nm-pppd-plugin-Message: nm-ppp-plugin: (nm_phasechange): status 1 / phase 'dead'
    nm-pppd-plugin-Message: nm-ppp-plugin: (nm_exit_notify): cleaning up

    # clean up
    sudo systemctl unmask NetworkManager.service
    sudo systemctl restart NetworkManager.service

Helpful links: https://bugzilla.redhat.com/show_bug.cgi?id=1324895

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions