[SRU]bug report script uses invalid nm options

Bug #1582803 reported by Sebastien Bacher on 2016-05-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Aron Xu
Xenial
Undecided
Unassigned

Bug Description

[Impact]
Xenial reports have those warnings "Error: Object 'nm' is unknown, try 'nmcli help'." the "nm-cli" syntax changed and the hook needs to be updated

[Test Case]
Future apport report to errors.ubuntu.com should have proper information output from nmcli command, rather than throwing an error message.

[Regression Potential]
This is a simple change of the command line option on information collection, which should be safe.

Aron Xu (happyaron) on 2016-06-23
tags: added: desktop-trello-import
Aron Xu (happyaron) on 2016-06-28
Changed in network-manager (Ubuntu):
importance: Low → Medium
status: New → In Progress
Aron Xu (happyaron) on 2016-07-05
Changed in network-manager (Ubuntu):
status: In Progress → Triaged
summary: - bug report script uses invalid nm options
+ [SRU]bug report script uses invalid nm options
description: updated
Aron Xu (happyaron) on 2016-07-05
Changed in network-manager (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Please fix this in yakkety first, as per SRU rules.

Aron Xu (happyaron) wrote :

@pitti, it's committed to git, needs an upload.

Hello Sebastien, or anyone else affected,

Accepted network-manager into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.2.0-0ubuntu0.16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu):
status: In Progress → Fix Committed
Changed in network-manager (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Aron Xu (happyaron) wrote :

This works for me, marking as verification-done.

tags: added: verification-done xenial
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.2.0-0ubuntu0.16.04.3

---------------
network-manager (1.2.0-0ubuntu0.16.04.3) xenial; urgency=medium

  * cli-initialize-connection-list-in-do_device_connect.patch:
    Make sure connection list available for nmc_secrets_requested().
    (LP: #1595707).
  * Removing default_powersave_on.patch, and instead install config
    file that accomplishes the same (LP: #1557026)
  * Fix invalid nmcli option in bug report script
    debian/source_network-manager.py (LP: #1582803)

 -- Aron Xu <email address hidden> Tue, 05 Jul 2016 16:01:03 +0800

Changed in network-manager (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for network-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.2.2-0ubuntu7

---------------
network-manager (1.2.2-0ubuntu7) yakkety; urgency=medium

  [ Martin Pitt ]
  * debian/NetworkManager.conf: Re-Drop "dns=dnsmasq" option again, resolved
    now does DNS requests on port 53 so that chrome and other NSS deniers
    work.
  * debian/network-manager.postinst: Fix conf.d path with mkdir.
  * Make /run/NetworkManager/conf.d/* files override corresponding ones in
    /usr/lib/. (LP: #1614043)
  * Move libgnutls-dev build dependency (which does not exist any more) to
    libgnutls28-dev.

  [ Aron Xu ]
  * Fix invalid nmcli options in bug report script (LP: #1582803)

 -- Martin Pitt <email address hidden> Wed, 17 Aug 2016 12:55:29 +0200

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers