[touch] Mobile data connection drops, and doesn't automatically reconnect

Bug #1579098 reported by Andrea Bernabei
150
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
John McAleely
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Krillin, rc-proposed, r325

In the last couple of weeks it often happened that the mobile data connection dropped without reconnecting afterwards. I often find my device without mobile data connection without apparent reason.

Switching mobile data connection Off and back On from settings restores the connection.

I don't have any useful additional info to provide, unfortunately.
Please let me know if you need log/cmd output in particular.

phablet@ubuntu-phablet:~$ nmcli d status
DEVICE TYPE STATE CONNECTION
ril_1 gsm disconnected --
wlan0 wifi disconnected --
ril_0 gsm unavailable --
ifb0 ifb unmanaged --
ifb1 ifb unmanaged --
ip6tnl0 ip6tnl unmanaged --
sit0 iptunnel unmanaged --
lo loopback unmanaged --
tunl0 unknown unmanaged --

Syslog since last time mobile data was connected:
http://pastebin.ubuntu.com/16259803/

Revision history for this message
Andrea Bernabei (faenil) wrote :
Revision history for this message
Alfonso Sanchez-Beato (alfonsosanchezbeato) wrote :

Taking a look at output of ofono scripts it seems all is good on that side: the modem is attached but the context has not been activated by NM.

Revision history for this message
Andrea Bernabei (faenil) wrote :

info: the logs were taken while the bug was "active". And it still is :)

summary: - Mobile data connection drops, and doesn't automatically reconnect
+ [touch] Mobile data connection drops, and doesn't automatically
+ reconnect
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

This sounds like the symptom I described on bug #1565717

Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
importance: Undecided → High
status: New → Confirmed
importance: High → Critical
milestone: none → 12
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
John McAleely (john.mcaleely) wrote :

@faenil - I think I read on IRC that your machine lacks MAC addresses and so forth, for $reasons. Can you confirm this bug on a stock device?

Revision history for this message
Andrea Bernabei (faenil) wrote :

@John: IMEIs and MACs are correct, now.

(And the bug was there before the inconvenience happened)

Revision history for this message
Tony Espy (awe) wrote :

I'm able to reproduce this on arale ( rc-proposed, 334 ) by either toggling cellular technology ( 2/3g -> 2g only, and back ), or by putting the device into a faraday cage.

This is partially a regression in 1.1.93 ( we dropped a related patch ), and partially a day-one problem.

I have what looks to be a promising fix, but would like to discuss with upstream before I land it in the silo.

tags: added: hotfix
Tony Espy (awe)
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
tags: added: bq-feedback
Revision history for this message
Tomas Öqvist (tomoqv) wrote :

I experience this frequently on the Pro 5 as well. Sometimes when I pull down indicator for mobile it shows 3G or 4G, but shows no connection on the top indicator bar (see attached image).

Revision history for this message
Roascio Paolo (roa) wrote :

The same Tomas reported occurs also in krillin after OTA11

Revision history for this message
Mateo Salta (mateo-salta) wrote :

Happens at work all the time, I work in a fridge, while in my pocket it should loose connection time to time because of the area. But then comming outside at lunch it has stopped trying to connect - must toghle airplane mode to get it to try again.

Can we have a retry connection triggered on unlocking the phone, if the device gave up trying to connect?

Revision history for this message
Mateo Salta (mateo-salta) wrote :

I'm on mx4 ota11.

Revision history for this message
Jos van Houtem (jos-vh67) wrote :

Same problem here. But Iwant to add that when I switch off Mobile data (at night) and in the morning to "on" again, I have to switch it once more "off" and "on" to connect again (OTA-11 on E4.5).

tags: added: lt-blocker
Tony Espy (awe)
Changed in network-manager (Ubuntu):
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Revision history for this message
Piotr Mitana (pmitana) wrote :

Has this bug actually been fixed properly?

On Meizu Pro 5 with OTA-14 I still experiencing mobile data connection drops and the "indicator schizofrenic" very often. Am I the only one?

Revision history for this message
Tomas Öqvist (tomoqv) wrote :

You are not the only one. I have no idea what was actually fixed and released regarding this bug, because nothing has changed for me. My Pro 5 has serious issues with both mobile data and wifi. It seems it can't reconnect properly once a signal is lost. I probably toggle airplane mode 5-10 times a day to reconnect. Indicator comes and goes and doesn't seem to have much to do with the actual data connection of my phone.

One thing I wonder though is if this problem is more common on the Pro 5 than on other devices and if it is related to which operator or cellular network you are on. I did a quick poll on G+ (https://plus.google.com/107122765209471240742/posts/9ESqWr35RSs?sfc=true) to see how many users had frequent connection problems. It turned out that about 50% of users have no issues whatsoever with mobile data or wifi. Only 5% had frequent mobile data connection issues, so that can explain the low priority to this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers