Oem install end user has no wifi

Bug #1572956 reported by Dave Morley on 2016-04-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

STEPS:
1. On a wifi enable laptop (Intel in this case) install the current final iso in oem mode
2. Note wifi can connect in the oem installer pages
3. Reboot into the OEM installed desktop session
4. Again note that wifi ap are shown as available (/!\ do not connect to one)
5. Double click on the setup for end user
6. Add the oem password
7. Reboot
8. In End user setup note that AP are available (/!\ again do not connect to one)
9. Complete the end user setup
10. Login to the enduser session
11. Note No wifi available.

EXPECTED:
Wifi to be available for the enduser

ACTUAL:
Wifi is available at all points until the end user desktop session is available. On reboot of the machine wifi is then functioning as normal. Just not in the initial user session.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: network-manager 1.1.93-0ubuntu4
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Apr 21 11:40:03 2016
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2016-04-21 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
IpRoute:
 default via 192.168.1.1 dev wlp3s0 proto static metric 600
 169.254.0.0/16 dev wlp3s0 scope link metric 1000
 192.168.1.0/24 dev wlp3s0 proto kernel scope link src 192.168.1.190 metric 600
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT AUTOCONNECT-PRIORITY READONLY DBUS-PATH ACTIVE DEVICE STATE ACTIVE-PATH
 davmor2 8ecce479-2ed4-4515-b217-c916cb3ac4f8 802-11-wireless 1461235193 Thu 21 Apr 2016 11:39:53 BST yes 0 no /org/freedesktop/NetworkManager/Settings/1 yes wlp3s0 activated /org/freedesktop/NetworkManager/ActiveConnection/0
 Wired connection 1 474b3c4e-4775-4c34-b405-f2e7bd359117 802-3-ethernet 1461235118 Thu 21 Apr 2016 11:38:38 BST yes 4294966297 no /org/freedesktop/NetworkManager/Settings/0 no -- -- --
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlp3s0 wifi connected /org/freedesktop/NetworkManager/Devices/2 davmor2 8ecce479-2ed4-4515-b217-c916cb3ac4f8 /org/freedesktop/NetworkManager/ActiveConnection/0
 enp2s0 ethernet unavailable /org/freedesktop/NetworkManager/Devices/0 -- -- --
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/1 -- -- --
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1572956

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed

Pretty sure we fixed this in the last-minute ubiquity uploads for xenial which re-added nm-applet and the network wizard panel.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers