VPN split DNS gets broken after suspend/resume

Bug #1553885 reported by kolya on 2016-03-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetworkManager
Incomplete
Medium
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I've got a company's VPN server I connect to. When I connect to it I get several DNS entries for split DNS configuration and this works fine.

After suspend/resume cycle I reconnect to VPN and see those split DNS entries added along with entries for VPN's DNS servers that do not have domain attached to it (i.e. not split). Disconnecting and reconnecting to VPN doesn't solve the problem: those non split entries gets stuck until I restart NetworkManager.

I'll attach the patch that addresses the problem.

Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Confirmed

The attachment "0001-Remove-dns-VPN-DEVICE-DNS-config-before-adding-diffe.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in network-manager:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.